PDA

View Full Version : Had to install DBI and UNIVERSAL::moniker for todays nightly?



Jeffrey Gordon
2004-12-12, 09:00
So I have been running the latest nightly for awhile now on my Linux
box. Today I noticed that slimserver failed to start complaining it
needed the DBI and UNIVERSAL::moniker modules. So I installed them,
however what has changed in slimserver that required these two modules?


-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.1 (MingW32)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org

iD8DBQFBvGs3H0fQtyBJLGwRAqzIAJ9RKIqPkhWJCyjZWVt6GW vNkM0dVQCgwAju
znsQpEwkz1elEKjb/Ztx9qk=
=db05
-----END PGP SIGNATURE-----

Laurent Perez
2004-12-12, 11:23
U:moniker makes it more easy to to declare variables out of classes
name, and DBI is the de-facto database interface layer for perl, so I
would say latest nightly now runs an embedded database, and has a
quite readable code ?

kdf
2004-12-12, 12:38
Quoting Jeffrey Gordon <jeff (AT) thetank (DOT) org>:

> So I have been running the latest nightly for awhile now on my Linux
> box. Today I noticed that slimserver failed to start complaining it
> needed the DBI and UNIVERSAL::moniker modules. So I installed them,
> however what has changed in slimserver that required these two modules?
>
>


SQL. please read posts in the archive regarding "Change to Nightly Builds",
posted here Dec 4 or this page:
http://www.slimdevices.com/dev_nightly.html

If you dont want to run these, now 'unstable', builds please download from
5.4.1 stable builds.

-kdf