PDA

View Full Version : Port 9000 blocked



TheLastMan
2015-05-29, 12:05
Hi folks. I am trying to connect remotely from work to my LMS server on my home network which uses the port 9000. However, most outgoing ports are blocked here. Is there any way round this?

pinkdot
2015-05-29, 12:09
Find a port that isn't blocked? And set in settings-> advanced-> network

TheLastMan
2015-05-29, 12:24
Find a port that isn't blocked?
They all seem to be blocked! (other than 80 and 8080). Rather than test the whole range of 60,000 odd, do you know any likely candidates that might be open that my router won't be needing?
Thanks!

Roland0
2015-05-29, 13:22
You can use 8080, then. However, make sure your LMS server is actually reachable from outside your home network (in most home setups, it isn't)
Additionally, note that port 9000 is for the web interface - if you want to stream audio, you'll need another port

DJanGo
2015-05-29, 13:45
Hmmm...

i would ask the guy who is responsible for the office Network!

If you got 20 people in the office and half of them are using something like a radiostream @ work then nobody can use the Net....

I remember when 20 guys (mostly woman) checked the cool sidebarticker on Windows 7 and after that cool weather and picture screensh00tshit from <20 Users....

Mnyb
2015-05-29, 23:42
Just remember that in the simple unsafe way of doing this, you must portforward 9000 tcp and 3483 udp/tcp in the router .

Forum members doing this regularly are using vpn tunnelling instead .

I've done this the unsafe way on occasion , but I accessed my router from outside and only turned on this just for the listening session . And my music server is only a music server it contains no personal data of any kind .

philippe_44
2015-05-29, 23:54
Hi folks. I am trying to connect remotely from work to my LMS server on my home network which uses the port 9000. However, most outgoing ports are blocked here. Is there any way round this?

You can create a SSH tunnel to your home using port 443. Then you forward local port 9000 and 3483 to your LMS server at home. Bitvise does that easily on both end, client and server (no UDP forwarding, so client on the 'work' side of the tunnel cannot discover the LMS server, just need to manually configure them). This is safe but as said by some others, this is not a good practice to do that from the office though

TheLastMan
2015-06-01, 11:26
You can use 8080, then. However, make sure your LMS server is actually reachable from outside your home network (in most home setups, it isn't)
Additionally, note that port 9000 is for the web interface - if you want to stream audio, you'll need another port
I already do access LMS remotely via internet connections, just not from work where the outgoing ports are blocked. Port 80 is forwarded to my NAS web interface and 8080 is forwarded to my router's web interface. I was hoping there might be other commonly open ports that I might use.

This is not for streaming, just for occasional monitoring, setting up playlists for later use, updating plugins and so on. Probably about half an hour a month!

My work laptop is locked down so I cannot install any software on it - which probably puts a VPN out of the question.

This is not a major problem so if it is not easily fixed I won't worry too much.

If I want to listen to music at work, as I am in an open plan office, it has to be done on headphones. In which case I just use my phone which has a 128GB micro SDXC with all my music as 320 kbps MP3 files on it.

Atlantic
2015-06-01, 12:21
I already do access LMS remotely via internet connections, just not from work where the outgoing ports are blocked. Port 80 is forwarded to my NAS web interface and 8080 is forwarded to my router's web interface. I was hoping there might be other commonly open ports that I might use.

This is not for streaming, just for occasional monitoring, setting up playlists for later use, updating plugins and so on. Probably about half an hour a month!



So, if you only need to access your LMS Web UI, you can do that from your work computer's browser, using port 443. Port 443 will not be blocked.

eg: http://[your url if you have a suitable DNS record, or your IP address]:443

You will ALSO need to set up your router at your home to forward port 443 onto [your LMS server's IP address], port 9000 .

regards, Atlantic

DJanGo
2015-06-01, 18:25
Puh


i do have some websites and want to know if someone finds my content so i decided to add a show me the visitors gimmick in two of them.

After some time i want to know what kind of content the visitors of my website(s) prefer computerstuff, musicstuff or homebrewstuff so i changed my visitor gimmick not only to show me the visitors also show me which sites they look after.

After that i wasnt happy for the big feedback.
Most of them want to go to /wrdprs/wp-admin/ or /wrdprs/wp-login.php - stupid me i thought i had good content :confused:

Stupid them - i didnt have wordpress installed. ;););)

Why i wrote this?
Read this (http://www.heise.de/security/meldung/Exploit-Kit-greift-ueber-50-Router-Modelle-an-2665387.html) - sorry a german site. Maybe google helps (https://translate.google.com/translate?sl=de&tl=en&js=y&prev=_t&hl=de&ie=UTF-8&u=http%3A%2F%2Fwww.heise.de%2Fsecurity%2Fmeldung%2 FExploit-Kit-greift-ueber-50-Router-Modelle-an-2665387.html&edit-text=)


If you dont have a uptodate router eg. a vigor /sonicwall - just "scrap" from the centstore i strongly recommend to rethink about "i need acces to my router from outside/ WAN" or "my NAS".

cheers

TheLastMan
2015-09-04, 01:58
So, if you only need to access your LMS Web UI, you can do that from your work computer's browser, using port 443. Port 443 will not be blocked.

eg: http://[your url if you have a suitable DNS record, or your IP address]:443

You will ALSO need to set up your router at your home to forward port 443 onto [your LMS server's IP address], port 9000 .

regards, Atlantic
Atlantic; a very belated thank you!

A short note on how I got this to work if anybody else is having similar issues:

After an awful lot of Googling I eventually found out what you were talking about. This process is achieved using one of two methods;
1. Port Address Translation or PAT. This allows you to use several port numbers as a proxies for the one that the server is listening on. The proxy ports are known as "origin" ports and the port that the server is listening on is known as the "destination" port. In this case I could use 443 as the "origin" and 9000 as the "destination".

2. Virtual Server. This is a simple extension of Port Forwarding that allows the incoming port number to be different from the port number the server is listening on. This means doing two separate port forward entries:
[external ip]:9000 -> [internal ip]:9000
[external ip]:443 -> [internal ip]:9000

My rather ancient Netgear DG834GT router allowed Port Forwarding but did not have a Virtual Server function or PAT available in the firmware. So I bought a new router that had a Virtual Server setup. That took quite a bit of time as it involved downloading a lot of instruction manuals as this is not often listed as a "feature" in the specifications of most routers sold to the general public.

Anyway, the new router came with a host of other improvements, such as much faster wi-fi and better stability, so it was worth doing even without making remote LMS work.

Like most computer stuff it is "simple when you know how" - it is finding the "know how" that is difficult!

TheIBM
2015-09-04, 16:24
Hi folks. I am trying to connect remotely from work to my LMS server on my home network which uses the port 9000. However, most outgoing ports are blocked here. Is there any way round this?

Opening SB 9000 directly to the outside world is a seriously BAD idea! Shudder!!!

If you have a fixed IP at home or can use a Dynamic DNS service then install CYGWIN which is an SSH server for Windoz (assuming your using windoz) Mac has SSH built in and its available for all versions of Linux if not already pre installed.

Then at work install PUTTY.

Point a web browser to localhost and SOCKS proxy in network settings.

Set up a dynamic port in PUTTY to point to your home address. Connect. You need to add a user at the home end with permissions to access via SSH. Set a Very secure password!

Open and pinhole port 22 (SSH) on the home router to the internal home PC (the SSH server)

Enter localhost:9000 in the browser

This stuff is very well documented on the net. Tag# SSH, PUTTY, CYGWIN