PDA

View Full Version : Full scan hangs



radish112
2015-03-14, 11:36
Hi.

I am running a full scan, but the process hangs (the process has now been running for about an hour and is still ongoing).

In the past, the process took only about 10-15 minutes to complete. As the image below shows, the initial processes are being completed very quickly, but I'm not getting a message that the scan has been completed. And my Squeezebox displays the message "Can't connect to server."

I'm running LMS on a Vortexbox (linux machine). So, I don't think this is a Daylight Savings Time issue, but I might be wrong about this. Please let me know if this is the case. The light on the Vortexbox shows ongoing disk activity of some kind.

The only other thing I believe I have changed since my last 10-15 minute scan is addition of the Ickstream plugin. Has anyone who has installed Ickstream experienced subsequent scanning problems?

Any advice appreciated. Thanks in advance.

Steve



17610

skriefal
2015-03-14, 14:02
Which version of LMS? I had similar results with LMS 7.7, but the problem went away when I updated to LMS 7.9.

garym
2015-03-14, 16:58
ickstream hasn't affected my scanning. Go into LMS > Settings > Advanced and set your scanning log to "debug". Then do the scan again and when it hangs, look at your scanning log and see what it is showing. This may provide some hints. And you can post it here too for others to look at.

mherger
2015-03-15, 22:30
> I am running a full scan, but the process hangs (the process has now
> been running for about an hour and is still ongoing).

Could you please upload the scanner.log file?

--

Michael

radish112
2015-03-16, 07:49
Thanks to all for your helpful replies to my "Full scan hangs" problem. I started a full scan about 45 minutes ago. After about 35 minutes, my Squeezebox showed the "Can't connect to server" message. At the time I lost contact with the Squeezebox, the scanner.log showed what I have cut and pasted below, under the dotted line. Note also that there were many instance of the "skipping!" issue, but when I tried pasting the entire scanner.log file I got the following message:

The following errors occurred with your submission
You have included a total of 21 images in your message. The maximum number that you may include is 10. Please correct the problem and then continue again.

Images include use of smilies, the BB code [img] tag, and HTML <img> tags. The use of these is all subject to them being enabled by the administrator.


OK...here's part of the scanner.log file...many thanks for your help

--------------------------------------------------------------------



[15-03-16 10:14:40.7442] Slim::Formats::Playlists::Base::playlistEntryIsVal id (120) Warning: file:///storage/music/flac/ThemeTimeRadio47%20Fools/10%20Fool%20Fool%20Fool.mp3 found in playlist:
file:///storage/music/playlist/TrackStat%205%20Ratings.m3u doesn't exist on disk - skipping!
[15-03-16 10:14:40.7460] Slim::Formats::Playlists::Base::playlistEntryIsVal id (120) Warning: file:///storage/music/flac/ThemeTimeRadio47%20Fools/10%20Fool%20Fool%20Fool.mp3 found in playlist:
file:///storage/music/playlist/TrackStat%205%20Ratings.m3u doesn't exist on disk - skipping!
[15-03-16 10:14:50.7176] Slim::Utils::Scanner::Local::new (816) Handling new playlist file:///storage/music/playlist/TrackStat%20Played.m3u
[15-03-16 10:14:52.0623] Slim::Utils::Scanner::Local::new (816) Handling new playlist file:///storage/music/playlist/monk@play.m3u
[15-03-16 10:14:53.6935] Slim::Utils::Scanner::Local::__ANON__ (413) Rescanning changed audio files (0)
[15-03-16 10:14:53.6952] Slim::Music::Import::runImporter (488) Starting Plugins::SmartMix::Importer scan
[15-03-16 10:15:59.4748] Slim::Music::Import::endImporter (620) Completed Plugins::SmartMix::Importer Scan in 65 seconds.
[15-03-16 10:16:00.7958] Slim::Music::Artwork::precacheAllArtwork (608) Starting precacheArtwork for 1198 albums
[15-03-16 10:17:22.1216] Slim::Music::Artwork::__ANON__ (727) precacheArtwork finished in 81.3140180110931
[15-03-16 10:17:22.1229] Slim::Music::Import::endImporter (620) Completed precacheArtwork Scan in 82 seconds.
[15-03-16 10:17:22.3664] Slim::Music::Import::runScanPostProcessing (403) Starting Database optimization.

garym
2015-03-16, 07:54
save the full log to your computer, zip it with winzip or equivalent, then attach the zip file to a thread message here.

Mnyb
2015-03-16, 08:22
The log is actually a text file follow the link with explorer just don't copy and paste from the web-UI the link in the web UI just shows part of the file for easy acess .

radish112
2015-03-17, 12:10
Folks,

Thanks for your offer to help with my scanning problem. I had a bit of a learning curve to figure out how to access, zip up, and attach the scanner.log, but I think I have succeeded. There are a couple of things that are puzzling me, however.

I conducted a full scan this afternoon. When I look at the first few lines of the scanner.log that is accessed from the LMS>Advanced>Logging UI interface, I see that the first few lines of the file are dated [15-03-17 12:01:13.9893], just as I expect. But when I used CryptoTerm to access the latest scanner.log file (named "scanner.log-20150317.gz"), I see that the first few lines are dated [15-03-16 13:18:45.6067], one day earlier. This is a complete mystery to me. Why would the scanner.log accessed via the UI show show the date as 15-03-17, and the scanner.log accessed via CryptoTerm show the date as 15-03-16? In any event, because Mnyb advised that I not cut and paste from the UI, I have attached the zip file of the scanner.log I accessed via Cryptoterm. I just don't know if this is the scan I did yesterday, or the scan I did today. I hope it will prove helpful either way.

Below I have embedded an image of the way I set up the "Debug" options. Please let me know if I messed this up somehow. I probably used "overkill" options.

As usual, the scan took a little over 2 hours to complete, and a couple of times the Squeezebox displayed the usual "Can't connect to server" message. Yet, another of the images I embedded below indicates that the actual scanning process took just over 12 minutes. I have no idea what was happening for the remaining time.

Thanks in advance for any help you can provide.

Cheers,

Steve

17664

17665

radish112
2015-03-18, 12:22
Folks,

I got some sound advice from Ron Olsen, an Administrator over at the Vortexbox Forums, that the file I uploaded here yesterday was already zipped, which was indicated by the .gz extension. Following Ron's instructions, I have uploaded a straight zip file this time.

I appreciate any help you might be able to give me with my problem.

Thanks,

Steve

DJanGo
2015-03-18, 13:17
[15-03-17 12:01:18.3693] Slim::Music::Import::endImporter (620) Completed precacheArtwork Scan in 87 seconds.
[15-03-17 12:01:18.5973] Slim::Music::Import::runScanPostProcessing (403) Starting Database optimization.
[15-03-17 12:01:18.5984] Slim::Schema::optimizeDB (440) Start schema_optimize
[15-03-17 12:23:14.4491] Slim::Schema::optimizeDB (454) End schema_optimize
[15-03-17 12:23:14.4615] Slim::Music::Import::endImporter (620) Completed dbOptimize Scan in 1315 seconds.
[15-03-17 12:23:14.7623] Slim::Music::Import::runScanPostProcessing (411) Finished background scanning.
[15-03-17 12:23:14.8010] Slim::Utils::SQLiteHelper::updateProgress (398) Notify to server: ["end"]
[15-03-17 12:23:14.8127] Slim::Utils::SQLiteHelper::updateProgress (422) Notify to server OK
[15-03-17 12:23:14.8938] Slim::Utils::SQLiteHelper::updateProgress (398) Notify to server: ["exit"]
[15-03-17 12:23:16.6377] Slim::Utils::SQLiteHelper::updateProgress (422) Notify to server OK
Scanner is done.
i didnt find (fastforward) no errors?

radish112
2015-03-18, 16:34
DJanGo,

Thanks for taking a look. The last time I ran a scan it took 3 hours before I could gain access to the Squeezebox again.

I think the scanning process itself is being completed in 10-15 minutes, but then there is some disk activity (??) going on for the next 2 hours and 45 minutes that I can't account for.

At this point the only "solution" seems to be setting up a rescan to automatically run in the wee hours of the morning when I won't need access to the Squeezebox.

Steve

Ron Olsen
2015-03-18, 19:23
If you are running VortexBox 2.3, I suggest installing LMS 7.9 from the Squeeze Community repository and see if that fixes your scanning issues. See http://info.vortexbox.org/tiki-index.php?page=squeezecommunity-2.3 for installation instructions.

LMS 7.9 has significant improvements to the scanning code over LMS 7.8; see http://htmlpreview.github.io/?https://github.com/Logitech/slimserver/blob/public/7.9/Changelog7.html for details.

If you want to analyze CPU and disk I/O behavior on your VB:

1. Login to your VB.

2. Install the htop process monitor and iotop I/O monitor:

yum install htop iotop

3. To see which processes are using the most CPU time:

htop

4. To see which processes are doing the most disk i/o:

iotop

Exit either program by entering "q".

See

man htop and
man iotop for more info.

radish112
2015-03-20, 07:24
Ron,

Hey. Yep, I'm running VortexBox 2.3 and LMS 7.8.

Thanks for your suggestion, and for the clearn instructions for achieving the conversion to LMS 7.9.

After reading through the installation instructions I'm inclined to just wait until Andrew creates the official VortexBox packages for LMS 7.9 and then see if that solves my problem. At this point I have ripped all my current CDs, and I buy new ones at a pretty slow rate these days. Thus although I am bugged by the slowness of the rescans, I don't have to do them very often. So, I'll just live with running a scan, when necessary, late at night.

My other concern with installing the Squeeze Community version of LMS 7.9 is that I'm not sure whether saving the LMS 7.8 server preferences also saves my TrackStat ratings, which I would hate to lose.

Many thanks for your help.

Steve

Ron Olsen
2015-03-20, 17:46
Suit yourself.

However, upgrading from LMS 7.8 to LMS 7.9 should not affect your Trackstat data, which is stored in the LMS database in the /var/lib/squeezeboxserver/cache directory.

Also, Trackstat makes nightly backups in /storage/music/playlist on the VB, so you can restore Trackstat info from a backup if necessary. Enter

ls -l /storage/music/playlist to see the Trackstat backup files.

I doubt that Andrew will make an LMS 7.9 nightly available in the VB 2.3 repo. Users have asked for this for many months and nothing has happened. The Squeeze Community repo is your best bet for running LMS 7.9 on VB 2.3, and the installation is very easy.