View Full Version : AlienBBC and Mac installation instructions.

Adrian Merwood
2004-12-07, 07:29
Daniel Cohen wrote:

> I've just tried running the Mac OS X GUI version of mplayer.
> When I tried the suggested rtsp stream for Radio 1 it didn't work the
> first time, and gave an error message (in the console log)
> Connecting to server rmlivev8.bbc.net.uk[]:554 ...
> rtsp_session: session can not be established.
> Not a Realmedia rtsp url. Trying standard rtsp protocol.
> RTSP support requires the "LIVE.COM Streaming Media" libraries!
> Unable to open URL:
> rtsp://rmlivev8.bbc.net.uk/farm/*/ev7/live24/radio1/live/r1_dsat_g2.ra
> But when I tried Radio 2 (change radio1/live/r1 to radio2/live/r2) it
> did work, as did trying Radio 1 again. The console log showed
> Opening audio decoder: [realaud] RealAudio decoder
> opening shared obj
> '/usr/local/lib/mplayer//cook.bundle/Contents/MacOS/cook'
> Audio codec: [23] 44 kbps Stereo Music High Response - RA8
> Audio bitrate: 44.100 kbit/s (5513 bps) AUDIO: 44100 Hz, 2 ch, 16 bit
> (0x20), ratio: 5513->176400 (44.1 kbit)
> Selected audio codec: [racook] afm:realaud (RealAudio COOK)
> But running mplayer from the terminal using the radio 2 version of the
> correct address (with \* not just *) gave the usual error messages
> (can't find LIVE.COM, etc)


I'm pretty much convinced that mplayer is our sticking point here. I
cannot get it to play any sort of relaudio stream so far. Did you build
your mplayer by hand or are you using the fink build?


Adrian Merwood
2004-12-08, 05:08

I have done some more diagnosis and made some progress:

1. I compiled mplayer from source using the same configuration options
used in the fink version (mplayer.info in fink directory)

2. I ran transcoder proxy in a separate window and monitored the output
whilst I used softsquueze to drive the plugin

3. This copy of mplayer will NOT go to urls in the format:


but it will go to the corresponding:


providing I escape the *

4. I modified transcoder_proxy.perl to look for the .rpm and use
LWP::simple to get the one line contents of the .rpm url and extract
the rtsp:// url

5. I still could not get mplayer to run until I started playing with
the options passed to mplayer. My version does not like -really-quiet

6. Removing this and running mplayer from the command line I now get
an error loading the RealAudio codecs.

merlin:SlimServer.prefPane/Contents/server] adrian% mplayer -vo null
-cache 32 -af resample=44100:0:1 -ao pcm -aofile tmp.wav
MPlayer 1.0pre5-3.3 (C) 2000-2004 MPlayer Team

AltiVec found
CPU: PowerPC
Reading config file /sw/etc/mplayer/mplayer.conf
Reading config file /Users/adrian/.mplayer/config
Reading /Users/adrian/.mplayer/codecs.conf: Can't open
'/Users/adrian/.mplayer/codecs.conf': No such file or directory
Reading /sw/etc/mplayer/codecs.conf: Can't open
'/sw/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
font: can't open file: /Users/adrian/.mplayer/font/font.desc
Font /sw/share/mplayer/font/font.desc loaded successfully! (206 chars)
Using usleep() timing
Can't open input config file /Users/adrian/.mplayer/input.conf: No such
file or directory
Input config file /sw/etc/mplayer/input.conf parsed: 52 binds

Resolving rmlivev8.bbc.net.uk for AF_INET6...
Couldn't resolve name for AF_INET6: rmlivev8.bbc.net.uk
Resolving rmlivev8.bbc.net.uk for AF_INET...
Connecting to server rmlivev8.bbc.net.uk[]:554 ...
Cache size set to 32 KBytes
Connected to server: rmlivev8.bbc.net.uk
Cache fill: 0.00% (0 bytes) REAL file format detected.
======= WAVE Format =======
Format Tag: 28515 (0x6F63)
Channels: 2
Samplerate: 22050
avg byte/sec: 44100
Block align: 640
bits/sample: 16
cbSize: 18
Unknown extra header dump: [0] [80] [0] [10] [0] [b] [2] [80] [0] [8]
[1] [0] [0] [2] [4] [0] [0] [18]
demux_real: invalid chunksize! (0)
Clip info:
name: Radio 4
author: BBC
copyright: (C) British Broadcasting Corporation 2004
================================================== ====================== ==
Opening audio decoder: [realaud] RealAudio decoder

MPlayer interrupted by signal 10 in module: init_audio_codec
- MPlayer crashed. This shouldn't happen.
It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
gcc version. If you think it's MPlayer's fault, please read
DOCS/HTML/en/bugreports.html and follow the instructions there. We
can't and
won't help unless you provide this information when reporting a
possible bug.

7. This is as far as I have got!!!