PDA

View Full Version : Squeezelite Running - Other Audio



blawford
2014-12-29, 04:02
I have Squeezelite running on a Raspberry Pi and Windows 7 machine in two different rooms, the Raspberry Pi is dedicated for audio playing the Windows 7 machine isn't. The problem I am having is that I am unable to have the Squeezelite client running on the Windows machine and get sound from other applications, is there a work around for this?

Apologies if this has been covered before (I would imagine it must have been) but a search didn't bring anything back...

Thanks.

Triode
2014-12-29, 04:23
I have Squeezelite running on a Raspberry Pi and Windows 7 machine in two different rooms, the Raspberry Pi is dedicated for audio playing the Windows 7 machine isn't. The problem I am having is that I am unable to have the Squeezelite client running on the Windows machine and get sound from other applications, is there a work around for this?

Apologies if this has been covered before (I would imagine it must have been) but a search didn't bring anything back...

Thanks.

You need to pick a sound card on the windows machine which does not lock the audio output - list then with the -l option and then try each in turn with the -o option.

blawford
2014-12-29, 08:14
You need to pick a sound card on the windows machine which does not lock the audio output - list then with the -l option and then try each in turn with the -o option.

Spot on, changed output from 3 to 0 (output devices listed below for reference, in case anyone else finds this thread in the future) and was able to playback a video file with audio simultaneously while playing something from my LMS.

Output devices:
0 - Microsoft Sound Mapper - Output [MME]
1 - TX-SR606 (Intel(R) Display Audi [MME]
2 - TX-SR606 (Intel(R) Display Audio) [Windows WASAPI]
3 - Output (Intel(R) Display Audio Output 1) [Windows WDM-KS]

Many thanks.