PDA

View Full Version : Sirius message. Why?



Ikabob
2014-12-24, 10:31
Can anyone tell me why I cannot listen continuously to a Sirius station? I get the message " you are no longer authorized to use this service". I am a paid premium subscriber. Thank you.

garym
2014-12-24, 10:37
I used to rarely get this message. But in last week or so I seem to get it every 2 or 3 minutes. But eventually (after 2 to 4 stops and restarts of same station) I can listen to siriusXM for an hour or two with no stopping. See this thread as well:

http://forums.slimdevices.com/showthread.php?102466-Sirius-app-stops-playing-under-LMS&highlight=siriusXM+stopping

ralphy
2014-12-25, 12:59
I used to rarely get this message. But in last week or so I seem to get it every 2 or 3 minutes. But eventually (after 2 to 4 stops and restarts of same station) I can listen to siriusXM for an hour or two with no stopping. See this thread as well:

http://forums.slimdevices.com/showthread.php?102466-Sirius-app-stops-playing-under-LMS&highlight=siriusXM+stopping

I've attached patches for servers running linux/osx, won't work for windows, that I use to bypass this problem.

The original patch came from a bugzilla report that I can't find at the moment.

I've only tested this with a Canadian SiriusXM subscription, it may not work for the US.

Download the appropriate patch for your version of lms.

Change to the top level install directory for your server. Mine is in /opt/logitechmediaserver

cd /opt/logitechmediaserver
patch -p1 < /path/to/appropriate/patchfile/for/your/lms/version

and restart lms.

The patch modifies Slim/Plugin/Sirius/ProtocolHandler.pm. I'd suggest making a copy before attempting to patch it.

garym
2014-12-29, 11:02
I've attached patches for servers running linux/osx, won't work for windows, that I use to bypass this problem.

The original patch came from a bugzilla report that I can't find at the moment.

I've only tested this with a Canadian SiriusXM subscription, it may not work for the US.

Download the appropriate patch for your version of lms.

Change to the top level install directory for your server. Mine is in /opt/logitechmediaserver

cd /opt/logitechmediaserver
patch -p1 < /path/to/appropriate/patchfile/for/your/lms/version

and restart lms.

The patch modifies Slim/Plugin/Sirius/ProtocolHandler.pm. I'd suggest making a copy before attempting to patch it.

Thanks Ralphy. I'm a complete "copy/paste and follow exact instructions" linux guy (with no other knowledge of linux). And I've never patched anything on my system. I assume I do the following to patch my LMS 7.8 on my vortexbox (fedora linux machine).

0. Save my original copy of ProtocolHandler.pm in case of a problem. Mine is at:

/usr/lib/perl5/vendor_perl/Slim/Plugin/Sirius/ProtocolHandler.pm

1. download the patch file to a location on my vortexbox server. I'll use the "backup subdirectory in my file storage directory:

/storage/backup

2. Log into my vortexbox with command line. I think my equivalent to opt/logitechmediaserver is: opt/vortexbox (there is no other subdirectory under "opt" and vortexbox is the "name" of my linux server. So with command line, I'd enter the following to change to the appropriate subdirectory:

cd /opt/vortexbox

3. enter the following via command line:

patch -p1 /storage/backup/lms-7.8-sirius-not-auth.patch

4. restart LMS.

(I assume if it doesn't work, I can take the previously saved copy of ProtocolHandler.pm and copy it back over to:
/usr/lib/perl5/vendor_perl/Slim/Plugin/Sirius/

Thanks in advance for any assistance on this.

Ron Olsen
2014-12-29, 13:16
Thanks Ralphy. I'm a complete "copy/paste and follow exact instructions" linux guy (with no other knowledge of linux). And I've never patched anything on my system. I assume I do the following to patch my LMS 7.8 on my vortexbox (fedora linux machine).

0. Save my original copy of ProtocolHandler.pm in case of a problem. Mine is at:

/usr/lib/perl5/vendor_perl/Slim/Plugin/Sirius/ProtocolHandler.pm

1. download the patch file to a location on my vortexbox server. I'll use the "backup subdirectory in my file storage directory:

/storage/backup

2. Log into my vortexbox with command line. I think my equivalent to opt/logitechmediaserver is: opt/vortexbox (there is no other subdirectory under "opt" and vortexbox is the "name" of my linux server. So with command line, I'd enter the following to change to the appropriate subdirectory:

cd /opt/vortexbox

3. enter the following via command line:

patch -p1 /storage/backup/lms-7.8-sirius-not-auth.patch

4. restart LMS.

(I assume if it doesn't work, I can take the previously saved copy of ProtocolHandler.pm and copy it back over to:
/usr/lib/perl5/vendor_perl/Slim/Plugin/Sirius/

Thanks in advance for any assistance on this.

I applied Ralphy's patch to LMS 7.9 on my VB 2.3 system; here are the instructions for your VBA:

1. Download the LMS 7.8 patch and save it on your VB in /storage/backup/lms-7.8-sirius-not-auth.patch.

2. Login to your VortexBox.

3. Save the official version of ProtocolHandler.pm:


cd /usr/lib/perl5/vendor_perl/Slim/Plugin/Sirius
cp -a ProtocolHandler.pm ProtocolHandler.pm.official


4. Apply the patch:


cd /usr/lib/perl5/vendor_perl
patch -p1 < /storage/backup/lms-7.8-sirius-not-auth.patch


5. Restart LMS:

systemctl restart squeezeboxserver

6. LMS should now be running with the patched version of ProtocolHandler.pm.

garym
2014-12-29, 13:45
Thanks Ron. All works except for the last step (after I changed the "backup" to "Backup" to match my directory name, oops!).

(I can see the copied file with "official" at the end in the right subdirectory). But I get this on the last step (not finding the "patch" command?):


[root@vortexbox Sirius]# cd /usr/lib/perl5/vendor_perl
[root@vortexbox vendor_perl]# patch -p1 < /storage/Backup/lms-7.8-sirius-not-auth.patch
-bash: patch: command not found
[root@vortexbox vendor_perl]#

Ron Olsen
2014-12-29, 14:04
Thanks Ron. All works except for the last step (after I changed the "backup" to "Backup" to match my directory name, oops!).

(I can see the copied file with "official" at the end in the right subdirectory). But I get this on the last step (not finding the "patch" command?):


[root@vortexbox Sirius]# cd /usr/lib/perl5/vendor_perl
[root@vortexbox vendor_perl]# patch -p1 < /storage/Backup/lms-7.8-sirius-not-auth.patch
-bash: patch: command not found
[root@vortexbox vendor_perl]#

Login to your VB and enter

yum install patch and try steps 4-6 again.

garym
2014-12-29, 14:13
Login to your VB and enter

yum install patch and try steps 4-6 again.

Aha. That was it. installed Patch, then all worked and the file was patched (and SirusXM working!). Thanks!

p.s. I'm assuming I won't have to redo the patch unless I do a complete reinstall of LMS 7.8 or uninstall then reinstall the siriusXM plugin.

Ron Olsen
2014-12-29, 15:59
Aha. That was it. installed Patch, then all worked and the file was patched (and SirusXM working!). Thanks!

p.s. I'm assuming I won't have to redo the patch unless I do a complete reinstall of LMS 7.8 or uninstall then reinstall the siriusXM plugin.

You will lose the patch if logitechmediaserver-7.8.0-2.fc20.noarch.rpm is updated to a newer version or reinstalled.

Removing/reinstalling the LMS SiriusXM plugin has no effect on the ProtocolHandler.pm patch.

garym
2014-12-29, 16:41
You will lose the patch if logitechmediaserver-7.8.0-2.fc20.noarch.rpm is updated to a newer version or reinstalled.

Removing/reinstalling the LMS SiriusXM plugin has no effect on the ProtocolHandler.pm patch.

got it. thanks.

Ron Olsen
2014-12-29, 16:58
You will lose the patch if logitechmediaserver-7.8.0-2.fc20.noarch.rpm is updated to a newer version or reinstalled.

Removing/reinstalling the LMS SiriusXM plugin has no effect on the ProtocolHandler.pm patch.

It may be worthwhile to save the patched version of ProtocolHandler.pm:

1. Login to your VortexBox.

2. I like to keep a copy of any files I modify so I don't lose them when software is updated. To save the patched version of ProtocolHandler.pm (after you have applied the patch, of course):


cd /usr/lib/perl5/vendor_perl/Slim/Plugin/Sirius
cp -a ProtocolHandler.pm ProtocolHandler.pm.patched


3. If LMS is updated or reinstalled, you can then restore the patch by


cd /usr/lib/perl5/vendor_perl/Slim/Plugin/Sirius
cp -a ProtocolHandler.pm.patched ProtocolHandler.pm


4. If you didn't save the patched version, you would have to reapply the patch:


cd /usr/lib/perl5/vendor_perl
patch -p1 < /storage/Backup/lms-7.8-sirius-not-auth.patch

but this may fail in the (unlikely) event that the official version of ProtocolHandler.pm is modified.

garym
2014-12-29, 17:08
It may be worthwhile to save the patched version of ProtocolHandler.pm:


2. I like to keep a copy of any files I modify so I don't lose them when software is updated. To save the patched version of ProtocolHandler.pm (after you have applied the patch, of course):


Great idea. Done! (plus I add all the tips/code you and others provide me to a WORD document I keep of "useful VBA commands" with enough explanation so if I need it 6 months from now I have it at my fingertips).

tcutting
2014-12-29, 18:47
Any idea how to implement this patch on an Ubuntu install?

Sent from my HTC6525LVW using Tapatalk

Ron Olsen
2014-12-29, 20:07
Any idea how to implement this patch on an Ubuntu install?

If you are using the LMS .deb package, the file to patch is /usr/share/perl5/Slim/Plugin/Sirius/ProtocolHandler.pm

1. Download the appropriate patch (7.8 or 7.9) to your Ubuntu system and save it in $HOME/lms-sirius-not-auth.patch

2. Login to your Ubuntu system.

3. Save the official version of ProtocolHandler.pm:


cd /usr/share/perl5/Slim/Plugin/Sirius
sudo cp -a ProtocolHandler.pm ProtocolHandler.pm.official

4. Apply the patch:


cd /usr/share/perl5
sudo patch -p1 < $HOME/lms-sirius-not-auth.patch

5. Save a copy of the patched file:


cd /usr/share/perl5/Slim/Plugin/Sirius
sudo cp -a ProtocolHandler.pm ProtocolHandler.pm.patched

6. Restart LMS:

sudo service logitechmediaserver restart

mherger
2015-01-05, 02:37
> The original patch came from a bugzilla report that I can't find at the
> moment.

Did you find it? I would be very much interested in this issue. We
shouldn't need to disable the activity check to keep the radio playing...

--

Michael

Ron Olsen
2015-01-05, 04:39
> The original patch came from a bugzilla report that I can't find at the
> moment.

Did you find it? I would be very much interested in this issue. We
shouldn't need to disable the activity check to keep the radio playing...

--

Michael

See http://bugs.slimdevices.com/show_bug.cgi?id=11544 and http://forums.slimdevices.com/showpost.php?p=637411&postcount=174

ralphy
2015-01-05, 05:39
> The original patch came from a bugzilla report that I can't find at the
> moment.

Did you find it? I would be very much interested in this issue. We
shouldn't need to disable the activity check to keep the radio playing...

--

Michael

No, I looked again today. I remember finding it through a google search the last time, tried that too but no luck so far.


See http://bugs.slimdevices.com/show_bug.cgi?id=11544 and http://forums.slimdevices.com/showpost.php?p=637411&postcount=174

I found the original file I downloaded back in June 2011. Turns out it did come from the not so sirius files all downloads section, but is not part of the 1.1 plugin.

https://notsosirius-squeezecenter.googlecode.com/files/ProtocolHandler.pm

netchord
2015-02-11, 08:13
just wondering if there's any work being done to fix the SXM plugin- i'm not sure i'm comfortable with the path outlined here.

still getting timeouts after a minute or so.

netchord
2015-02-17, 06:10
coming back to this, i'm having success on every SXM station I listen to, EXCEPT TheLoft (channel 30). MetOpera Radio, Symphony Hall, Pure Jazz all are fine, and will play for hours ww/out a hitch.

The Loft times out after ~1 min. I pinged someone on SXM side who is in a position to know, and he said the issue is w/ the LMS implementation, not SXM.

Michael, or anyone else, can you help?

garym
2015-02-17, 06:14
coming back to this, i'm having success on every SXM station I listen to, EXCEPT TheLoft (channel 30). MetOpera Radio, Symphony Hall, Pure Jazz all are fine, and will play for hours ww/out a hitch.

The Loft times out after ~1 min. I pinged someone on SXM side who is in a position to know, and he said the issue is w/ the LMS implementation, not SXM.

Michael, or anyone else, can you help?

I haven't systematically tested this, but I seem to notice the same sort of thing. I can stream the Grateful Dead channel for a couple of hours with no stopping. But something like XM Public Radio (channel 122) will stop after a minute or two. I may have to restart 2 or 3 times and then it will eventually "stick" and play for an hour or so.