PDA

View Full Version : Spotify : Problem with thrid party plugin with Duet



Josd
2014-12-15, 12:35
Hello Forum users,

I am a Duet user for more than 5 years now and now have a Premium Spotiy account to get into music streaming. I'm use my Synology NAS as LMS. There I have installed the Triode 3e party plugin to be able to stream Spotify Music. After setting the account data I was able to start the menu on the Duet controller and every thing look good.

The trouble is when I start to hit the PLAY button the following error shows at the LMS log. The result of this error is that there is no music. Cover art is showing :

[14-12-13 12:01:02.9149] Plugins::Spotify::ProtocolHandler::handleDirectErr or (366) stream failed - bad player: -1

Can any one help me get this solved ?

Thanks in advance.

Jos Damen
The Netherlands

toby10
2014-12-16, 03:44
No idea but I'd start here: http://forum.synology.com/enu/viewtopic.php?f=131&t=27084

Not all NAS' are supported by Triode's plugins.

cadfish
2014-12-16, 08:03
Hello Forum users,

I am a Duet user for more than 5 years now and now have a Premium Spotiy account to get into music streaming. I'm use my Synology NAS as LMS. There I have installed the Triode 3e party plugin to be able to stream Spotify Music. After setting the account data I was able to start the menu on the Duet controller and every thing look good.

The trouble is when I start to hit the PLAY button the following error shows at the LMS log. The result of this error is that there is no music. Cover art is showing :

[14-12-13 12:01:02.9149] Plugins::Spotify::ProtocolHandler::handleDirectErr or (366) stream failed - bad player: -1

Can any one help me get this solved ?

Thanks in advance.

Jos Damen
The Netherlands


I had a similar error message. The reason was that I start LMS with explicit IP address and the plugin expects the cli to listen on loopback interface (127.0.0.1). So setting the cli adress explicitely to 127.0.0.1 solved the problem. Maybe you should check how LMS is started on your Synology NAS.

For details of my problem check the following thread:

http://forums.slimdevices.com/showthread.php?79706-Announce-Spotify-Premium-Plugin-(Beta)&p=799013&viewfull=1#post799013


and here for the solution:

http://forums.slimdevices.com/showthread.php?79706-Announce-Spotify-Premium-Plugin-(Beta)&p=800339&viewfull=1#post800339

GŁnther

Josd
2014-12-17, 05:05
Dear gunter and Toby,

Thank you for the support in finding a solution. After reading all the info, that you provided, I first decided to reinstall LMS (Logitec Media Server) on my Synology DS212+. To my suprise it is now working ! I'm very happy with the new feature, otherwise I had to buy a Sonos or Bluesound to provide with good streaming audio.

LMS was working without changing any setting except installing the extra Triode plugin and provide username and password (with settings) .

I want to specify my setup so other people know that this set-up is working:

Synology DS212+ with DSM 5.1-5004 Update 2
LMS 7.7.3-040 with Triode v2.3.9
Duet Receiver Firmware 77
IPad 2 with Squeezepad app version 1.11.0

Again thanks for your support

Regards,

Jos Damen
The Netherlands