View Full Version : Player not working with ethernet, does with wifi

2014-12-08, 10:25
I have a Squeezebox Classic, running firmware 137, server is 7.7.5. I've been running it over wifi for many years.

Recently I experienced the problem of the player randomly resetting, sometimes skipping. I read up on the forums, did factory resets and xilinx programs, didn't help. So I switched from a wireless to an ethernet connection. The player has no problem seeing the server and the music, but when I hit Play, it switches to play mode but doesn't play. The track counter isn't moving and there's nothing on the level meter.

If I switch back to wifi, no problem (except for the intermittent issues mentioned). I'm using the exact same static IP and other connection settings. It's connected through a router acting as a wireless access point to my main router. Switch back to ethernet, sees the music, won't play.

Any suggestions?


2014-12-08, 10:42
Remove the static IP on Ethernet.
Each network card has its own MAC address. You can't have the 2 MAC addresses - wired & wireless - with the same IP. Your switch or router doesn't know where to find the route to the wired connection so is sending them to where it last found that IP address - the wireless card.

2014-12-08, 18:10
Remove the static IP on Ethernet.
Each network card has its own MAC address. You can't have the 2 MAC addresses - wired & wireless - with the same IP. Your switch or router doesn't know where to find the route to the wired connection so is sending them to where it last found that IP address - the wireless card.

Hmm, made no difference. First a tried a different static IP, then I tried DHCP. I made sure the router and WAP only were seeing the hardwired connection, correct MAC address. The server sees the unit correctly. The unit can see the music database and navigate to a song on an album. It fails when it tries to play the song though. I can ping the unit ok.

2014-12-08, 20:21
Does an actual ethernet cable directly to the main router work ?

2014-12-08, 21:02
No, and now that I moved it, it complains "ethernet appears disconnected". I tried two different cables and two different ports on the main router.

Then I brought it back to the WAP, and I'm getting the same thing there. So it seems like the jostling made something stop working (not that I handled it roughly).

I can try reseating the networking card inside the SB, but it seems like it's likely ok, since it works if I switch it to a wifi connection.

Is the wired networking part of the card separately powered from the wifi?

Any other suggestions? Anything?

2014-12-08, 23:16
Hmm ethernet is on the main board wifi is a separate card ? The ethernet port may actually be broken .

2014-12-09, 02:08
If the server could see the correct MAC address and the player could select tracks ok then I doubt it is the card. It would not work at any level if it was the card.
What happens if you connect to MySqueezebox.com instead of your LMS?
What is LMS running on? Could the LAN port on the LMS be firewalled?

2014-12-09, 07:07
The LMS is running on a Linux machine (ubuntu). Its configuration hasn't changed in a long time, and the SB is talking fine with it over wifi. On wifi tracks play without issue (except for the occasional reboots and skipping).

I have not tried connecting to MySqueezebox.com. Will try tonight if I can get it talking on ethernet again. Note: another thing I've started seeing is that sometimes the SB acts like I'm holding down a button on the remote - as if I'm pressing it repeatedly. A quick press of the right arrow will result in endless advances to the right. There's nothing wrong with the remote. I can cover up the led and it keeps acting like the button is pressed.

2014-12-09, 10:48
Doesn't sound good!
I am sure it does on wifi (sound good that is) but you know what I mean.

2014-12-09, 12:51
Yeah, it seems like there's some kind of baseline flakiness going on. This probably accounts for:

- sometimes not recognizing that the ethernet cable is connected at all
- sometimes processing a button press repeatedly

Perhaps it's a heat thing related to a loose connection or hairline circuit board break. More experimentation may shed more light.

My gut tells me there is a different issue going on related to not playing through ethernet. I say this because simply changing the configuration through the remote from wired to wireless gets it working, and changing back makes it not work. I would think the transport mechanism shouldn't make any difference in the functionality end of things, that it would either completely work or completely not communicate. But instead when it's wired, it _mostly_ works. There's some amount of data that is obviously being exchanged, since I can see the database. It's just the actual playback that freezes, only through ethernet.

Can someone suggest particularly useful categories to turn on logging for within the server? There are many categories.

2014-12-09, 14:39
Years ago I had a problem with somewhat similar symptoms not with a SB - full ethernet packets were being discarded by receiver but packets which were not full (e.g. short control packets) were received OK. Turned out to be a problem with network packet maximum size had different values and caused problems with packet fragmentation/recombination. While I don't think this is your problem, I think you need to look at network level TCP statistics on LMS PC network interface to see whether packets are being rejected/retransmitted etc. It may give a hint at what is happening.

It might also help to fire up Wireshark or similar to see what is happening at TCP, IP and Ethernet levels.

2014-12-09, 18:52
After playing around with it some more, I now think it's a case of a bad solder joint or other bad/flaky connection. Running it without the case, I was able to make the "no ethernet connection" condition come and go by putting slight pressure on the board or connections. And also getting into/out of repeating button press mode.

If the problem is in the main connections between the external connector daughter board and the main board, I may be able to improve it, but if it's not that, there's probably no hope.

I could get it to the point of selecting a track to play, but still no luck actually getting the counter to start playing. Perhaps if the solder joints are improved the wifi mode will start working reliably... Well I'll report back in a few days once I monkey with improving the connections.

2014-12-09, 18:58
bpa - thanks for the suggestions. I'll have to get familiar with using Wireshark, which I'm game for.

2014-12-11, 04:15
Why would the solder joints suddenly start failing? Is the unit prone to over-heating? (Now that you've opened it, does it smell?)

One or two bad solder joints could happen at the factory level, but issues would normally arise right away. I've never come across any electronic gear where the they failed over time, with the exception of misuse. (IE: corrosion)

2014-12-11, 15:28
Have it fallen of the shelf or something ? or maybe picking it to clean with wires hanging out of it ? half bad cold solders can get worse over time ? small tip solder iron try the re-flow the connections . It migth be fiddly i'll go and see my optician before I try :/

2014-12-11, 17:16
Fizbin and Mnyb, thinking it's a solder issue is just a guess, coming from the observation that putting mild torque or pressure on the connections and/or board can change the behavior between seeing the ethernet and not seeing it at all, and also between hiccups with the ir communications of the remote and no hiccups.

The history is that a few months ago I started having reboot and playback stutter issues, which I read there was a history of with the wifi daughterboard. So I tried reseating and removing the board and then switched to ethernet and saw the other issues I've mentioned. So the hardware has had a lot of handling in the last two weeks.

No burnt smell inside the unit. I'm not going to try to reflow the surface mount stuff, that's beyond me. I was just thinking about the connector board containing all the audio, power, and network inputs.

But if anyone has other ideas to try, speak up. About the issue when it can see the ethernet but won't start playing, I checked and the server's ethernet is not using jumbo frames. MTU was actually 1500.

2014-12-11, 17:44
MTU was actually 1500.

Some ISPs have a MTU of 1492. You should check with something like this http://kb.linksys.com/Linksys/GetArticle.aspx?docid=fbf8e8564632422eaa8ea80bf9dc ba64_386.xml

2014-12-11, 19:07
Thanks for the link - the recommended MTU size came to what the port was already set to - 1500.

2014-12-11, 19:39
I just checked the voltage points mentioned in this thread: http://forums.slimdevices.com/showthread.php?74844-Troubleshooting-(internal)-power-supply-issue&p=515312&viewfull=1#post515312

Everything is pretty close, except the 14.8V point comes out between 14.5 and 14.6, perhaps not important.