PDA

View Full Version : SmartMix & Spotify: 1.5.0 to fix"non-playable" tracks issue



mherger
2014-10-14, 08:58
If you're using SmartMix with Spotify, then please update to 1.5.0 and
give it some testing. I hopefully have fixed the addition of tracks
which eventually couldn't be played and sometimes stopped playback all
together. Please let me know if you're still seeing this issue. Thanks!

--

Michael

pippin
2014-10-14, 10:44
Now.... If you also fix the "incomplete artwork" issue, that would be seriously helpful.

mherger
2014-10-14, 12:06
> Now.... If you also fix the "incomplete artwork" issue, that would be
> seriously helpful.

What's that about?

--

Michael

mherger
2014-10-14, 12:10
Oh, like this?

http://gyazo.com/ac3e7d81c46b450cb81273d9df8c3fcf.png


[14-10-14 21:09:10.8400] Slim::Utils::Misc::msg (1343) Warning: [21:09:10.8398] Image::Scale libjpeg error: Corrupt JPEG data: premature end of data segment ((data))
[14-10-14 21:09:10.8407] Slim::Utils::Misc::msg (1343) Warning: [21:09:10.8406] Image::Scale libjpeg error: Unsupported marker type 0x7f ((data))


Are you using Triode's plugin or the official? I'm seeing this with Triode's - and this most likely is not a SmartMix issue, is it?

Triode
2014-10-14, 12:29
Oh, like this?

http://gyazo.com/ac3e7d81c46b450cb81273d9df8c3fcf.png


[14-10-14 21:09:10.8400] Slim::Utils::Misc::msg (1343) Warning: [21:09:10.8398] Image::Scale libjpeg error: Corrupt JPEG data: premature end of data segment ((data))
[14-10-14 21:09:10.8407] Slim::Utils::Misc::msg (1343) Warning: [21:09:10.8406] Image::Scale libjpeg error: Unsupported marker type 0x7f ((data))


Are you using Triode's plugin or the official? I'm seeing this with Triode's - and this most likely is not a SmartMix issue, is it?

Is this for large artwork only with my plugin (requested if the size is greater than 250 pixels I think ?) Any trend in when it occurs?

Edit: I think I've found a bug which may cause this - are you able to reproduce regularly Michael - can I send you a binary to test I've fixed it? If so what server do you run?

pippin
2014-10-14, 12:39
Sure. I run 7.8 on OSX.
Yes, only your plugin, but I thought it's related to the artwork scaler in the server, that's why I originally asked Michael.

He's, it's indeed only with "large artwork", by that standard I never ever use anything else, at least in iPeng :) even the thumbnails are 300x300 these days.

pippin
2014-10-14, 12:40
Oh, like this?

http://gyazo.com/ac3e7d81c46b450cb81273d9df8c3fcf.png


[14-10-14 21:09:10.8400] Slim::Utils::Misc::msg (1343) Warning: [21:09:10.8398] Image::Scale libjpeg error: Corrupt JPEG data: premature end of data segment ((data))
[14-10-14 21:09:10.8407] Slim::Utils::Misc::msg (1343) Warning: [21:09:10.8406] Image::Scale libjpeg error: Unsupported marker type 0x7f ((data))


Are you using Triode's plugin or the official? I'm seeing this with Triode's - and this most likely is not a SmartMix issue, is it?

No, sorry. I thought you or Triode suspected it's relat d to the artwork scaler in 7.8.
But now that I think about it it also happens with the completely unscaled artwork iPeng now uses on NowPlaying.

mherger
2014-10-14, 12:55
> Code:
> --------------------
>>> [14-10-14 21:09:10.8400] Slim::Utils::Misc::msg (1343) Warning: [21:09:10.8398] Image::Scale libjpeg error: Corrupt JPEG data: premature end of data segment ((data))
>> [14-10-14 21:09:10.8407] Slim::Utils::Misc::msg (1343) Warning: [21:09:10.8406] Image::Scale libjpeg error: Unsupported marker type 0x7f ((data))
>>
> Is this for large artwork only with my plugin (requested if the size is
> greater than 250 pixels I think ?) Any trend in when it occurs?
>

Yes, I've only seen it when in SP's Now Playing mode (using that large skin). Browsing in the web UI, or displaying the playlist there wouldn't cause the issue. And it didn't happen with all covers. I skipped through 10-15 tracks before it happened.

Triode - I have OSX Mavericks, ReadyNAS ARM or x64 Linux (CentOS6 based). Oh, and Windows7

Triode
2014-10-14, 12:59
Sure. I run 7.8 on OSX.
Yes, only your plugin, but I thought it's related to the artwork scaler in the server, that's why I originally asked Michael.

He's, it's indeed only with "large artwork", by that standard I never ever use anything else, at least in iPeng :) even the thumbnails are 300x300 these days.

Does the attached help pippin - should be a replacement spotifyd for osx.

pippin
2014-10-14, 13:22
Thanks. I'll give it a try, will probably know by tomorrow. It doesn't happen on every artwork but it's frequent enough that a few hours without it should be significant

slartibartfast
2014-10-14, 14:15
If you're using SmartMix with Spotify, then please update to 1.5.0 and
give it some testing. I hopefully have fixed the addition of tracks
which eventually couldn't be played and sometimes stopped playback all
together. Please let me know if you're still seeing this issue. Thanks!

--

Michael
Is that with any plugin? I think I previously found that unplayable tracks only turned up when I had both plugins installed to allow me to play different tracks on different players. When I uninstalled the Logitech plugin the problem went away. Can I now install both plugins and avoid unplayable tracks?

mherger
2014-10-14, 21:42
> Does the attached help pippin - should be a replacement spotifyd for
> osx.

Might be good: skipped through about 120 tracks without a single glitch.
Switched back to the released version and got the first broken artwork
after about 20-30 tracks, then pretty frequently (should probably have
wiped the cache to get quicker results).

--

Michael

mherger
2014-10-14, 21:45
> Is that with any plugin? I think I previously found that unplayable
> tracks only turned up when I had both plugins installed to allow me to
> play different tracks on different players. When I uninstalled the
> Logitech plugin the problem went away. Can I now install both plugins
> and avoid unplayable tracks?

The underlying problem should be independent of the plugin you use: if
SmartMix adds rubbish, then the plugin can't do much about it.

--

Michael

pippin
2014-10-15, 03:51
Might be good: skipped through about 120 tracks without a single glitch.
Switched back to the released version and got the first broken artwork
after about 20-30 tracks, then pretty frequently (should probably have
wiped the cache to get quicker results).


Same here. Looks good. I've been seeing one or two broken images but those were thumbnails only (while the full scale image loaded correctly) so I think the broken ones simply had been cached versions previously created by the old spotifyd.
With the old spotifyd the image is always broken for both the thumbnail and the full-scale artwork.

Triode
2014-10-15, 11:59
Same here. Looks good. I've been seeing one or two broken images but those were thumbnails only (while the full scale image loaded correctly) so I think the broken ones simply had been cached versions previously created by the old spotifyd.
With the old spotifyd the image is always broken for both the thumbnail and the full-scale artwork.

OK thanks - I'll do a bit more testing myself and then hopefully release at the weekend (its a pain to build all the binaries!)

janus
2014-10-15, 14:15
Hi i just upgraded to version 1.5.0 but now nothing gets added to my playlist. I use only Spotify as my music source. I dont know what happened. Please advise. Thanks!

mherger
2014-10-15, 14:34
> Hi i just upgraded to version 1.5.0 but now nothing gets added to my
> playlist. I use only Spotify as my music source. I dont know what
> happened. Please advise. Thanks!

Please enable logging for plugin.smartmix, try a few ways to start a
mix, then report what exactly you did, and what the server.log is reporting.

--

Michael

janus
2014-10-16, 06:12
> Hi i just upgraded to version 1.5.0 but now nothing gets added to my
> playlist. I use only Spotify as my music source. I dont know what
> happened. Please advise. Thanks!

Please enable logging for plugin.smartmix, try a few ways to start a
mix, then report what exactly you did, and what the server.log is reporting.

--

Michael

Hi thanks for the prompt reply. I just started playing a track from Spotify. Got the following logs (I set to DEBUG mode for SmartMix log):
[14-10-16 15:05:45.1803] Plugins::SmartMix::Plugin::onPlaylistChange (1291) Received command playlist loadtracks
[14-10-16 15:05:45.1812] Plugins::SmartMix::Plugin::onPlaylistChange (1292) While in mode: new!, from LivingRoom
[14-10-16 15:05:45.1822] Plugins::SmartMix::Plugin::onPlaylistChange (1342) Cyclic mode ending due to playlist: playlist loadtracks command
[14-10-16 15:05:45.4361] Plugins::SmartMix::Plugin::onPlaylistChange (1291) Received command playlist newsong
[14-10-16 15:05:45.4371] Plugins::SmartMix::Plugin::onPlaylistChange (1292) While in mode: new!, from LivingRoom
[14-10-16 15:05:45.4383] Plugins::SmartMix::Plugin::neverStopTheMusic (1355) 0 songs remaining, songIndex = 0
[14-10-16 15:05:45.4401] Plugins::SmartMix::Plugin::neverStopTheMusic (1387) Auto-mixing from random tracks in current playlist
[14-10-16 15:05:45.4419] Plugins::SmartMix::Plugin::createMix (797) Starting dynamic mix using: { track_id => ["spotify-WW:track:3SaIsrEzrQGDcG1jCeaK8q"] }
[14-10-16 15:05:45.4436] Plugins::SmartMix::API::_call (298) Async API call: GET http://developer.echonest.com/api/v4/playlist/dynamic/create?song_id=spotify-WW%3Atrack%3A3SaIsrEzrQGDcG1jCeaK8q&bucket=id%3Aspotify-WW&bucket=tracks&type=song-radio&distribution=wandering&api_key=*
[14-10-16 15:05:47.6547] Plugins::SmartMix::API::_getResponseBody (357) x-ratelimit-limit: 120
[14-10-16 15:05:47.6557] Plugins::SmartMix::API::_getResponseBody (357) x-ratelimit-remaining: 110
[14-10-16 15:05:47.6566] Plugins::SmartMix::API::_getResponseBody (357) x-ratelimit-used: 10
[14-10-16 15:05:47.6619] Plugins::SmartMix::API::_call (298) Async API call: GET http://developer.echonest.com/api/v4/playlist/dynamic/feedback?session_id=168534774eac47bcb7d5d294821a51 df&play_song=SOWAICW13D43D1DBF8&play_song=SOEEGFZ133EB86A1E2&play_song=SOLUPKJ1449100EEBC&play_song=SOPBNHE1312A8AC177&play_song=SOBVYHU13271F5D008&play_song=SOPSZAP13C6761CD08&play_song=SOILUDZ13D4336FD73&play_song=SOFCATD13134395FEF&play_song=SOWRMBF12AB0184C19&play_song=SOYLBLK14121826CB1&play_song=SOANKFQ1312A8A88DF&play_song=SOQRJBD13E89554BC0&play_song=SOHIQFP1312FDFF85E&play_song=SODIUSV13FEBC05633&play_song=SOYEYMS143864102D6&play_song=SOWAIMR14490F243C7&play_song=SOMYWXR137590DA59B&play_song=SOEPZKA1412174C46D&play_song=SODDCVM141A2548E5A&play_song=SOMHDLO12AB0183F66&play_song=SOAQORI131712D2D27&play_song=SOLLHUB1373B303ECF&play_song=SOPSXAF1375926EC80&play_song=SOQMRON13D46D0B81A&play_song=SOENBTY1311AFD6E44&play_song=SOPCVRN13F6549DE3E&play_song=SOLSFUY12A6D4F61E9&play_song=SOATIZO130516DF23D&play_song=SODQFLK12A8C131E11&play_song=SOCGIBI1311AFDF442&play_song=SOXLMEU13B0DE6D5AE&play_song=SODROIU146FEB055B0&play_song=SOAEUJO130516DEC19&play_song=SOOGFRM1313439C902&play_song=SOGWNET13F5A132FBD&play_song=SOLRRLI13E2E6481BB&play_song=SOBAAWW1392657D221&play_song=SOOMCHP13CF4838116&play_song=SOPAFGJ1454F44613C&play_song=SOWPXWP12AF72A47CD&play_song=SOAHTNT1313438BF5F&play_song=SODHUOU1366D72EB42&play_song=SODCDPD1312FDFC4F7&play_song=SOLVBCW130516DCD04&play_song=SOBZIES14244DD501B&play_song=SOMJAEP137761FDC3B&play_song=SOJYHOI1481916CCA6&play_song=SOCXXGI12AB0189491&play_song=SODYCQE1311AFE9102&play_song=SOFZKVF1449656AC54&play_song=SOGVHNB13609860DCE&play_song=SODRIHE1461AF70AA8&play_song=SOGVNNL12A67AE0CFB&play_song=SODAJBS135BF6EE9DA&play_song=SOELZCM135C3EF087E&play_song=SOCWKDO1315CD4770D&play_song=SODNRUA144BD011CD3&play_song=SOQIMTA13731C28484&play_song=SOQVBUY144BD05AA9F&play_song=SOTYPVT1315CD451D9&play_song=SONHGMQ13152A7047C&play_song=SOETWUB139E0A85152&play_song=SOTNSGC131343931D8&play_song=SODQUAS13A18D341BE&play_song=SOVIOLF1316771AB0D&play_song=SOMIRQI1311AFD9F53&play_song=SOMATVM12AF72A2D68&play_song=SOLYMSR130516DE270&play_song=SOGNVHK1312FE01572&play_song=SOOHPAM12A58A7FD50&play_song=SOEGHIR144E66A7DE9&play_song=SODCZVO130516DFD76&play_song=SOQNEKU12AB01870B6&play_song=SOBPUTY12A6D4F7B04&play_song=SOVVGQZ13FFC4B74DE&play_song=SOGOBFY1462DF254DF&play_song=SOSRUPR14509A7EFA1&play_song=SOIUTLA131343A0C95&play_song=SOKCJVX144CC0B4BA5&play_song=SOVCUGM1462F9404AB&play_song=SOHONFH13A7CFC5F57&play_song=SOOHBZD13CF106FDE8&play_song=SOKSMDZ13E908AEC1E&play_song=SOIQKOQ140C259B344&play_song=SOAMXVN145972A4B73&play_song=SOCVPOS144BD26F08D&play_song=SOTEFWR1366F0EE198&play_song=SOFMDYC1373FF2FD3F&play_song=SOBTDMV13C000F35C5&play_song=SOFDZBF1312A8ABC0E&play_song=SOKJTNU1371938DCC5&play_song=SOEVOKU12A8C13B5B1&play_song=SOGMSGN12A8C137955&play_song=SOKFSSW12AB01833CD&play_song=SONRSFX13B1FFC210E&play_song=SOBWQEG131712D121A&play_song=SOHNBJE13E5E6E36F3&play_song=SOSMEWM12A8C131E7E&play_song=SOVGLXN13529C89AA6&play_song=SOYNKQG13C1B4C0A10&play_song=SONQOQF1315CD46AE0&play_song=SODOVIT13777446D39&play_song=SONWESR13ADCB02395&play_song=SOJRUJQ13F850C26C5&play_song=SOMNGZC13FD2CD4146&play_song=SOFHZZE136732EBFC3&play_song=SOKUOIS13ECF8601FB&play_song=SOMFCOV1445A85D022&play_song=SOKDPWO1444128E022&play_song=SOJTWTQ1405663679E&play_song=SOVEVMX1338A5D29B8&play_song=SOMBZAQ13105FA49CA&play_song=SOHSIIP144BD25D672&play_song=SOBWAHO13AD1AE1C5C&play_song=SOGOMSM13F850FA0E9&play_song=SOCLLDG1423B9089F2&play_song=SODPYCT1377A5DC691&play_song=SOBYODX1311AFE253A&play_song=SOITCMB14606726419&play_song=SOASZAR1313438D9BE&play_song=SOPBBGK144BF6E6150&play_song=SOBEUPC144AFC66BFD&play_song=SOSRZEW1315CD4762E&play_song=SOEMXEO12AF729EDBB&play_song=SODZHSH1315CD46F43&play_song=SOIBCQC144B2C52279&play_song=SOGDZQW13A7C21C9BF&play_song=SOAKHIR1478A88689B&play_song=SOJNMDQ144BD204420&play_song=SODYXDA13134395ECF&play_song=SOHJOMW144AF6CE827&play_song=SOIJMJT1311AFEA249&play_song=SOFNHCQ12AF72A97C4&play_song=SOTIVFG144BD21E15D&play_song=SOAEVBY136016E2366&play_song=SOBNMKJ12AF72A8E32&play_song=SOSSIHK144BD214811&play_song=SOFRYFL1338A5D30FF&play_song=SOUXSTS145B465084C&play_song=SOOGXIR137699D142A&play_song=SOARSJD1376D392AEF&play_song=SOGRDBD12B3A1465C0&play_song=SOGBLOM12A8C132F32&play_song=SOYWHGG137665B1767&play_song=SOATSKR1460645A8FD&play_song=SONYNAX145B0AC8DF7&play_song=SOACARQ135CAA195DA&play_song=SOAKXID1460CB3A767&play_song=SOKFCWF12A6D4F7EF4&play_song=SOSYGDQ144BE84E5EA&play_song=SOJNYFL14602081E21&play_song=SOVEIPZ1366CBBCADE&play_song=SODMXPU144BDD02BC9&play_song=SOHLMYN144E5F9632B&play_song=SODNWIM1312FDFCEB3&play_song=SOCRCQA1311AFD7D32&play_song=SOFFXWC136D248D197&play_song=SOEVAGF12A8C131803&play_song=SOIQWPM135C204B2CB&play_song=SOAZBVF12A6D4FD5B5&play_song=SOBDSWJ12A58A76D35&play_song=SOSPUVK145FDFF4DD0&play_song=SOESPWT12A6D4FB698&play_song=SOFTHBE145B04386A6&play_song=SOVPWLD1373E964B2D&play_song=SOHGLLR135CA9AE00F&play_song=SODIBHY12AB018716B&play_song=SOAKIVE13D661C1155&play_song=SODQPVC13762D20371&play_song=SOBNSFZ144BD1F78BE&play_song=SOAHHKT12A6D4FA422&play_song=SOSUCSV1460FB740BA&play_song=SOAFFAS144C0091958&play_song=SOWSNNM144B06E5C39&play_song=SOKITWV144BF759614&play_song=SOWVVVP12A6D4F721B&play_song=SOIYIDE12AF72A0D3A&play_song=SOMAFZR135847F3A58&play_song=SOFBGEE13666864E61&play_song=SODUWOV12A6D4F803E&play_song=SOLDEZL137757FAFF1&play_song=SOBMCQF13775714C8C&play_song=SOZKSWW146EF87F479&play_song=SOZQHCC144BCFA7D5A&play_song=SOMRIGL145AFF3B228&play_song=SORTORJ1376D58AF67&play_song=SOWPLZY1338A5D62DA&play_song=SOWAMVQ145FC194954&play_song=SOONVJW135BCAAD6FC&play_song=SOMGPWW1311AFE464D&play_song=SOETAAT1316771159D&play_song=SOEHMMX14046E62DBA&play_song=SOCDVMU135A69BF8B6&play_song=SOYJNPW131677143D9&play_song=SOVXQDE12A81C232A8&play_song=SOGGZHF12A67ADE66F&play_song=SOHAJGG145A961682C&play_song=SOETHMT1315CD4767C&play_song=SORXBTU13167716629&play_song=SOPARBH144BE70D562&api_key=*
[14-10-16 15:05:47.6666] Plugins::SmartMix::Plugin::_createMixCb (858) Got dynamic playlist session_id: 168534774eac47bcb7d5d294821a51df
[14-10-16 15:05:47.6683] Plugins::SmartMix::Plugin::addTracks (1058) 0 songs remaining, songIndex = 0
[14-10-16 15:05:47.6695] Plugins::SmartMix::API::_call (298) Async API call: GET http://developer.echonest.com/api/v4/playlist/dynamic/next?session_id=168534774eac47bcb7d5d294821a51df&results=5&api_key=*
[14-10-16 15:05:48.1955] Plugins::SmartMix::API::_getResponseBody (357) x-ratelimit-limit: 120
[14-10-16 15:05:48.1964] Plugins::SmartMix::API::_getResponseBody (357) x-ratelimit-remaining: 108
[14-10-16 15:05:48.1973] Plugins::SmartMix::API::_getResponseBody (357) x-ratelimit-used: 12
[14-10-16 15:05:48.3426] Plugins::SmartMix::API::_getResponseBody (357) x-ratelimit-limit: 120
[14-10-16 15:05:48.3436] Plugins::SmartMix::API::_getResponseBody (357) x-ratelimit-remaining: 109
[14-10-16 15:05:48.3445] Plugins::SmartMix::API::_getResponseBody (357) x-ratelimit-used: 11

Please advise! Thanks!

Eric

mherger
2014-10-16, 06:39
> Hi thanks for the prompt reply. I just started playing a track from
> Spotify. Got the following logs (I set to DEBUG mode for SmartMix log):

Is this really all there is? I'm not seeing what the result of the last
call was...

--

Michael

janus
2014-10-16, 06:56
> Hi thanks for the prompt reply. I just started playing a track from
> Spotify. Got the following logs (I set to DEBUG mode for SmartMix log):

Is this really all there is? I'm not seeing what the result of the last
call was...

--

Michael

Hi yes it is all the information I saw in server.log. Did you check the uploaded file?

janus
2014-10-16, 07:00
Hi yes it is all the information I saw in server.log. Did you check the uploaded file?

Maybe this is what you searched?

[14-10-16 15:58:34.1348] Slim::Networking::IO::Select::__ANON__ (147) Error: Select task failed calling Slim::Networking::Async::HTTP::_http_read_body: illegal file descriptor or filehandle (either no attached file descriptor or illegal value): at /share/MD0_DATA/.qpkg/LogitechMediaServer/var/home/SqueezeboxServer/Slim/Networking/IO/Select.pm line 150.
; fh=Slim::Networking::Async::Socket::HTTP=GLOB(0xcc 89d30)

mherger
2014-10-16, 07:03
> Hi yes it is all the information I saw in server.log. Did you check the
> uploaded file?

Hmm... I wonder whether it's the ID I'm sending:
spotify-WW:track:3SaIsrEzrQGDcG1jCeaK8q. They changed that a while ago
to get rid of the -WW postfix, eg. spotify:track:3SaIsrEzrQGDcG1jCeaK8q.
Maybe it doesn't find tracks using the old IDs any more.

What if you started a mix based on a local track, or one of the
pre-defined recipes?

--

Michael

schwimma
2014-10-16, 07:12
first of all, i love this plugin>>> thanx!!

since last week i have an spotify premium account

following problem, when i chosse spotify and lokal sources as sources for music under options, it would not play , when i switch back to only local music it works ( but i must reboot my squeeze server)

i use the triode spotify plugin all newest version

touch with 7.8 and server with 7.81 on an qnap nas (fasc branding 4.07)

any advice?

thank you

daniel

janus
2014-10-16, 07:31
> Hi yes it is all the information I saw in server.log. Did you check the
> uploaded file?

Hmm... I wonder whether it's the ID I'm sending:
spotify-WW:track:3SaIsrEzrQGDcG1jCeaK8q. They changed that a while ago
to get rid of the -WW postfix, eg. spotify:track:3SaIsrEzrQGDcG1jCeaK8q.
Maybe it doesn't find tracks using the old IDs any more.

What if you started a mix based on a local track, or one of the
pre-defined recipes?

--

Michael

Too bad, no matter what I did, either from local track and/or recipe and/or de blender... nothing works.

If you need other log information please let me know.... thanks!


Eric

mherger
2014-10-16, 07:45
> following problem, when i chosse spotify and lokal sources as sources
> for music under options, it would not play , when i switch back to only
> local music it works ( but i must reboot my squeeze server)

Might be the aforementioned issue with spotify:track:... vs.
spotify-WW:track:... IDs. I'm hopefully going to push out another
release tonight.

--

Michael

janus
2014-10-16, 07:59
> following problem, when i chosse spotify and lokal sources as sources
> for music under options, it would not play , when i switch back to only
> local music it works ( but i must reboot my squeeze server)

Might be the aforementioned issue with spotify:track:... vs.
spotify-WW:track:... IDs. I'm hopefully going to push out another
release tonight.

--

Michael

I have more info for you, please see attached file...16507

Oh forgot to mention: no tracks ever got added to the current playlist... contrary to what the log shows...

Eric

schwimma
2014-10-16, 08:26
would be great

thanx

janus
2014-10-16, 11:45
Hi Michael,

I just installed 1.5.1 but still no mixes from 1 song off Spotify. The predefined recipe is hit or miss. Does it have to do with my setting in SmartMix? I set it first to Local Files AND Spotify. It added only mixes from my local files and no Spotify tracks. When I only set it to use Spotify no tracks were ever added. Something missing here I guessed.

Thanks a lot for the quick response and really appreciate for your time to fix it right away.... but still no mixes ;-(

Anyone had any success here with new mixes?

Thanks!

Eric

mherger
2014-10-16, 13:09
> I have more info for you, please see attached

Hmm... from this log file it seems you're trying to play from the
Blender web UI? Could you please just use the player UI, browse to My
Music/SmartMix and play eg. the Recommendations mix (as always with
plugin.smartmix set to debug)? I'm still missing log entries from your
files.

--

Michael

schwimma
2014-10-16, 22:54
Morning

smartmix not in the plugin list anymore and server always wants to reboot when i hit the plugin page...

edit: reinstalled server with lates nightly build but not able to activate any 3rd party plugin, still deactivated after reboot

because of that i had this boot rounds when using automatic plugin update?!

janus
2014-10-17, 00:13
Hi Michael,

I played the recommended mix but no music actually got played. Also no new mixes when I played one song from Spotify. Please see attached file 16510

mherger
2014-10-17, 00:27
> smartmix not in the plugin list anymore and server always wants to
> reboot when i hit the plugin page...

Well... reboot it to install the update.

--

Michael

mherger
2014-10-17, 00:50
> I played the recommended mix but no music actually got played. Also no
> new mixes when I played one song from Spotify. Please see attached file

Still nothing...

I pushed out 1.5.2 which adds nothing but more logging. Please again,
run with plugin.smartmix set to debug, try to play a mix or two, then
provide the log file (it should be much larger now). Thanks!

--

Michael

schwimma
2014-10-17, 01:21
hi

on an pc installation it seems to work (7.8.1--139xxxx)

could there be a problem with the nightly build (7.8.1--14xxxxx) and 3rd party plugins?

behavior is that i check the plug in, then he forced me to reboot but imidiatly the plug in is unchecked and not installed, but not only smartmix, none of them

schwimma

janus
2014-10-17, 01:41
> I played the recommended mix but no music actually got played. Also no
> new mixes when I played one song from Spotify. Please see attached file

Still nothing...

I pushed out 1.5.2 which adds nothing but more logging. Please again,
run with plugin.smartmix set to debug, try to play a mix or two, then
provide the log file (it should be much larger now). Thanks!

--

Michael

OKAY here you go... I played a song or two and collected the server.log for you in DEBUG mode: 16511

mherger
2014-10-17, 01:45
> on an pc installation it seems to work (7.8.1--139xxxx)

What does work? The plugin update? The SmartMix plugin? Spotify?

--

Michael

mherger
2014-10-17, 02:04
> OKAY here you go... I played a song or two and collected the server.log
> for you in DEBUG mode: 16511

Good: it's not a problem with the plugin talking to TEN to get the mix.
It does get a list of tracks. Now... what Spotify implementation are you
using? Triode's or the official one available from mysb.com?

Fire up the web UI. On the left hand side in the Radio section, there's
a "Tune In URL" item. Please paste spotify:track:45CEbemr6B7QoYxQhKcvtK
in there (make sure there's nothing left from a previous URL, or even
the leading http). Would it play? What if you tried
spotify://track:45CEbemr6B7QoYxQhKcvtK?

--

Michael

schwimma
2014-10-17, 02:06
> on an pc installation it seems to work (7.8.1--139xxxx)

What does work? The plugin update? The SmartMix plugin? Spotify?

--

Michael

both, smartmix with spotify and also the updates i will try a fallback to 7.8.1--13xxx on my NAS

janus
2014-10-17, 02:25
> OKAY here you go... I played a song or two and collected the server.log
> for you in DEBUG mode: 16511

Good: it's not a problem with the plugin talking to TEN to get the mix.
It does get a list of tracks. Now... what Spotify implementation are you
using? Triode's or the official one available from mysb.com?

Fire up the web UI. On the left hand side in the Radio section, there's
a "Tune In URL" item. Please paste spotify:track:45CEbemr6B7QoYxQhKcvtK
in there (make sure there's nothing left from a previous URL, or even
the leading http). Would it play? What if you tried
spotify://track:45CEbemr6B7QoYxQhKcvtK?

--

Michael

Yes the track plays... how come not from the mixes created by SamrtMix? Im using the triode Spotify (not from mysb.com). Do you have a fix or a reason why my player is not getting the mixes?? Thanks a lot for your help ;-)

schwimma
2014-10-17, 04:37
so, with fallback to build 139xxx i am able to activate the plugins again

unfortunatly smarttmix with spotify still not possible..time counts up but nothing to hear ( also no title or playlist shown)

btw>>> this works: spotify:track:45CEbemr6B7QoYxQhKcvtK

this not: spotify://track:45CEbemr6B7QoYxQhKcvtK?

even no local streaming till reboot

mherger
2014-10-17, 05:13
Oh, one more thing... Could you please go to Settings/Advanced/SmartMix
and check the "Spotify Country" setting? Make sure it knows the county
your registered your Spotify account in.

--

Michael

janus
2014-10-17, 05:30
Oh, one more thing... Could you please go to Settings/Advanced/SmartMix
and check the "Spotify Country" setting? Make sure it knows the county
your registered your Spotify account in.

--

Michael

Yes it is already set to the right country Im in right now (Netherlands). Has it got to do with the fact that I only choose Spotify as source and no Local Files?

mherger
2014-10-17, 05:58
> Yes it is already set to the right country Im in right now
> (Netherlands).

The same as you've configured in the Spotify settings?

> Has it got to do with the fact that I only choose Spotify
> as source and no Local Files?

That option is not available: SmartMix would either use your local files
only, or a mix of local and remote.

--

Michael

janus
2014-10-17, 06:12
> Yes it is already set to the right country Im in right now
> (Netherlands).

The same as you've configured in the Spotify settings?

> Has it got to do with the fact that I only choose Spotify
> as source and no Local Files?

That option is not available: SmartMix would either use your local files
only, or a mix of local and remote.

--

Michael


Yes same country as set in Spotify.

I can untick Local Files in Advanced -> Smart Mix -> Music Sources

Eric

mherger
2014-10-17, 06:35
> I can untick Local Files in Advanced -> Smart Mix -> Music Sources

Ah, right. Did you try with it checked? Doesn't make sense to uncheck
it, as it would potentially play the same tracks you have in your
collection, but stream them over the internet.

--

Michael

janus
2014-10-17, 06:48
> I can untick Local Files in Advanced -> Smart Mix -> Music Sources

Ah, right. Did you try with it checked? Doesn't make sense to uncheck
it, as it would potentially play the same tracks you have in your
collection, but stream them over the internet.

--

Michael

Oh yes... it actually works now... but is it possible to make it work without local tracks? I don't mind streaming from the internet all the time. Thanks for the help!

Eric

janus
2014-10-17, 06:56
Oh yes... it actually works now... but is it possible to make it work without local tracks? I don't mind streaming from the internet all the time. Thanks for the help!

Eric

But now it doesn't .... seems like Smart Mix can't find any mix for the song I just played from Spotify...

schwimma
2014-10-18, 02:38
Hi again

should i provide any log file or something?

if yes, witch one?

thanx very much

daniel

mherger
2014-10-18, 05:27
> should i provide any log file or something?

Settings/Advanced/Logging -> set plugin.smartmix to debug. Try to play a
mix. Send me your server.log file (link is on that page - please get
more than just the default 50 lines).

--

Michael

schwimma
2014-10-18, 07:04
thanx a lot

here you are...

mherger
2014-10-19, 05:20
Thanks. But unfortunately you either didn't enable debugging for for the
plugin or didn't try to play a mix. There's no trace of a mix being
requested.

Another observation: your SmartMix profile is empty. Did you ever run a
scan since you've installed the plugin?

And you should either enter your correct username/password for the
Last.fm Audioscrobbler plugin, or disable it.

Michael


Am 18.10.14 um 16:04 schrieb schwimma:
>
> thanx a lot
>
> here you are...
>
>
> +-------------------------------------------------------------------+
> |Filename: smartmix.zip |
> |Download: http://forums.slimdevices.com/attachment.php?attachmentid=16514|
> +-------------------------------------------------------------------+
>
> ------------------------------------------------------------------------
> schwimma's Profile: http://forums.slimdevices.com/member.php?userid=63428
> View this thread: http://forums.slimdevices.com/showthread.php?t=102294
>
>

Triode
2014-10-19, 10:15
Oh, like this?

http://gyazo.com/ac3e7d81c46b450cb81273d9df8c3fcf.png


[14-10-14 21:09:10.8400] Slim::Utils::Misc::msg (1343) Warning: [21:09:10.8398] Image::Scale libjpeg error: Corrupt JPEG data: premature end of data segment ((data))
[14-10-14 21:09:10.8407] Slim::Utils::Misc::msg (1343) Warning: [21:09:10.8406] Image::Scale libjpeg error: Unsupported marker type 0x7f ((data))


Are you using Triode's plugin or the official? I'm seeing this with Triode's - and this most likely is not a SmartMix issue, is it?

I've updated my plugin to 2.3.8 to hopefully resolve this issue - please let me know if you still see it.

schwimma
2014-10-20, 02:27
sorry for that but i did choose debug (also for spotify plug in) and i startted to play a mix ( classic rock)

ok did it again...

mherger
2014-10-20, 04:24
schwimma - I don't know what you're doing wrong. But this log is still
very confusing: if there wasn't the startup line mentioning "Logitech
Media Server", I would have bet that's a scanner.log file instead. Do
you distinct server.log and scanner.log files on your system?

And then, oh well, still no trace of SmartMix even trying to do a mix.
Did you go to Einstellungen/Erweitert/Logging to set plugin.smartmix to
Debug?

Michael


Am 20.10.14 um 11:27 schrieb schwimma:
>
> Triode wrote:
>> I've updated my plugin to 2.3.8 to hopefully resolve this issue - please
>> let me know if you still see it.
>
> sorry for that but i did choose debug (also for spotify plug in) and i
> startted to play a mix ( classic rock)
>
> ok did it again...
>
>
> +-------------------------------------------------------------------+
> |Filename: smartmix.zip |
> |Download: http://forums.slimdevices.com/attachment.php?attachmentid=16522|
> +-------------------------------------------------------------------+
>
> ------------------------------------------------------------------------
> schwimma's Profile: http://forums.slimdevices.com/member.php?userid=63428
> View this thread: http://forums.slimdevices.com/showthread.php?t=102294
>
>

schwimma
2014-10-20, 06:36
maybe a missunderstanding

enclosed some screenshots of what i have done

mherger
2014-10-20, 23:16
Ok, that's fine as far as settings go. But did you actually try to play
a mix with those settings enabled, and before you sent the log file?

Am 20.10.14 15:36, schrieb schwimma:
>
> maybe a missunderstanding
>
> enclosed some screenshots of what i have done
>
>
> +-------------------------------------------------------------------+
> |Filename: screenshots.zip |
> |Download: http://forums.slimdevices.com/attachment.php?attachmentid=16523|
> +-------------------------------------------------------------------+
>
> ------------------------------------------------------------------------
> schwimma's Profile: http://forums.slimdevices.com/member.php?userid=63428
> View this thread: http://forums.slimdevices.com/showthread.php?t=102294
>
>

schwimma
2014-10-21, 00:02
ah, maybe the sequence was the problem

1.configure log

2.play mix

3.open log

another try

sorry for that

mherger
2014-10-21, 00:28
You seem to have enabled debugging for server.plugins, but not
plugin.smartmix. I still don't see any activity there...

Want to start a thread in the German forum?

Am 21.10.14 09:02, schrieb schwimma:
>
> ah, maybe the sequence was the problem
>
> 1.configure log
>
> 2.play mix
>
> 3.open log
>
> another try
>
> sorry for that
>
>
> +-------------------------------------------------------------------+
> |Filename: Smartmix.zip |
> |Download: http://forums.slimdevices.com/attachment.php?attachmentid=16526|
> +-------------------------------------------------------------------+
>
> ------------------------------------------------------------------------
> schwimma's Profile: http://forums.slimdevices.com/member.php?userid=63428
> View this thread: http://forums.slimdevices.com/showthread.php?t=102294
>
>

schwimma
2014-10-21, 00:58
smartmix also was configured to debug.... strange

ok, my english performance again outs me as a german native speaker ;-)

should i open a thread?