PDA

View Full Version : Strange CPU/Memory Usage



Devin Carlen
2004-11-30, 16:09
Hi All,

I've had my squeezebox for a couple of months, and it has always had
some issues with memory and cpu utilization, especially on startup of
the slim.exe process. I've used various version (and am now using 5.4
with same results). Lately it seems to have gotten even worse,
basically to the point where it is unusable. I killed the process a
second ago after my pc pooted and was unresponsive. The slim.exe was
already consuming over 200 MB of memory and using 100% cpu time, and was
like that until I killed the process. I have a relatively small (1500
songs) archive, which as I understand it should only use about 32 megs
of memory.

Any ideas on how I can get this thing usable again?

Thanks!

-- Devin

kdf
2004-11-30, 16:52
Quoting Devin Carlen <dcarlen (AT) escapia (DOT) com>:

> Hi All,
>
> I've had my squeezebox for a couple of months, and it has always had
> some issues with memory and cpu utilization, especially on startup of
> the slim.exe process. I've used various version (and am now using 5.4
> with same results). Lately it seems to have gotten even worse,
> basically to the point where it is unusable. I killed the process a
> second ago after my pc pooted and was unresponsive. The slim.exe was
> already consuming over 200 MB of memory and using 100% cpu time, and was
> like that until I killed the process. I have a relatively small (1500
> songs) archive, which as I understand it should only use about 32 megs
> of memory.
>
> Any ideas on how I can get this thing usable again?

first thing to look for when you have this kind of thing on startup is any
shortcuts in your music library folders that might link back to somewhere else
inside the library folder tree. This causes a circular scan which causes the
memory usage to keep growing as the scan never manages to end.

it's a known bug with a few patch ideas submitted, but none seem to work
globally enough yet to make it into release.

-kdf