PDA

View Full Version : WOL Win 8.1 - advice needed



kidstypike
2014-04-20, 11:43
I acquired a new Asus Laptop with Win 8, I upgraded it to Win 8.1. After a week trying, I can't get my Squeezeboxen to wake the thing up.

I've installed nothing but LMS, which works fine.

The wireless mouse, and keyboard/mouse pad wake it no problem.

Anyone got their players to wake a Win 8 PC?

slate
2014-04-20, 12:12
You have to go to properties on your LAN interface to enable it.

Go to DeviceManager and find your LAN interface.
Then select Advanced tab.
In the list find "Wake on magic packet" and enable it

It might also be possible that you have to enable something in BIOS

kidstypike
2014-04-20, 12:29
You have to go to properties on your LAN interface to enable it.

Go to DeviceManager and find your LAN interface.
Then select Advanced tab.
In the list find "Wake on magic packet" and enable it

It might also be possible that you have to enable something in BIOS

Thanks.

I've done all the "Enable Wake on magic packet" stuff, many times, without success.

Also no joy with getting into the BIOS, I've been trying for days :( can't be done. I read this someplace: "Windows 8ís boot loader precludes any tinkering in the BIOS", unless someone here knows better?

verypsb
2014-04-20, 12:55
Windows firewall?

kidstypike
2014-04-20, 12:59
Windows firewall?

Nope, turned off to check, didn't help.
Thanks

kidstypike
2014-04-20, 13:47
OK, I found how to get into the BIOS in Win 8: http://www.askvg.com/how-to-access-and-use-windows-8-metro-boot-loader-and-advanced-boot-options/

Nothing in there seems to have anything to do with the problem though :(

NPendrigh
2014-04-20, 17:32
I have the opposite problem - the bloody thing keeps being woken up by the Touch pinging (I am guessing) the PC :(

Have you had a look at the LMS Settings?

Advanced, Prevent System Standby

kidstypike
2014-04-21, 12:54
I have the opposite problem - the bloody thing keeps being woken up by the Touch pinging (I am guessing) the PC :(

Have you had a look at the LMS Settings?

Advanced, Prevent System Standby

Prevent System Standby, default settings. This just keeps the system from sleeping when using Squeezeboxen, or scanning, which it does no problem. Laptop sleeps OK when Squeezeboxen are idle.

Players or WOL apps can't wake laptop.

reinholdk
2014-04-21, 13:46
I've done all the "Enable Wake on magic packet" stuff, many times, without success.

Can you be more specific about what you've tried?

I'm running LMS on Win7 but just checked the network adapter settings on Win8.1 and they are pretty much the same as on Win7.
There are two settings in the properties dialog of the network adapter that you need to check:
- 'Wake on magic packet' in the long list of properties on the 'Advanced' tab and
- 'Device can wake-up computer from standby' on the 'Power management' tab
(sorry, don't have an English OS at hand, so the names might be similar)

kidstypike
2014-04-21, 14:33
Can you be more specific about what you've tried?

I'm running LMS on Win7 but just checked the network adapter settings on Win8.1 and they are pretty much the same as on Win7.
There are two settings in the properties dialog of the network adapter that you need to check:
- 'Wake on magic packet' in the long list of properties on the 'Advanced' tab and
- 'Device can wake-up computer from standby' on the 'Power management' tab
(sorry, don't have an English OS at hand, so the names might be similar)

I have a windows 7 PC in front of me, with LMS installed, WOL works perfectly.

I also have a windows 8 laptop, my players and WOL apps cannot wake the laptop.

I can compare the properties for the network adapters side by side.

However, I cannot get WOL from my players to work.

Couple of images of win 8 machine's adapter attached below.

Apesbrain
2014-04-21, 17:39
There is a post at the bottom of this page about a new Realtek driver that may help:
http://answers.microsoft.com/en-us/windows/forum/windows8_1-hardware/wake-on-lan-wol-system-wakes-with-magic-packet-but/6df4cd33-4c0b-4458-8264-bff5ae398183?auth=1

kidstypike
2014-04-22, 07:04
There is a post at the bottom of this page about a new Realtek driver that may help:
http://answers.microsoft.com/en-us/windows/forum/windows8_1-hardware/wake-on-lan-wol-system-wakes-with-magic-packet-but/6df4cd33-4c0b-4458-8264-bff5ae398183?auth=1


Thanks Apesbrain, I thought I was on to something there, but sadly installing the new driver hasn't solved the problem.

Can anyone using windows 8.1 actually confirm that they can turn on their PC/laptop with their players?

reinholdk
2014-04-23, 04:57
Found an MS KB article about changes in WOL behaviour in Win8(.1):
http://support.microsoft.com/kb/2776718/en-us

Basically, it says in Win8 there's a new power state called 'hybrid shutdown', which is used by default, and WOL from this state is NOT supported. WOL is supported only from the sleep and hibernate states.

The article also describes how to disable the hybrid shutdown state, so please try to see if that solves the issue for you.

slate
2014-04-23, 05:24
That could be it... and explain why it Works for me...

When I installed my old server (win7) I just enabled WOL on the LAN interface and in power settings screen off = 5 min, sleep after 20 min. I can not recall doing anything else.

And when I setup my current server (win8) I did the same.

This way the boxes or apps wakes the server and keeps it running... I normally turn of stuff when I do not use it and so the server will go to sleep when I turn of my Touch/Receiver/Radio/piCorePlayer

kidstypike
2014-04-23, 05:27
Found an MS KB article about changes in WOL behaviour in Win8(.1):
http://support.microsoft.com/kb/2776718/en-us

Basically, it says in Win8 there's a new power state called 'hybrid shutdown', which is used by default, and WOL from this state is NOT supported. WOL is supported only from the sleep and hibernate states.

The article also describes how to disable the hybrid shutdown state, so please try to see if that solves the issue for you.

reinholdk - thanks for the continued interest. However, I've seen that article before, one of the first things I did was to disable "fast startup", it hasn't helped.