PDA

View Full Version : Trackstat on Freenas9.2.1-3



mrMuppet
2014-04-17, 13:05
Hi,

ive migrated my LMS from QNAP to FreeNAS and LMS is working fine (unbelievable FAST!) but i have problems with TRACKSTAT. The old Trackstat-data is used (i can use my old Ratings) but the Backup Function is not working anymore. I set the folder to 777 (only for testing) but it didn't help.

Any idea what i can do?

erland
2014-04-17, 14:40
Do you get any errors in the server.log ?
You will find it through LMS Settings/Advanced/Logging

mrMuppet
2014-04-18, 01:06
Oh, server.log was the right idea! It's full of Trackstat errors :
[14-04-06 14:09:07.9772] Plugins::TrackStat::Storage::saveTrack (1020) No matching alternative path found for file:///Qmultimedia/Musik/J/Jose%20Gonzalez/Veneer/CD1/11%20-%20Jose%20Gonzalez%20-%20Broken%20arrows.mp3. [14-04-06 14:09:08.0666] Plugins::TrackStat::Storage::saveTrack (1020) No matching alternative path found for file:///Qmultimedia/Musik/M/Morissette,%20Alanis/Jagged%20Little%20Pill/01%20-%20Morissette,%20Alanis%20-%20All%20I%20Really%20Want.mp3.
It's always the path from my old machine.

What can I do to rematch the files?

Gesendet von meinem Galaxy S3 mit Tapatalk.

erland
2014-04-18, 04:05
Oh, server.log was the right idea! It's full of Trackstat errors :
[14-04-06 14:09:07.9772] Plugins::TrackStat::Storage::saveTrack (1020) No matching alternative path found for file:///Qmultimedia/Musik/J/Jose%20Gonzalez/Veneer/CD1/11%20-%20Jose%20Gonzalez%20-%20Broken%20arrows.mp3. [14-04-06 14:09:08.0666] Plugins::TrackStat::Storage::saveTrack (1020) No matching alternative path found for file:///Qmultimedia/Musik/M/Morissette,%20Alanis/Jagged%20Little%20Pill/01%20-%20Morissette,%20Alanis%20-%20All%20I%20Really%20Want.mp3.
It's always the path from my old machine.

What can I do to rematch the files?

Have you changed the folder structure ?
It looks like you run the restore with "Find alternative files" option enabled and then it's supposed to find the files during the restore process as long as it's only the beginning of the path that has changed, but from the log it looks like it doesn't find the files. Could it be that the files it complains about are old files which no longer exist or where the last part of the path has changed ?

Did you following the backup/restore procedure exactly ?
http://wiki.slimdevices.com/index.php/TrackStat_plugin#Upgrade.2FReinstall

It's important that you let the normal rescan finish before you start a TrackStat restore operation and it's important to remember that the TrackStat restore happens in the background.

However, from what I understood it was the backup that didn't work ? If that's the case it sounds like this is something else than the above error messages. Can you try to perform a backup and then look in the server.log immediately afterwards and see if you get any new log entries from TrackStat during the backup.

mrMuppet
2014-04-18, 12:47
I'm not sure if I did the right restore procedure. What do I have to do to start again? Just uninstall Trackstat and rescan again and install Trackstat after that, or do I have to reset the lms too?

Gesendet von meinem Galaxy S3 mit Tapatalk.

mrMuppet
2014-04-23, 13:15
:cool:At the moment i'm doing a complete rebuild... Seems to work.

i don't know if it is a problem, but in my Server.log there is every Title that has to be rematched with Trackstat foudn twice:

[14-04-23 22:11:33.1450] Plugins::TrackStat::Storage::findObjectForMovedUrl (956) Found 2 tracks matching file:///share/Qmultimedia/Musik/E/Elton%20John_GreatestHits(2003)/42%20%20-%20Written%20In%20The%20Stars%20-%20Elton%20John,%20Leann%20Rimes%20-%20Elton%20John.mp3, picking the first one: file:///media/Musik/E/Elton%20John/Elton%20John_GreatestHits(2003)/42%20%20-%20Written%20In%20The%20Stars%20-%20Elton%20John,%20Leann%20Rimes%20-%20Elton%20John.mp3

Is this ok?

Scan is over and backup restored. After a chance of Trackstat-folder permission i can save new Backups.

I thinks everysting is right now!

Thank you Erland!