PDA

View Full Version : Strange CPU/Memory Usage



Devin Carlen
2004-11-28, 21:03
Hi All,

I've had my squeezebox for a couple of months, and it has always had
some issues with memory and cpu utilization, especially on startup of
the slim.exe process. I've used various version (and am now using 5.4
with same results). Lately it seems to have gotten even worse,
basically to the point where it is unusable. I killed the process a
second ago after my pc pooted and was unresponsive. The slim.exe was
already consuming over 200 MB of memory and using 100% cpu time, and was
like that until I killed the process. I have a relatively small (1500
songs) archive, which as I understand it should only use about 32 megs
of memory.

Any ideas on how I can get this thing usable again?

Thanks!

-- Devin

Adam White
2004-11-29, 01:23
Same thing happened to me...

My money is on a shortcut in a directory pointing back up the directory
tree, thus it all gets very recursive!

Always a good idea to occasionally wipe your cache as well.

----- Original Message -----
From: "Devin Carlen" <dcarlen (AT) escapia (DOT) com>
To: <discuss (AT) lists (DOT) slimdevices.com>
Sent: Monday, November 29, 2004 4:03 AM
Subject: [slim] Strange CPU/Memory Usage


> Hi All,
>
> I've had my squeezebox for a couple of months, and it has always had
> some issues with memory and cpu utilization, especially on startup of
> the slim.exe process. I've used various version (and am now using 5.4
> with same results). Lately it seems to have gotten even worse,
> basically to the point where it is unusable. I killed the process a
> second ago after my pc pooted and was unresponsive. The slim.exe was
> already consuming over 200 MB of memory and using 100% cpu time, and was
> like that until I killed the process. I have a relatively small (1500
> songs) archive, which as I understand it should only use about 32 megs
> of memory.
>
> Any ideas on how I can get this thing usable again?
>
> Thanks!
>
> -- Devin
>
>