PDA

View Full Version : rebuffering problem



cjfreitag
2014-03-31, 12:34
This afternoon I started getting frequent rebuffing on my Touch; this unit is connected via ethernet directly to my main router and there was not any other significant network activity. I tried stopping and starting LMS (I am running 7.8) but the problem persisted. I'm listening to ALAC files; this has not been a problem before.

When I have had rebuffering issues in the past it has been temporary, and always with online services over WiFi. I have never had issues playing local music.

I'd be grateful for any diagnostic or troubleshooting tips...

kesey
2014-03-31, 12:48
This afternoon I started getting frequent rebuffing on my Touch; this unit is connected via ethernet directly to my main router and there was not any other significant network activity. I tried stopping and starting LMS (I am running 7.8) but the problem persisted. I'm listening to ALAC files; this has not been a problem before.

When I have had rebuffering issues in the past it has been temporary, and always with online services over WiFi. I have never had issues playing local music.

I'd be grateful for any diagnostic or troubleshooting tips...

Try doing a complete "Clear Library and Rescan Everything". It's worth doing every so often when re-buffering starts occurring. After the time when the clocks change you can often get a bit of rebuffering activity with LMS, so do the re-scan and see if things improve.

chaug
2014-10-05, 15:14
I'm also starting to experience rebuffering issues (for the first time in years) so I'd be interested to hear whether a rescan solved it. My last full rescan is not that long ago (couple of weeks) so I doubt that that will change things. But I'll try anyway.

I'd also like to understand how the scan (i.e. the state of the library) is connected to the buffer issue. I find it difficult to see how one can influence the other since the library is relevant when selecting a track, but not when playing it, right? But I'm curious to learn all about whatever might cause rebuffering on a machine with loads of free CPU capacity...

garym
2014-10-05, 15:41
I'm also starting to experience rebuffering issues (for the first time in years) so I'd be interested to hear whether a rescan solved it. My last full rescan is not that long ago (couple of weeks) so I doubt that that will change things. But I'll try anyway.

I'd also like to understand how the scan (i.e. the state of the library) is connected to the buffer issue. I find it difficult to see how one can influence the other since the library is relevant when selecting a track, but not when playing it, right? But I'm curious to learn all about whatever might cause rebuffering on a machine with loads of free CPU capacity...

agree. rebuffering is most likely related to interference in wifi (new neighbor with same channel, or new microwave, etc.) or a potential problem in ethernet cabling (bad cable, bad connection at router, etc.). Also, when getting rebuffering, you might see if if is related to a synched player. I was getting some rebuffering on my transporter, and realized it was caused by my RADIO (wifi connected) which happened to be synched to the Transporter at the time.

garym
2014-10-05, 15:43
Try doing a complete "Clear Library and Rescan Everything". It's worth doing every so often when re-buffering starts occurring. After the time when the clocks change you can often get a bit of rebuffering activity with LMS, so do the re-scan and see if things improve.

yes, on *windows* machines after a change to or from daylight savings time one needs to do a clear and rescan (or at least they used to....maybe newer versions of 7.8 or 7.9 resolve this).

chaug
2014-10-05, 16:41
In my case I've quite clearly identified wifi interference as the source of the trouble. More specifically, its my new Xeo wireless speakers that are causing the trouble. Can clearly see the dip in network quality when running a network test at 1000kbps (Settings -> Advanced -> Networking) when turning the speakers on and off. Great! Now I've great sounding speakers and no more speaker cables all over the place, and but now I have to solve the interference problem. I already tried switching the frequency that the speakers use as well as that of the wifi. I also increased the wifi's bandwith from 20 Mhz to 40 Mhz but all to no avail. So I guess the only way to avoid the interferences is to either connect the SB Touch with an ethernet cable or move my wifi to the 5 GHz band (the speakers are on 2.4 GHz) by installing a dual band access point (since my router doesn't do 5 GHz). As if I had nothing else to do...

garym
2014-10-05, 16:48
In my case I've quite clearly identified wifi interference as the source of the trouble. More specifically, its my new Xeo wireless speakers that are causing the trouble. Can clearly see the dip in network quality when running a network test at 1000kbps (Settings -> Advanced -> Networking) when turning the speakers on and off. Great! Now I've great sounding speakers and no more speaker cables all over the place, and but now I have to solve the interference problem. I already tried switching the frequency that the speakers use as well as that of the wifi. I also increased the wifi's bandwith from 20 Mhz to 40 Mhz but all to no avail. So I guess the only way to avoid the interferences is to either connect the SB Touch with an ethernet cable or move my wifi to the 5 GHz band (the speakers are on 2.4 GHz) by installing a dual band access point (since my router doesn't do 5 GHz). As if I had nothing else to do...

you might try "ethernet over powerline" adapters for connecting the squeezebox back to your router. That has worked for me and many others. Then the wireless speakers won't interfere. Also note that using the 40Mhz bandwidth can sometimes create *more* problems. More cross channel interference, etc. If we and all our close neighbors switch to 40Mhh bandwidth, an already bad problem (for those with close neighbors...apartment buildings, etc.) will get much worse.

get.amped
2014-10-05, 16:53
In my case I've quite clearly identified wifi interference as the source of the trouble. More specifically, its my new Xeo wireless speakers that are causing the trouble. Can clearly see the dip in network quality when running a network test at 1000kbps (Settings -> Advanced -> Networking) when turning the speakers on and off. Great! Now I've great sounding speakers and no more speaker cables all over the place, and but now I have to solve the interference problem. I already tried switching the frequency that the speakers use as well as that of the wifi. I also increased the wifi's bandwith from 20 Mhz to 40 Mhz but all to no avail. So I guess the only way to avoid the interferences is to either connect the SB Touch with an ethernet cable or move my wifi to the 5 GHz band (the speakers are on 2.4 GHz) by installing a dual band access point (since my router doesn't do 5 GHz). As if I had nothing else to do...

Your SB Touch only does wireless-G anyway. You will likely not see any improvement with a dual band router/access point unless you connect your SBT to a 5GHz access point acting as a wireless bridge to another 5GHz access point connected to your router. Might work but starts to become an expensive (and complicated) way to replace a 100mb wired ethernet cable.

Edit: on the other hand you can afford those speakers so the cost of the WAPs is probably just noise...

chaug
2014-10-06, 13:10
Your SB Touch only does wireless-G anyway. You will likely not see any improvement with a dual band router/access point unless you connect your SBT to a 5GHz access point acting as a wireless bridge to another 5GHz access point connected to your router. Might work but starts to become an expensive (and complicated) way to replace a 100mb wired ethernet cable.

Yes, I also realized that the 5GHz idea was nonsense, since none of the Squeezeboxes supports that. Ethernet over powerline could be option. Thanks for bringing that up, garym. What I did to day, as a start, was move the SB Touch a couple of metres so that I could connect it to the router via (real) Ethernet, at least temporarily. Turns out that the rebuffering issue is gone. Probably because it SB Touch is now closer to the Router (i.e. Wifi access point). But it could also be that the speakers chose a better frequency, for some reason (perhaps because the Xeo transmitter is now also closer to the access point?).

For anybody experiencing more serious issues with this kind of setup, I'd like to point you to this addendum to the Xeo manual (http://www.dynaudio.com/int/xeo/XEO_OwnersManualA.html). It explains how you can set your speakers to use a fixed frequency. Unfortunately, Dynaudio does not tell us exactly what frequencies the speakers are capable of using and how to set them. So if anyone figured that one out, please post.



Edit: on the other hand you can afford those speakers so the cost of the WAPs is probably just noise...

I have one unused WAP anyway but it's either 2.4 or 5 GHz, but before I buy another WAP I guess those Powerline adapters are the better option, if I ever need them. No, I would never buy those speakers at their recommended selling price and not even at the current sale price. I was lucky to get them used for less than half of their original selling price.


Also note that using the 40Mhz bandwidth can sometimes create *more* problems. More cross channel interference, etc. If we and all our close neighbors switch to 40Mhh bandwidth, an already bad problem (for those with close neighbors...apartment buildings, etc.) will get much worse.

Good point. I just followed the advice provided here (http://www.pcmag.com/article2/0,2817,2405996,00.asp). I wonder, though, if setting your router to 40 MHz alone already creates more interference or whether you actually need to fully use it, which is probably only the case at certain critical moments. But since my rebuffering issue seems solved, I'll switch it back, since there are at least 20 wifis in my area.