PDA

View Full Version : How exactly does it search for iTunes files?



Keith
2004-11-27, 07:48
Thanks for that, Dean. It does look as though that might be the cause.
The Y: drive is on a Network Attached Storage device which manages it's
own security. I thought access was wide open, but it seems that might
not be the case. I've done some testing and it appears that SlimServer
is not seeing Y: at all. I'm going to do some more digging into the
NAS's security settings.


-----Original Message-----
From: discuss-bounces (AT) lists (DOT) slimdevices.com
[mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of dean
blackketter
Sent: 27 November 2004 00:30
To: Slim Devices Discussion
Subject: [slim] How exactly does it search for iTunes files?

Hi Keith,

Is it possible that the permissions for the Y: drive prevent the SYSTEM

account (which is how the SlimServer is running) from accessing the
files on that drive?

That would explain the problems you are seeing.

-dean

On Nov 26, 2004, at 11:01 AM, Keith Leng wrote:

> Could anyone suggest why SlimServer is not finding some of my iTunes
> files in the following scenario?
>
> iTunes settings
> ---------------
> iTunes Music Folder = z:\music
> "Keep iTunes Music Folder organized" - checked
> "Copy files to iTunes folder when adding to library" - unchecked
>
> SlimServer is set to "Find iTunes Library Automatically". It
> successfully finds and plays files in z:\music. However, I've recently
> added some additional files which are in Y:\Replay Radio\Recordings.
It
> doesn't see these files.
>
> I added the files to iTunes using the menu option File=>"Add Folder to
> Library".
>
> iTunes can see and play these files without any problem. The iTunes
xml
> file entries seems fine. They all correctly point to the relevant
files
> on the Y: drive.
>
> I set up an iTunes playlist which includes files from z:\music and
> files
> from y:\Replay Radio\Recordings. SlimServer sees the playlist and it
> sees the files from z:\music. It doesn't see the files on the Y:
drive.
>
> If I create an iTunes playlist that includes only files from the Y:
> drive, SlimServer sees the playlist but reports that it's empty.
>
> I've tried stop/start/rescan etc. with no luck.
>
> Any ideas would be much appreciated.
>
>
> Keith
>
>
>
>