PDA

View Full Version : Debain package repository for LMS 7.8 and Squeezebox firmware



lordgibbness
2014-01-03, 12:16
Hi all

I am running LMS 7.8 on my Ubuntu server with my sources.list setup to install the nightly version whenever I run an upgrade of the OS. Details of this are described here: http://wiki.slimdevices.com/index.php/Debian_Package

Basically, I have added "deb http://debian.slimdevices.com unstable main" to the file.

However, my Touch and Radio devices are still using firmware 7.7.2 and if you go to the software update menu item, they state that the latest firmware is installed.

Is this issue caused by the fact that the firmware for the Touch and Radio are not in the debian package in the repository?

Any ideas how to install the new firmware?

thanks
Rob.

aubuti
2014-01-03, 13:04
If you look at the firmware download site (http://update.slimdevices.com/update/firmware/7.8.0/) you'll see that the firmware for the Radio (baby) is supposedly unchanged since 7.7.2.

On the other hand, the Touch (fab4) does appear to have new firmware to go with LMS 7.8.0 (r16739). But I notice that my Touch is still reporting that it has 7.7.2 r9663 and claims that it's the latest, even though I downloaded the deb package from the nightly download site (http://downloads.slimdevices.com/nightly/?ver=7.8) just about a week ago.

So it seems that there may be an issue with the packaging of the Touch firmware in 7.8, and not limited to the debian repo.

lordgibbness
2014-01-03, 17:11
Do you know if there is any way of forcing the player to find a new firmware?

I have tried placing the files from here: http://update.slimdevices.com/update/firmware/7.8.0/

in the following locations without any luck:

/var/lib/squeezeboxserver/cache/updates
/usr/share/squeezeboxserver/Firmware

Is there a config file somewhere that defines where the firmware is located?

thanks
Rob.

Mnyb
2014-01-04, 03:42
At the same location you also find a version file it is that one that tells LMS that's it time to update .

So just place the new fw file and version file in updates folder and restart LMS .

lordgibbness
2014-01-04, 05:07
Hi that's what I had done earlier - copied all the files (bin, version, sha) to the update cache, and restarted the Touch and the LMS, but it still doesn't seem to find the new firmware .

bonze
2014-01-04, 06:24
Hi that's what I had done earlier - copied all the files (bin, version, sha) to the update cache, and restarted the Touch and the LMS, but it still doesn't seem to find the new firmware .Have you tried stopping LMS, then emptying the cache/update folder, and then restarting LMS ?
It should then go looking for the latest.

lordgibbness
2014-01-04, 17:17
Yeah it was originally empty before I copied the firmware updates into the directory? Also, I have now removed the firmware files from the two directories mentioned above, after I couldn't get it to work.

Has anyone managed to update the Touch/Radio to firmware 7.8 and has a way to do this?

FYI my LMS version is:-

Logitech Media Server Version: 7.8.0 - 1387542508 @ Sat Dec 21 19:06:08 PST 2013
Operating system: Debian - EN - utf8
Platform Architecture: x86_64-linux
Perl Version: 5.14.2 - x86_64-linux-gnu-thread-multi
Database Version: DBD::SQLite 1.34_01 (sqlite 3.7.7.1)

aubuti
2014-01-04, 18:59
It has been a long time since I've done this, but isn't it possible to update the Touch's firmware via a USB stick? That is, copy the firmware file to a USB stick (root directory), insert the stick in the Touch, do the Touch's Settings > Advanced > Software Update menus, and then be prompted (and accept) to use the USB as the source. Using a SD card should work similarly.

Mnyb
2014-01-04, 23:36
It has been a long time since I've done this, but isn't it possible to update the Touch's firmware via a USB stick? That is, copy the firmware file to a USB stick (root directory), insert the stick in the Touch, do the Touch's Settings > Advanced > Software Update menus, and then be prompted (and accept) to use the USB as the source. Using a SD card should work similarly.

Yes it is , and it is also possible to update manually from LMS in the same menu .

There is an issue if software updates is disabled in LMS settings , it does not automatically find new content in the update folder.

lordgibbness
2014-01-05, 05:55
Ah thanks - that was the cause of my issue it appears. I had the software updates option disabled in the LMS settings.

After enabling that I have now updated the Touch firmware. It seems that all other firmwares (e.g. Radio, Boom, Classic) remain on the existing versions.

thanks for your help

Rob.

lordgibbness
2014-01-05, 08:00
By the way - do you know where the changelog for the firmware is, as I didn't see anything under the main changelog for LMS 7.8?

cheers
Rob.

rmac321
2014-05-23, 23:58
edit: oops, posted in wrong thread. sorry for the distraction...