View Full Version : Squeezebox classic - no display, but getting detected under available wifi-networks

2013-10-29, 02:14
Hello everyone!

am from Mumbai, India, and have just registered here. i seek some assistance from the members on an issue, that seems to have been beaten to near-death on this and on other forums, but still, would like to invite suggestions with regards to the particular issues am facing.

i recently got a Squeezebox Classic from a friend. he had got it purchased and delivered from the US. he also had got a step-up transformer with it, to connect it to the the power-supply here (its 220-240V here). but he didn't send me the transformer in the box (due to its bulkiness).

now when i connected the player to the bundled adapter (which was rated for an I/P voltage of 100-120V), and put in the adapter in one of the outlets of my Belkin spikeguard, the adapter instantaneously made a 'swoosh' sound, and fumes and a burning-smell started emanating out of it! i immediately took it out. i then ordered another adapter of the same-rating online, and got it delivered in a few days (5V DC 2A; however, I/P voltage-rating remains the same Indian standard, ie, 220-240V). so now, the red TOSLink light at the back of the squeezebox does light up, but no sort of display comes up on the VFD.

after going through a few other threads, i did the following as well:

- checked the innards of the SB. all solderings looked good. no signs of any burning or blown-up transistors or anything.

- the wifi-card was seated properly, as well as the daughter-board. but i still took out the daughter-board out of its connector, and re-seated it again, as firmly as was possible, within safe-limit.

- took out the wifi-card and connected to my router through LAN, but still, no display.

- tried the factory-reset by pressing the 'add' button on the remote while re-plugging the power-connector, but to no avail.

- tried pressing '1' while powering it up - no use.

- pressed 'brightness' button too - no use.

a few points worth noting:

- connected the earlier, bundled adapter, that had emanated fumes earlier, again, to the SB, for a few seconds, and no such thing this time, though i could hear slight 'swooshing' noise again, so i immediately took it out. the TOSLink light was lit up.

- the power-connector of the new adapter doesn't go all the way in inside the power-pin hole. it stays half-out, unlike the power-connector of the bundled adapter.

- the player does get detected on my wifi-network when the wifi-card is still placed inside the SB, but my router doesn't assign any IP to it, even when connected with an ethernet-cable to the router. i read something related to this on some thread, hence mentioning this point.

- i wish to use the SB in conjunction with a Seagate Goflex Home dock, with debian and squeezeplug loaded onto it.

- the device does get quite warm if left connected with the new power-adapter and ON. the TOSLink light stays lit up. and coupled with the fact that the player is getting detected in my wifi-network, i could safely say that its not dead. more so, because it was working just fine with the earlier user (he must be using it with the step-up transformer).

so, logically speaking, am getting a feeling that its something to do with the PSU or the VFD, or both of these things. i will head to some good technician for a check-up of the adapter and the player, if you would suggest.

sorry for the long write-up! would very much appreciate your replies.