Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 6 123 ... LastLast
Results 1 to 10 of 59
  1. #1
    Junior Member
    Join Date
    Jun 2013
    Posts
    20

    Logitech Media Server and Mac OS Mavericks

    Hello,

    I use since yesterday Apples new OS X aka Mavericks DP2.
    But now my Media Server wont starting. In DP1 everything was ok, no problems.
    I think that has to do with Perl 5 Subversion 16. Anybody has a tip or
    solution for that? Thanks in advance.
    cu aM

    P.S. Trying with Logitech Media Server 7.7.2/7.7.3/7.8

  2. #2
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,837

    Logitech Media Server and Mac OSMavericks

    > I use since yesterday Apples new OS X aka Mavericks DP2.
    > But now my Media Server wont starting. In DP1 everything was ok, no
    > problems.


    Did you set it to start automatically? Doesn't it start at all? Please
    check the server.log file.

    > I think that has to do with Perl 5 Subversion 16.


    When I ran a test about two weeks ago everything was fine. Did they update
    Perl in DP2?

    --

    Michael

  3. #3
    Junior Member
    Join Date
    Jun 2013
    Posts
    20
    Quote Originally Posted by mherger View Post
    Did you set it to start automatically? Doesn't it start at all? Please
    check the server.log file.
    yes, automatically ů I'll check the logs. Where is it on Mac?
    When I ran a test about two weeks ago everything was fine. Did they update
    Perl in DP2?
    I think so, because it was not with DP1 like that

  4. #4
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,837

    Logitech Media Server and Mac OSMavericks

    > yes, automatically ÔÇŽ I'll check the logs. Where is it on Mac?

    No need to check: I can confirm that they updated perl to 5.16 - which we
    don't provide binaries for :-(. Now I know what I'm going to do next week.

    >> When I ran a test about two weeks ago everything was fine. Did they
    >> update Perl in DP2?

    > I think so, because it was not with DP1 like that


    Did you update your previous installation of Mavericks, or did you install
    the DP2 on a clean system? I'm asking because my system still has Perl
    5.12 on board. But I guess that's a left-over from updating DP1 to DP2. I
    doubt we can rely on 5.12 being around in the release builds.

    --

    Michael

  5. #5
    Junior Member
    Join Date
    Jun 2013
    Posts
    20
    Quote Originally Posted by mherger View Post
    Now I know what I'm going to do next week
    fine, can't wait

    .
    Did you update your previous installation of Mavericks
    yes, I did
    cu aM

  6. #6
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,837

    Logitech Media Server and Mac OSMavericks

    >> Now I know what I'm going to do next week
    >>

    > fine, can't wait


    I got something working - without the media scanner (music only):

    Logitech Media Server Status
    Logitech Media Server Version: 7.7.3 - TRUNK @ UNKNOWN
    Hostname: pc-00091.herger.net
    Server IP Address: 192.168.0.91
    Server HTTP Port Number: 9000
    Operating system: OS X 10.9 - EN - utf8
    Platform Architecture: x86_64
    Perl Version: 5.16.2 - darwin-thread-multi-2level
    Database Version: DBD::SQLite 1.34_01 (sqlite 3.7.7.1)
    Total Players Recognized: 1

    Library Statistics
    Total Tracks: 3,725
    Total Albums: 493
    Total Artists: 208
    Total Genres: 63
    Total Playing Time: 280:09:50

    Media Scan Details
    Discovering files/directories: /Volumes/M├â┬ĄcBuchPro/Users/mh/Music (5076
    of 5076) Complete 00:00:01
    Scanning new music files: /Volumes/M├â┬ĄcBuchPro/Users/mh/Music (3635 of
    3635) Complete 00:00:24
    Discovering playlists: /Users/mh/Music/Playlists (1 of 1) Complete
    00:00:00
    iTunes Import (3699 of 3699) Complete 00:00:05
    iTunes Playlist Import (21 of 21) Complete 00:00:01
    Pre-caching Artwork (286 of 286) Complete 00:00:05
    The server has finished scanning your media library.
    Total Time: 00:00:36 (Friday, June 28, 2013 / 5:14 PM)


    What I'll have to work on next week:
    - fix Media::Scan - currently LMS is limited to audio files on 10.9
    - Image::Scale currently is using standard libjpg instead of
    libjpeg-turbo, taking a performance hit. Unfortunately this needs a newer
    nasm, which would only be available through macports - which is not
    available for Mavericks yet... This isn't a deal breaker, just using a
    slower library (they say 2-4x slower).
    - I'm getting tons of warnings during the binaries' builds which I'd like
    to better understand before publishing.

    Are you running 7.7 or 7.8?

    --

    Michael

  7. #7
    Junior Member
    Join Date
    Jun 2013
    Posts
    20
    Thank you The last version I try is 7.8

    Where can I find your version?
    cu aM

  8. #8
    Junior Member
    Join Date
    Jun 2013
    Posts
    20
    do you get ahead?
    cu aM

  9. #9
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,837

    Logitech Media Server and Mac OSMavericks

    > do you get ahead?

    Would you be familiar using git to get the latest code and test run it
    from the console? I will get back to this later today.

    --

    Michael

  10. #10
    Junior Member
    Join Date
    Jun 2013
    Posts
    20
    Quote Originally Posted by mherger View Post
    Would you be familiar using git ů
    no, not on mac :-/
    cu aM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •