Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 56 1231151 ... LastLast
Results 1 to 10 of 555
  1. #1
    Senior Member
    Join Date
    Apr 2005
    Posts
    8,410

    Announce: Local Player plugin and Squeezelite for Linux/Windows/OSX

    The Local Player plugin provides local playback capability from the server computer.

    Local Player installs a playback application (squeezelite) on the server computer which is automatically run by the server and which can be controlled via the web interface or other squeezebox control applications. It is intended to simplify the installation and configuration of the squeezelite by installing it via a plugin.

    Squeezelite is a new headless (no user interface) software emulation of a squeezebox which supports high resolution playback, gapless, crossfade and most other squeezebox playback features. It was originally written for linux and has been discussed on the linux forum: http://forums.slimdevices.com/showth...ux-(alsa-only). It now supports Windows and OSX too.

    To install please look in the "Other 3rd party plugins" list on the LMS plugins page.

    The plugin should install the relevant version of squeezelite for your server machine and then automatically start it. On linux it supports intel and arm machines. For arm you will need to visit the settings page to select the appropriate architecture (armv5te, armv6, armv6hf). You can select the audio output to use from the settings page.

    In some cases linux users will need to add the server user to the audio group to allow squeezeplay access to the audio output device.

    Please note the plugin download does not include all codecs. On linux use your normal distribution installation process to install the libraries given on the setting page. On windows/osx wav,aif and flac are supported by default. Other codecs are supported via the server transcoding.

    Squeezelite binaries may also be downloaded direct from here: http://code.google.com/p/squeezelite/downloads/list if you want to run it on other machines. Note there are no controls other than the command line options - it is controlled from the server using your favourite control application or web interface.

    Please try and post feedback here.
    Last edited by Triode; 2013-01-05 at 11:48.

  2. #2
    Senior Member pippin's Avatar
    Join Date
    Oct 2007
    Location
    Berlin
    Posts
    14,183
    Cool, have been looking for this
    Not so much for myself, but it will help a lot to support it for others.

    You use lame for decoding, too?
    Last edited by pippin; 2013-01-05 at 10:45.
    ---
    learn more about iPeng, the iPhone and iPad remote for the Squeezebox and
    Logitech UE Smart Radio as well as iPeng Party, the free Party-App,
    at penguinlovesmusic.com
    New: iPeng 9, the Universal App for iPhone, iPad and Apple Watch

  3. #3
    Senior Member
    Join Date
    Apr 2005
    Posts
    8,410
    Quote Originally Posted by pippin View Post
    You use lame for decoding, too?
    I'm currently using mad, but didn't include the dll in the download - hence the need for lame on the server.

    Considering libmpg123 - any views on this vs mad?

  4. #4
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    2,356
    Installed Squeezelite on a Windows 7 PC, playing flac files no problem.
    Doesn't play mp3's though, how do I check that I have lame installed?
    Last edited by kidstypike; 2013-01-05 at 11:48.
    Study/Server - LMS 7.9.1 - Raspberry Pi3/Pi screen/HiFiBerry DAC+/piCorePlayer 3.22/jivelite, 25K library on WDMyCloud, cache and playlists on a USB stick (formatted ntfs).
    Lounge - RPi 2/Max2Play > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Boom
    Garage - Radio
    In car - LMS 7.9.1 > RPi3/Max2Play/Access Point plugin > HiFiBerry DAC+ > car's hifi (files on a 2TB portable USB drive)
    Spares - 1xTouch, 1xSB3

  5. #5
    Senior Member
    Join Date
    Apr 2005
    Posts
    8,410
    Quote Originally Posted by kidstypike View Post
    Installed Squeezelite on a Windows 7 server, playing flac files no problem.
    Doesn't play mp3's though, how do I check that I have lame installed?
    Actually I think this may not work at present - I was assuming the server would decode, but it looks like it won't.

  6. #6
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    2,356
    Quote Originally Posted by Triode View Post
    Actually I think this may not work at present - I was assuming the server would decode, but it looks like it won't.
    Thanks, I've plenty flac file to play.
    Study/Server - LMS 7.9.1 - Raspberry Pi3/Pi screen/HiFiBerry DAC+/piCorePlayer 3.22/jivelite, 25K library on WDMyCloud, cache and playlists on a USB stick (formatted ntfs).
    Lounge - RPi 2/Max2Play > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Boom
    Garage - Radio
    In car - LMS 7.9.1 > RPi3/Max2Play/Access Point plugin > HiFiBerry DAC+ > car's hifi (files on a 2TB portable USB drive)
    Spares - 1xTouch, 1xSB3

  7. #7
    Senior Member pippin's Avatar
    Join Date
    Oct 2007
    Location
    Berlin
    Posts
    14,183
    Quote Originally Posted by Triode View Post
    I'm currently using mad, but didn't include the dll in the download - hence the need for lame on the server.

    Considering libmpg123 - any views on this vs mad?
    No, mad is what I know, too. But didn't know it uses lame. All these dependencies....
    ---
    learn more about iPeng, the iPhone and iPad remote for the Squeezebox and
    Logitech UE Smart Radio as well as iPeng Party, the free Party-App,
    at penguinlovesmusic.com
    New: iPeng 9, the Universal App for iPhone, iPad and Apple Watch

  8. #8
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    2,356
    Another problem:
    If I press play on an album, track 2 starts to play.
    If I then press >> it skips to track 4, press >> again and it skips to track 6 etc.. etc..

    All other players are fine.
    Study/Server - LMS 7.9.1 - Raspberry Pi3/Pi screen/HiFiBerry DAC+/piCorePlayer 3.22/jivelite, 25K library on WDMyCloud, cache and playlists on a USB stick (formatted ntfs).
    Lounge - RPi 2/Max2Play > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Boom
    Garage - Radio
    In car - LMS 7.9.1 > RPi3/Max2Play/Access Point plugin > HiFiBerry DAC+ > car's hifi (files on a 2TB portable USB drive)
    Spares - 1xTouch, 1xSB3

  9. #9
    Senior Member
    Join Date
    Apr 2005
    Posts
    8,410
    Quote Originally Posted by kidstypike View Post
    Another problem:
    If I press play on an album, track 2 starts to play.
    If I then press >> it skips to track 4, press >> again and it skips to track 6 etc.. etc..

    All other players are fine.
    What format? When you say press >> what interface is this on? Are there any errors in the server log?

  10. #10
    Senior Member chill's Avatar
    Join Date
    Mar 2007
    Posts
    511
    Hi Triode

    I installed this on my Mac mini server (OS X 10.6.8) running LMS 7.8.0 and it seems to work well. The install ran with no problems, and it plays my FLACs fine. As I think you're expecting, it doesn't play MP3s. It does play the 320k OGGs from your Spotify plugin though - was that expected?

    Can the local player be killed and restarted conveniently? As defined by the 'Sound' preference pane, the sound is currently going from my Mac to the USB input on my DAC, which is perfect, but out of interest I tried changing the output to the internal speaker or the TV on the HDMI port, and the only way I could find to make it switch was to stop and restart LMS. I tried 'powering off' the local player using the web interface and restarting it, but that didn't work - I suspect that's because the local player picks the output device defined by the preference pane at startup, and simply powering down the local player doesn't cause it to recheck the output device.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •