I am trying to re-build the firmware for the Touch using

I get the following error while configuring package libdbd-sqlite-perl-1.34 :

NOTE: Running task 774 of 1504 (ID: 1092, /home/pierre/Desktop/poky/meta-squeezeos/packages/perl/libdbd-sqlite-perl_1.34.bb, do_configure)
NOTE: package libdbd-sqlite-perl-1.34: started
NOTE: package libdbd-sqlite-perl-1.34-r18: task do_configure: started
ERROR: function do_configure failed
ERROR: log data follows (/home/pierre/Desktop/poky/build/tmp-fab4/work/armv6-none-linux-gnueabi/libdbd-sqlite-perl-1.34-r18/temp/log.do_configure.22486)
| DBI 1.57 is required to configure this module; please install it or upgrade your CPAN/CPANPLUS shell.

Did someone else encounter this error ?
How can it be fixed ?

Thanks a lot in advance for any help.