Home of the Squeezebox™ & Transporter® network music players.
Page 326 of 327 FirstFirst ... 226276316324325326327 LastLast
Results 3,251 to 3,260 of 3263
  1. #3251
    Junior Member
    Join Date
    May 2017
    Posts
    11

    Player goes silent after a couple of seconds..

    I have a two Raspberry PI's one which has a Kali Reclocker + Piano 2.1 DAC and at the other with the JustBoom DAC. The first one has an SSD with my music library and is running the 7.9.1 LMS and the Squeezelite player, the second just has the player.

    I'm just getting started with LMS and have been using the Max2Play server and player image on the RPI's. I have one RPI as both a server and a player and this one works fine, but the other RPI that is accessing the remote LMS only plays a few seconds of a track before it goes silent . However SqueezePad on my iPad works fine accessing the server as does Squeezeplay on my Mac... both playing tracks with no problems.

    It was suggested that I add -s nameofmyserver.local to the squeezelite command line, so I did :

    -o hw:CARD=sndrpijustboomd -V Digital -Q -s myserver.local

    But this made no difference.

    I have tried everything else I can think of but I'm now stumped and it seems my only solution will be to use a local server on both RPI's but that can't be right....

    ...any help would be much appreciated :-)
    Last edited by anotbot; 2017-05-18 at 08:58.

  2. #3252
    Senior Member
    Join Date
    Nov 2010
    Location
    Hertfordshire, UK
    Posts
    2,468
    Quote Originally Posted by anotbot View Post
    I have a two Raspberry PI's one which has a Kali Reclocker + Piano 2.1 DAC and at the other with the JustBoom DAC. The first one has an SSD with my music library and is running the 7.9.1 LMS and the Squeezelite player, the second just has the player.

    I'm just getting started with LMS and have been using the Max2Play server and player image on the RPI's. I have one RPI as both a server and a player and this one works fine, but the other RPI that is accessing the remote LMS only plays a few seconds of a track before it goes silent . However SqueezePad on my iPad works fine accessing the server as does Squeezeplay on my Mac... both playing tracks with no problems.

    It was suggested that I add -s nameofmyserver.local to the squeezelite command line, so I did :

    -o hw:CARD=sndrpijustboomd -V Digital -Q -s myserver.local

    But this made no difference.

    I have tried everything else I can think of but I'm now stumped and it seems my only solution will be to use a local server on both RPI's but that can't be right....

    ...any help would be much appreciated :-)
    I guess it can't be a firewall issue, nor the server address, since it does play, albeit only for seconds. Have you any debug logs from the remote one? I don't know what -Q does, it's not in my version's (Ralphy) help. Have you tried the JustBoom DAC on the Pi with LMS to see if it is a DAC/squeezelite issue?
    LMS 7.9.1 on VortexBox Midi box, Xubuntu 17.04, FLACs 16->24 bit, 44.1->192kbps. Touch & EDO. 2nd Touch standard.
    LMS plugin UPnP/DLNA Bridge to MF M1 CLiC (to A308CR amp & ESLs) & Marantz CR603 UPnP renderers.
    Alternatively Minimserver & Upplay to same & to upmpdcli/mpd PC renderers.
    Squeezelite to Meridian USB Explorer DAC to PC speakers/headphones.
    Wireless Xubuntu 17.04 laptop firefox/upplay or Android 'phone with Squeeze-Commander/BubbleUPnP controls LMS/Minimserver.

  3. #3253
    Junior Member
    Join Date
    May 2017
    Posts
    11
    Quote Originally Posted by PasTim View Post
    I guess it can't be a firewall issue, nor the server address, since it does play, albeit only for seconds. Have you any debug logs from the remote one? I don't know what -Q does, it's not in my version's (Ralphy) help. Have you tried the JustBoom DAC on the Pi with LMS to see if it is a DAC/squeezelite issue?
    I have tried swapping the Pi's and having the server on the other - same issue the local one was fine, the remote only played a couple of seconds. I also tried running the server on a Mac Pro but then both players only ran for a few seconds. On occasion, one album will play, but then change album and it's back to same 2 -4 seconds of playing and then silence. I've tried different controllers on the iPad - iPeng, SqueezePad and Squeezebox they all find the players and the library/server with no issue and iPeng and SqueezePad will play fine on the iPad.

    here is the debug from the JustBoom Pi (player) :

    #### SQUEEZELITE VERSION ####
    Squeezelite Max2Play v1.0.1 based on v1.8.4-726, Copyright 2012-2015 Adrian Smith, 2015-2016 Ralph Irving.


    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC


    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o sysdefault:CARD=sndrpijustboomd -a 80:4:: -o hw:CARD=sndrpijustboomd -V Digital -Q -s livingroom.local
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d sysdefault:CARD=sndrpijustboomd -t hardware -m hw:CARD=sndrpijustboomd -c Digital
    USE_USB_DAC=0
    USE_EQUALIZER=0
    SYSTEM_USER=pi
    YMPD_PARAMETER=--webport 8081


    #### SQUEEZELITE -l ####
    Output devices:
    null - Discard all samples (playback) or generate zero samples (capture)
    equal
    plugequal - Equalizer for plughw:0,0
    default:CARD=ALSA - bcm2835 ALSA, bcm2835 ALSA - Default Audio Device
    sysdefault:CARD=ALSA - bcm2835 ALSA, bcm2835 ALSA - Default Audio Device
    dmix:CARD=ALSA,DEV=0 - bcm2835 ALSA, bcm2835 ALSA - Direct sample mixing device
    dmix:CARD=ALSA,DEV=1 - bcm2835 ALSA, bcm2835 IEC958/HDMI - Direct sample mixing device
    dsnoop:CARD=ALSA,DEV=0 - bcm2835 ALSA, bcm2835 ALSA - Direct sample snooping device
    dsnoop:CARD=ALSA,DEV=1 - bcm2835 ALSA, bcm2835 IEC958/HDMI - Direct sample snooping device
    hw:CARD=ALSA,DEV=0 - bcm2835 ALSA, bcm2835 ALSA - Direct hardware device without any conversions
    hw:CARD=ALSA,DEV=1 - bcm2835 ALSA, bcm2835 IEC958/HDMI - Direct hardware device without any conversions
    plughw:CARD=ALSA,DEV=0 - bcm2835 ALSA, bcm2835 ALSA - Hardware device with all software conversions
    plughw:CARD=ALSA,DEV=1 - bcm2835 ALSA, bcm2835 IEC958/HDMI - Hardware device with all software conversions
    default:CARD=sndrpijustboomd - snd_rpi_justboom_dac, - Default Audio Device
    sysdefault:CARD=sndrpijustboomd - snd_rpi_justboom_dac, - Default Audio Device
    dmix:CARD=sndrpijustboomd,DEV=0 - snd_rpi_justboom_dac, - Direct sample mixing device
    dsnoop:CARD=sndrpijustboomd,DEV=0 - snd_rpi_justboom_dac, - Direct sample snooping device
    hw:CARD=sndrpijustboomd,DEV=0 - snd_rpi_justboom_dac, - Direct hardware device without any conversions
    plughw:CARD=sndrpijustboomd,DEV=0 - snd_rpi_justboom_dac, - Hardware device with all software conversions



    #### SHAIRPORT VERSION ####
    2.8.0-openssl-Avahi-ALSA-soxr


    #### OUTPUT SOUND DETAILS CARD 0 ####
    closed


    #### OUTPUT SOUND DETAILS CARD 1 ####
    access: RW_INTERLEAVED
    format: S32_LE
    subformat: STD
    channels: 2
    rate: 44100 (44100/1)
    period_size: 882
    buffer_size: 3528

  4. #3254
    Junior Member
    Join Date
    May 2017
    Posts
    11
    Quote Originally Posted by PasTim View Post
    I guess it can't be a firewall issue, nor the server address, since it does play, albeit only for seconds. Have you any debug logs from the remote one? I don't know what -Q does, it's not in my version's (Ralphy) help. Have you tried the JustBoom DAC on the Pi with LMS to see if it is a DAC/squeezelite issue?
    Yes, I've tried having the Justboom DAC as the server and it then plays fine , but then the other Pi exhibits the same behaviour, playing a few seconds and stopping. I also tried running the server on a Mac Pro, but then both Pi's have the problem. However, there is no problem when using my iPad (SqueezePad) or a Mac (SqueezePlay) as players and using either of the Pi's or the MacPro as the server. The issue seems to be with the Pi being used with a remote server.

  5. #3255
    Senior Member
    Join Date
    Nov 2010
    Location
    Hertfordshire, UK
    Posts
    2,468
    Quote Originally Posted by anotbot View Post
    Yes, I've tried having the Justboom DAC as the server and it then plays fine , but then the other Pi exhibits the same behaviour, playing a few seconds and stopping. I also tried running the server on a Mac Pro, but then both Pi's have the problem. However, there is no problem when using my iPad (SqueezePad) or a Mac (SqueezePlay) as players and using either of the Pi's or the MacPro as the server. The issue seems to be with the Pi being used with a remote server.
    Any squeezelite and/or LMS logs showing errors?
    LMS 7.9.1 on VortexBox Midi box, Xubuntu 17.04, FLACs 16->24 bit, 44.1->192kbps. Touch & EDO. 2nd Touch standard.
    LMS plugin UPnP/DLNA Bridge to MF M1 CLiC (to A308CR amp & ESLs) & Marantz CR603 UPnP renderers.
    Alternatively Minimserver & Upplay to same & to upmpdcli/mpd PC renderers.
    Squeezelite to Meridian USB Explorer DAC to PC speakers/headphones.
    Wireless Xubuntu 17.04 laptop firefox/upplay or Android 'phone with Squeeze-Commander/BubbleUPnP controls LMS/Minimserver.

  6. #3256
    Senior Member
    Join Date
    Nov 2010
    Location
    Hertfordshire, UK
    Posts
    2,468
    Quote Originally Posted by PasTim View Post
    Any squeezelite and/or LMS logs showing errors?
    I realise that you supplied one squeezelite log, but is there nothing else? Do you get the library errors on the system running LMS? Can you compare the logs from both PIs?
    LMS 7.9.1 on VortexBox Midi box, Xubuntu 17.04, FLACs 16->24 bit, 44.1->192kbps. Touch & EDO. 2nd Touch standard.
    LMS plugin UPnP/DLNA Bridge to MF M1 CLiC (to A308CR amp & ESLs) & Marantz CR603 UPnP renderers.
    Alternatively Minimserver & Upplay to same & to upmpdcli/mpd PC renderers.
    Squeezelite to Meridian USB Explorer DAC to PC speakers/headphones.
    Wireless Xubuntu 17.04 laptop firefox/upplay or Android 'phone with Squeeze-Commander/BubbleUPnP controls LMS/Minimserver.

  7. #3257
    Junior Member
    Join Date
    May 2017
    Posts
    11
    Hi PasTim,

    Thank you for your help.

    Here is the log from the Pi server - I'm not sure what any of it means :-)

    I was trying adding various options to the squeezelite command line.

    The first bit is the default for the just boom card : -o hw:CARD=sndrpijustboomd -V Digital -Q

    It was suggested that I add -s myserver.local:9000 or -s myserver.local - the first broke the player and the second made no difference. So I can't be sure if the any errors that are being reported are due to the above...

    #### SQUEEZESERVER LOG ####
    [17-05-17 18:41:25.7579] Slim::Networking::Slimproto::client_readable (414) Client not found for slimproto msg op: STAT from 192.168.0.12
    [17-05-17 18:53:15.8443] Slim::Utils::Timers::__ANON__ (273) Error: Timer Slim::Web::Cometd::sendResponse failed: illegal file descriptor or filehandle (either no attached file descriptor or illegal value): at /usr/share/perl5/Slim/Networking/IO/Select.pm line 134.
    [17-05-17 18:54:14.9176] Slim::Utils::Timers::__ANON__ (273) Error: Timer Slim::Web::Cometd::sendResponse failed: illegal file descriptor or filehandle (either no attached file descriptor or illegal value): at /usr/share/perl5/Slim/Networking/IO/Select.pm line 134.
    [17-05-17 19:58:30.0733] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-17 19:58:30.1036] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-17 20:58:28.6592] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-17 20:58:28.6915] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-17 21:58:27.2543] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-17 21:58:27.2988] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-18 09:03:29.8931] Slim::Web::JSONRPC::requestMethod (443) b8:27:eb:d3:61:3a: request not dispatchable!
    [17-05-18 09:03:34.9497] Slim::Web::JSONRPC::requestMethod (443) b8:27:eb:d3:61:3a: request not dispatchable!
    [17-05-18 09:03:40.0044] Slim::Web::JSONRPC::requestMethod (443) b8:27:eb:d3:61:3a: request not dispatchable!
    2017-05-18 09:08:11 squeezeboxserver_safe stopped.
    2017-05-18 12:16:27 squeezeboxserver_safe started.
    [17-05-18 12:16:32.3580] main::init (387) Starting Logitech Media Server (v7.9.1, 1493198727, Sat Apr 29 04:38:50 UTC 2017) perl 5.020002 - arm-linux-gnueabihf-thread-multi-64int
    [17-05-18 12:16:36.8669] Plugins::NPRRadio::Metadata::init (21) Register NPR meta provider, default icon=
    [17-05-18 12:27:32.7936] Slim::Networking::Slimproto::client_readable (414) Client not found for slimproto msg op: STAT from 192.168.0.12
    [17-05-18 12:32:14.0424] Slim::Networking::Slimproto::client_readable (414) Client not found for slimproto msg op: STAT from 192.168.0.12
    [17-05-18 12:32:24.1567] Slim::Networking:iscovery::Players::_players_error (146) Unable to get players: Timed out waiting for data
    [17-05-18 12:41:24.0725] Slim::Networking::Slimproto::client_readable (414) Client not found for slimproto msg op: STAT from 192.168.0.12
    [17-05-18 13:59:20.2046] Slim::Networking::Slimproto::client_readable (414) Client not found for slimproto msg op: STAT from 192.168.0.12
    [17-05-18 13:59:20.7322] Slim::Web::Cometd::handler (422) errorNeedsClient: 02:46:90:3d:fd:97, status, -, 1, tags:JjaldBxKAc, subscribe:60
    2017-05-18 14:08:01 squeezeboxserver_safe stopped.
    2017-05-18 14:08:17 squeezeboxserver_safe started.
    [17-05-18 14:08:36.1254] main::init (387) Starting Logitech Media Server (v7.9.1, 1493198727, Sat Apr 29 04:38:50 UTC 2017) perl 5.020002 - arm-linux-gnueabihf-thread-multi-64int
    [17-05-18 14:08:43.0297] Plugins::NPRRadio::Metadata::init (21) Register NPR meta provider, default icon=
    [17-05-18 14:08:48.6544] Slim::Web::Cometd::handler (422) errorNeedsClient: b8:27:eb:d3:61:3a, status, -, 1, tags:JjaldBxKAc, subscribe:60
    [17-05-18 14:08:48.6598] Slim::Web::JSONRPC::requestMethod (443) b8:27:eb:d3:61:3a: request not dispatchable!
    [17-05-18 14:08:53.7180] Slim::Web::JSONRPC::requestMethod (443) b8:27:eb:d3:61:3a: request not dispatchable!
    2017-05-18 14:08:58 squeezeboxserver_safe stopped.
    2017-05-18 14:08:58 squeezeboxserver_safe started.
    [17-05-18 14:09:02.0954] main::init (387) Starting Logitech Media Server (v7.9.1, 1493198727, Sat Apr 29 04:38:50 UTC 2017) perl 5.020002 - arm-linux-gnueabihf-thread-multi-64int
    [17-05-18 14:09:04.6760] Plugins::NPRRadio::Metadata::init (21) Register NPR meta provider, default icon=
    [17-05-18 14:09:08.9543] Slim::Web::JSONRPC::requestMethod (443) b8:27:eb:d3:61:3a: request not dispatchable!
    [17-05-18 14:09:14.0931] Slim::Web::JSONRPC::requestMethod (443) b8:27:eb:d3:61:3a: request not dispatchable!
    [17-05-18 14:09:18.6615] Slim::Web::JSONRPC::requestMethod (443) b8:27:eb:d3:61:3a: request not dispatchable!
    [17-05-18 14:09:18.6658] Slim::Web::JSONRPC::requestMethod (443) b8:27:eb:d3:61:3a: request not dispatchable!
    [17-05-18 14:09:39.6789] Slim::Web::JSONRPC::requestMethod (443) b8:27:eb:d3:61:3a: request not dispatchable!
    [17-05-18 14:09:39.7583] Slim::Web::JSONRPC::requestMethod (443) b8:27:eb:d3:61:3a: request not dispatchable!
    [17-05-18 21:19:12.0024] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-18 21:19:12.0389] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed


    #### PERL VERSION ####
    v5.20.2

  8. #3258
    Senior Member
    Join Date
    Nov 2010
    Location
    Hertfordshire, UK
    Posts
    2,468
    Quote Originally Posted by anotbot View Post
    Hi PasTim,

    Thank you for your help.

    Here is the log from the Pi server - I'm not sure what any of it means :-)

    I was trying adding various options to the squeezelite command line.

    The first bit is the default for the just boom card : -o hw:CARD=sndrpijustboomd -V Digital -Q

    It was suggested that I add -s myserver.local:9000 or -s myserver.local - the first broke the player and the second made no difference. So I can't be sure if the any errors that are being reported are due to the above...

    #### SQUEEZESERVER LOG ####
    .....
    I don't understand much of this either, but maybe other more knowledgeable people here will. It certainly looks as if your remote squeezelite player is struggling to make itself known to the LMS server.

    Have you tried using -s with the local-IP-address:9000 rather than 'myserver.local'? A correct IP address or resolved host name shouldn't break the player.
    LMS 7.9.1 on VortexBox Midi box, Xubuntu 17.04, FLACs 16->24 bit, 44.1->192kbps. Touch & EDO. 2nd Touch standard.
    LMS plugin UPnP/DLNA Bridge to MF M1 CLiC (to A308CR amp & ESLs) & Marantz CR603 UPnP renderers.
    Alternatively Minimserver & Upplay to same & to upmpdcli/mpd PC renderers.
    Squeezelite to Meridian USB Explorer DAC to PC speakers/headphones.
    Wireless Xubuntu 17.04 laptop firefox/upplay or Android 'phone with Squeeze-Commander/BubbleUPnP controls LMS/Minimserver.

  9. #3259
    Junior Member
    Join Date
    May 2017
    Posts
    11
    Yes, I've tried that and though the squeezelite player starts up, it can no longer be found by any controller... so not a solution :-(

  10. #3260
    Senior Member
    Join Date
    Nov 2010
    Location
    Hertfordshire, UK
    Posts
    2,468
    Quote Originally Posted by anotbot View Post
    Yes, I've tried that and though the squeezelite player starts up, it can no longer be found by any controller... so not a solution :-(
    Beats me - sorry. You really don't have any firewalls set up anywhere do you?
    LMS 7.9.1 on VortexBox Midi box, Xubuntu 17.04, FLACs 16->24 bit, 44.1->192kbps. Touch & EDO. 2nd Touch standard.
    LMS plugin UPnP/DLNA Bridge to MF M1 CLiC (to A308CR amp & ESLs) & Marantz CR603 UPnP renderers.
    Alternatively Minimserver & Upplay to same & to upmpdcli/mpd PC renderers.
    Squeezelite to Meridian USB Explorer DAC to PC speakers/headphones.
    Wireless Xubuntu 17.04 laptop firefox/upplay or Android 'phone with Squeeze-Commander/BubbleUPnP controls LMS/Minimserver.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •