I'm trying to build my own version of wpa_supplicant for Squeezebox Radio. I followed this guide to setup the build environment: http://wiki.slimdevices.com/index.ph...d_Instructions
Now i have a working cross compiler. I made a hello world and it works on the SBRadio.
Next i tried to compile the wpa_supplicant-0.6.9 but it fails to find a compatible openssl version at the linker stage:

./squeezeos/poky/build/tmp-jive/cross/armv5te/bin/../lib/gcc/arm-none-linux-gnueabi/4.4.1/../../../../arm-none-linux-gnueabi/bin/ld: skipping incompatible ./squeezeos/poky/build/tmp-jive/staging/i686-linux/usr/lib/libssl.so when searching for -lssl
.squeezeos/poky/build/tmp-jive/cross/armv5te/bin/../lib/gcc/arm-none-linux-gnueabi/4.4.1/../../../../arm-none-linux-gnueabi/bin/ld: skipping incompatible ./squeezeos/poky/build/tmp-jive/staging/i686-linux/usr/lib/libssl.a when searching for -lssl
.squeezeos/poky/build/tmp-jive/cross/armv5te/bin/../lib/gcc/arm-none-linux-gnueabi/4.4.1/../../../../arm-none-linux-gnueabi/bin/ld: cannot find -lssl
collect2: ld returned 1 exit status
make: *** [wpa_supplicant] Fehler 1

Using the openssl under i686-linux was only a wild guess and obviously did not work. But .squeezeos/poky/build/tmp-jive/work/armv5te-none-linux-gnueabi/ contains no openssl. What now? Maybe my toolchain is incomplete? How can i build openssl for arm is there a special poky/bitbake command?

Btw I'm using Ubuntu 10.04.4 LTS maybe thats the cause is it possible that it will work in an older version maybe 8.04?

regards Cabal