Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 3 of 3
  1. #1
    Junior Member
    Join Date
    Jun 2012
    Posts
    3

    ZyXel NSA221 and media server complete and utter failure.

    So my tale of woe is as follows.

    Set re-index clean all files etc overnight.
    In morning no squeeze center server.
    Stop squeezecenter and start again still no server
    Stop mysql and restart no sql server available gives message "#2013 - Lost connection to MySQL server at 'waiting for initial communication packet', system error: 95"
    Stop mysql again this fails and just shows the rotating arrow and sits there add infinitum.
    Now there is no access to any of the ZyXel maintenance screens at all.

    Seems to indicate some catastrophice failure in the software stack.

    At this point the device is completely locked and cannot even be restarted from the browser control panel.
    Leaving for approx 5 minutes, can then access the web control panel and restart.
    Restarts, comes back up with MySql and Squeezecenter disabled so least it has respected the commands.
    Restarting both of these seems successful.

    Now can access the sueezecenter but after browsing through three or four albums it fails and I recieve the response through the browser "Error 102 (net::ERR_CONNECTION_REFUSED): The server refused the connection.".
    Restarting squeezecenter again seems to stabilise the situation and enable me to browse through the albums loaded, lots have no album art although I have been careful to check that each does.


    Any help that can be offered would be great at the moment this device software combination is of no value whatsoever, shortly it will be talking the walk of shame back to the suppliers as unable to provide what it is advertised to do.
    Being frankly honest I have never used such a poor peice of computer equipment, and I have worked in IT for twenty years so that really is saying something. I have had this device for 7 days and not once has squeezecenter managed to make it through any 24 hour period without failing completely.

    Technical details are below, perhaps they will shed some light.

    Thanks in anticipation.
    Dave

    ################################################## ##################################################
    Firmware version is 4.23(AFM.0)
    Squeezecenter version is 7.7
    MySql version is Server version: 5.1.30
    Protocol version: 10
    User: root@localhost

    Scan details from Squeezecenter as below.


    Media Scan Details
    Discovering files/directories: /i-data/md0/.media/squeezecenter (18567 of 18567) Complete 00:04:12
    Scanning new music files: /i-data/md0/.media/squeezecenter (64 of 64) Complete 00:00:38
    Pre-caching Artwork (17 of 1070) Running 00:56:16
    Debut
    The server has finished scanning your media library.
    Total Time: 01:01:06

    Library Statistics
    Total Tracks: 16,701
    Total Albums: 1,342
    Total Artists: 214
    Total Genres: 90
    Total Playing Time: 1114:12:53

  2. #2
    Senior Member Mnyb's Avatar
    Join Date
    Feb 2006
    Location
    Vństerňs Sweden
    Posts
    13,263
    7.7 does not use MySQL unless you edit certain files and create the dB yourself . 7.7 uses SQLite .

    There are hints on this forum on how to still use MySQL , but that is not officially supported and is up to the user to make it work .

    About your problem complete server.log and scanner.log may shed some light .

    it seems like the scan is not finished properly and without a dB in good order the product falls on it's face .

    You should not try to use it while scanning , the cpu can easily be pegged at 100% while scanning .
    And behavior will be as described treacle slow web-UI etc

    Who is providng the LMS package for the ZyXel NSA221 ?? does ZyXel has any kind of support if it where they that provided the port of LMS to be used in their product ? note that LMS is open source so it can be modified and ported to anything ,but the implementation of it may be out of logitechs hands , they do the windows build and Mac builds on some Linux variants and the ReadyNAS build . Versions for Qnap and Linksys are for example done by others .
    I would not say that your experience is typical
    --------------------------------------------------------------------
    Main hifi: Touch + CIA PS +MeridianG68J MeridianHD621 MeridianG98DH 2 x MeridianDSP5200 MeridianDSP5200HC 2 xMeridianDSP3100 +Rel Stadium 3 sub.
    Bedroom/Office: Boom
    Kitchen: Touch + powered Fostex PM0.4
    Misc use: Radio (with battery)
    iPad1 with iPengHD & SqueezePad
    (in storage SB3, reciever ,controller )
    server HP proliant micro server N36L with ClearOS Linux

    http://people.xiph.org/~xiphmont/demo/neil-young.html

  3. #3
    Junior Member
    Join Date
    Jun 2012
    Posts
    3

    Phew !!(I think !)

    Mnyb thanks for he input, dug around in the logs and nothing of any real consequence.

    Turns out it was something in the NAS (Zyxel NSA221), factory reset re-installed latest firmware etc and all now seems to be indexing fine.

    Have also had problems streaming which I have now idetified as an overheating router.

    Eventually (fingers crossed) I think I have solved most of my issues and am now just tidying and tuning :-)

    Thanks again for your input defeinitely helped.

    Dave

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •