Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 19
  1. #1

    Touch prevents PC from sleeping / constantly wakes it up.

    Ok guys, this problem has been bugging me for months now.

    Ok here's my (simple) setup:

    Squeezebox Touch > router via ethernet. PC > router via ethernet. That's it.

    Problem is, the (idle) Touch simply refuses to let my PC sleep, and if I put the PC to sleep manually, the Touch wakes it up in less than a minute.

    I know it's the Touch causing the problem, because if I unplug it, either the ethernet cable or from the mains, the problem goes away. And if I completely disable Squeezebox server on the PC, again, sorted.

    So anyway, I've trawled through every setting on both the Touch itself AND the server, and can't find anything that fixes the problem. The only thing I can do is uncheck the setting 'Allow this device to wake the computer' in my ethernet card settings under Device Manager which fixes the problem, but NOW the darn PC goes to sleep while the Touch is playing! Arghhhh! Can't win.

    Also tried checking the setting 'Wake with Magic Packet only', no dice.

    If I run the PC on wireless all's good; the PC stays awake when the Touch is playing, goes to sleep (and stays asleep) when the Touch is idle. Problem is I need to run wired to get my full Broadband speed, so wireless is out of the question.

    I'm completely at a loss here. I've Googled the problem a hundred times and come up with nothing. I'm amazed no one else suffers this.

    Any help? Cheers.

  2. #2
    Senior Member toby10's Avatar
    Join Date
    Jul 2007
    Location
    USA (home of the bottomless credit card)
    Posts
    9,053
    Switch the Touch to MySB.com when you are done using it. This can be done from the Home menu if you move "Switch to MySB.com" to your Home menu.
    Touch > Settings > Advanced > Network > "Switch to MySB.com" (press & hold, select Add to Home Menu)

    Just consider "Switch to MySB.com" as your Off button. Simply select My Music and it will wake & connect to your local LMS server.

  3. #3
    Quote Originally Posted by toby10 View Post
    Switch the Touch to MySB.com when you are done using it. This can be done from the Home menu if you move "Switch to MySB.com" to your Home menu.
    Touch > Settings > Advanced > Network > "Switch to MySB.com" (press & hold, select Add to Home Menu)

    Just consider "Switch to MySB.com" as your Off button. Simply select My Music and it will wake & connect to your local LMS server.
    Thank you very much for the workaround! I'll be using this method here on.

    Still it's annoying that we even have to do this. Why on earth would the Touch hassle the PC every 30 seconds or so when it's not Even doing anything? Just doesn't make any sense. I'm really surprised this isn't a more wide-spread issue.

    Anyway, thanks again! Much appreciated.

  4. #4
    Senior Member aubuti's Avatar
    Join Date
    Oct 2005
    Posts
    8,819
    Quote Originally Posted by ReValveiT View Post
    Still it's annoying that we even have to do this. Why on earth would the Touch hassle the PC every 30 seconds or so when it's not Even doing anything? Just doesn't make any sense. I'm really surprised this isn't a more wide-spread issue.
    It's not universal. These days I have my server on 24/7, but when I formerly used sleep-and-WOL I never had problems with the Touch waking the server when it wasn't supposed to. Do you have any applets on the Touch that may be causing it? Or, even though you set the pc to wake on magic packet only, maybe the pc isn't really implementing it the way it should? Or maybe there's a problem with more recent Touch firmware?

  5. #5
    Senior Member Apesbrain's Avatar
    Join Date
    Jun 2005
    Location
    East Coast, USA
    Posts
    1,037
    Just FYI, I've had the same problem at times over wireless. Typically "solving" it came down to checking that the wireless adapter power management was set to only respond to management stations (magic packet) -- some unidentified app/malware seemed to be removing this setting -- and then rebooting everything. Sounds like you've already done that. There is a well-developed plugin that can automate the switch to mysqueezebox.com that you might find useful.

  6. #6
    Quote Originally Posted by aubuti View Post
    It's not universal. These days I have my server on 24/7, but when I formerly used sleep-and-WOL I never had problems with the Touch waking the server when it wasn't supposed to. Do you have any applets on the Touch that may be causing it? Or, even though you set the pc to wake on magic packet only, maybe the pc isn't really implementing it the way it should? Or maybe there's a problem with more recent Touch firmware?
    Cheers for the info.

    No applets. I've done many factory resets and recently a fresh install of Windows 7 64bit w/ a fresh Squeezebox Server install. Still the problem persists.

  7. #7
    Senior Member aubuti's Avatar
    Join Date
    Oct 2005
    Posts
    8,819
    I suppose another workaround is to switch to using wireless for the Touch instead of ethernet. It's less than ideal, but if the wifi signal is good it should comfortably provide enough bandwidth for lossless streaming, especially as the server will still be wired to the router.

  8. #8
    Senior Member Mnyb's Avatar
    Join Date
    Feb 2006
    Location
    Vństerňs Sweden
    Posts
    15,993
    Quote Originally Posted by aubuti View Post
    I suppose another workaround is to switch to using wireless for the Touch instead of ethernet. It's less than ideal, but if the wifi signal is good it should comfortably provide enough bandwidth for lossless streaming, especially as the server will still be wired to the router.
    Yeh but squeezeboxes can send WOL anyway even they are on wifi , putting the server on wifi migth stop it ,but then it migth actually fall back to sleep when not wanted instead .

    Try the black screensaver (no clock ) for off or stop .

    Try stop (long press on pause button ) instead of pause ?
    --------------------------------------------------------------------
    Main hifi: Touch + CIA PS +MeridianG68J MeridianHD621 MeridianG98DH 2 x MeridianDSP5200 MeridianDSP5200HC 2 xMeridianDSP3100 +Rel Stadium 3 sub.
    Bedroom/Office: Boom
    Kitchen: Touch + powered Fostex PM0.4
    Misc use: Radio (with battery)
    iPad1 with iPengHD & SqueezePad
    (spares Touch, SB3, reciever ,controller )
    server HP proliant micro server N36L with ClearOS Linux

    http://people.xiph.org/~xiphmont/demo/neil-young.html

  9. #9
    Quote Originally Posted by Mnyb View Post
    Yeh but squeezeboxes can send WOL anyway even they are on wifi , putting the server on wifi migth stop it ,but then it migth actually fall back to sleep when not wanted instead .

    Try the black screensaver (no clock ) for off or stop .

    Try stop (long press on pause button ) instead of pause ?
    Cheers Mnyb...

    Have tried the 'long press' stop many times, but not the blank screen. I'll give that a bash.

    Server (PC) on wireless works fine as mentioned, but I need wired to get my full BB speed.

    Touch on wireless may work, but I believe it sounds better wired (just opinion, don't shoot!)

    Anyway. Switching to mysqueezebox.com as advised by toby10 is working fine for me. Still it would be nice to know why this is happening.

    Thanks everyone for discussing.

  10. #10
    Senior Member aubuti's Avatar
    Join Date
    Oct 2005
    Posts
    8,819
    Quote Originally Posted by Mnyb View Post
    Yeh but squeezeboxes can send WOL anyway even they are on wifi , putting the server on wifi migth stop it ,but then it migth actually fall back to sleep when not wanted instead .
    <slap forehead> Yes, you're absolutely right. What I wrote doesn't make sense. Thanks for putting it straight.

    EDIT: to the OP, have you checked to see if the problem could be with your pc's BIOS? For example, the wake-on-magic-packet-only setting not working. See if there is newer firmware available.
    Last edited by aubuti; 2012-04-20 at 12:55.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •