Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 4 123 ... LastLast
Results 1 to 10 of 38
  1. #1

    Solaris 11 (NOT Express): Problem with UPnP Plugin and Image Browser

    Hi there,

    I am running LMS 7.7.2 (Nigthly 33769) on Solaris 11 (NOT Express). I compiled all Perl Modules (Perl Version 5.12.3) with the GNU Compiler (Version 4.5.2) by myself. I could provide the modified buildme.sh and the patches if required.
    There were two issues I had during comilation:
    - Libmediascan had an issue compiling mediscan_unix.c. I solved this by changing line 114:
    if (dp->d_type == DT_DIR) {
    to
    stat(dp->d_name, &t);
    if ((t.st_mode & S_IFMT) == S_IFDIR) {
    I also had to add "struct stat t;" to function "recurse_dir"

    - Another issue I had was that the EV module (version 4.3) does compile fine but fails the test.

    - After another issue with the UDP Socket (see http://forums.slimdevices.com/showth...=83939&page=22) I have LMS up and running.

    Now I have two problems:
    1. The dlna server only shows up right after start. It never advertises itself after that.
    2. The image browser shows the entries to my images, but does not know where to find them. I does not show them.

    On another OS (MacOS) I have no problems.

    Anybody any ideas? Is EV essential for UPnP and the image browser???

    Hints from Openindiana users are also welcome.
    Last edited by chincheta0815; 2012-01-29 at 02:50.

  2. #2
    Junior Member
    Join Date
    Jun 2010
    Posts
    4
    I would greatly appreciate a copy of the modified buildme.sh, patches and anything else required to get LMS working under Solaris 11.

    I've previously tried to install older versions under Solaris 10 and 11 express but have never been able to get them working.

    LMS is the main reason I haven't moved my Ubuntu server to Solaris.

  3. #3
    Sorry for not replying.
    I will provide you with the scrips over the weekend.

  4. #4

    Files for Building LMS on Solaris/OpenIndiana

    Here are the files that are necessary to build LMS on Solaris/OpenIndiana. I hope this helps others to build LMS on these OSes for enjoying the combination of LMS with ZFS.

    The package also contains some patches to make LMS working with UPnP. Well, the latter is not quite right: The file UDP.pm will be patches for setting the sockopts right and the file Discovery.pm is patched to reply with the r
    Last edited by chincheta0815; 2012-03-18 at 04:40.

  5. #5
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Location
    Canada
    Posts
    1,105
    Quote Originally Posted by chincheta0815 View Post
    If anybody can be so nice to download it there and upload it to this thread I will highly appreaciate that. I will delete the link then.
    Here's the file.
    Attached Files Attached Files
    Ralphy

    1-Touch, 4-Classics, 2-Booms, 1-Reverted UE Radio
    Squeezebox client builds donations always appreciated.

  6. #6
    Thank you.

  7. #7
    Junior Member
    Join Date
    Mar 2012
    Posts
    24

    libmediascan

    I had the same problem with not being able to see images with the image broswer (or when connected from a UPnP client). On Solaris you have to compile libmediascan with __linux__ defined. If you do this you should find that the image browser will start working. You can do it on the configure line in buildme.sh by adding "-D__linux__" to the CFLAGS setting.

  8. #8
    Thank you very much. I added the flag and now it browses images like a charm. Awesome.

    Do you have different tricks for the videos (ffmpeg, etc.)

    I have some more issued:
    - EV fails the stat.t test when using gcc
    - libjeg-turbo won't compile neither
    - video are not shown

    Maybe we could open a new thread for Solaris/OpenOndiana users?

    P.S.: I will add the changes needed to my buildScript and post it once in a while.

  9. #9
    I checked the new capabilities of LMS after compiling libmediascan as suggested.

    I now have, as I write above, support for the photos.

    BUT: How do I get LMS to show videos? Is there a trick with ffmpeg???

  10. #10
    Junior Member
    Join Date
    Mar 2012
    Posts
    24
    I haven't seen a failure to compile EV. I'm not quite doing it the same way that you are. Instead of changing the compile options for the standard Solaris perl I compiled perl 5.12.4 using gcc following the instructions at the beginning of buildme.sh, and installed that into /usr/local. I've then used it to build the rest of the stuff in buildme.sh.
    Not quite sure why you are trying to compile libjpeg-turbo. The default script just compiles jpeg-8b. Is there an advantage to using libjpeg-turbo?

    I have to admit I have not tried video through the UPnP server yet.

    Your modification to Discovery.pm, I don't seem to need that. I'm wondering if you have a route defined for multicast on your Solaris machine? Should be something like:


    # ipadm show-addr
    ADDROBJ TYPE STATE ADDR
    lo0/v4 static ok 127.0.0.1/8
    net0/v4static static ok 192.168.254.35/24
    lo0/v6 static ok ::1/128
    # netstat -rn

    Routing Table: IPv4
    Destination Gateway Flags Ref Use Interface
    -------------------- -------------------- ----- ----- ---------- ---------
    default 192.168.254.1 UG 2 26477
    127.0.0.1 127.0.0.1 UH 2 1754 lo0
    192.168.254.0 192.168.254.35 U 13 5348082 net0
    224.0.0.0 192.168.254.35 U 1 0 net0

    Routing Table: IPv6
    Destination/Mask Gateway Flags Ref Use If
    --------------------------- --------------------------- ----- --- ------- -----
    ::1 ::1 UH 2 28 lo0
    # route -p show
    persistent: route add default 192.168.254.1
    persistent: route add 224.0.0.0 sqboxsrv 0
    ## grep sqboxsrv /etc/hosts
    192.168.254.35 sqboxsrv loghost

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •