Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 4 of 4
  1. #1
    Junior Member
    Join Date
    Jun 2010
    Posts
    4

    Reinstall after failed Ubuntu OS upgrade

    I had an install of Logitech Media Server 7.7 running on my Mythbunutu 11.04 backend, and everything was running fine until I made the poor decision of updating to Mythbuntu 11.10. Unfortunately, the upgrade failed and I was let with a very unstable OS. Using a CD for 11.10, I was able to redo an "upgrade" from the disk, so now I am back to a running state.

    This "upgrade" really only kept my home directory, the system files all have been replaced (I lost my database and settings for MythTV and had to reset everything up).

    Last night I went to reinstall the LMS, and installation failed. I was doing this remotely through SSH (unit is headless at the moment), and attempted the install using "sudo dpkg -i". It looked like it was installing fine until the end, where it referenced something about "MySQL" and said [failed]. At the moment, I am not near the PC to verify the exact terminology.

    My assumption is that there is a conflict with the previous LMS specific MySQL install.... Is the log file generated that would verify this?
    How can I manually remove all traces of the previous LMS setup, while not affecting my MythTV MySQL?

    Any help would be appreciated, and I will be happy to post any logs when I get home this evening.

    Thanks.

  2. #2
    Junior Member
    Join Date
    Jun 2010
    Posts
    4
    OK, let me correct myself. This appears to be an issue with apparmour... here is what I get:

    Code:
    Unpacking replacement logitechmediaserver ...
    Setting up logitechmediaserver (7.7.0~33609) ...
     * Reloading AppArmor profiles                                                  /sbin/apparmor_parser: Regex grouping error: Unclosed grouping or character class, expecting close }
    /sbin/apparmor_parser: Unable to parse input line '/{,var/run/mysqld/mysqld.pid'
    /sbin/apparmor_parser: Regex grouping error: Unclosed grouping or character class, expecting close }
    /sbin/apparmor_parser: Unable to parse input line '/{,var/run/mysqld/mysqld.sock'
    ERROR processing regexs for profile /usr/sbin/mysqld, failed to load
                                                                             [fail]
    dpkg: error processing logitechmediaserver (--install):
     subprocess installed post-installation script returned error exit status 123
    Processing triggers for ureadahead ...
    Errors were encountered while processing:
     logitechmediaserver
    Any sugestions?

  3. #3
    Junior Member
    Join Date
    Nov 2011
    Posts
    6

    Lightbulb

    Problem is the postinstall script damages the AppArmor file. Until Logitech fix their package, you have to hack the postinstall script yourself. The file is: /var/lib/dpkg/info/logitechmediaserver.postinst

    The patch I posted here should do the trick: http://forums.slimdevices.com/showth...d=1#post673529

    You also have to restore your /etc/apparmor.d/usr.sbin.mysqld manually.

    Then "dpkg --configure -a" would execute the patched postinstall script and finish the installation.

    Hope this helps.

  4. #4
    Junior Member
    Join Date
    Dec 2011
    Posts
    1
    > You also have to restore your /etc/apparmor.d/usr.sbin.mysqld manually.

    So far so good, but how exactly do I restore this? I have the same problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •