Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 5 of 5
  1. #1

    SqueezePlay stopped working on XP

    Since somewhere today, SqueezePlay has stopped working. I sometimes use the emulator on both my music workstation (XP Pro) as well as my regular desktop (XP Home).
    After a lot of fiddling, reinstalling and rebooting, and nothing working, I thought I'd try it on some machines that never had SqueezePlay installed. Interesting result: on my netbook (W7 Starter) it works without a problem. On my fileserver (XP Pro) however, it isn't working either.
    The weird thing is that it initially does talk with Squeezebox Server as it can retrieve the name of my collection (I changed the name and the change was seen at client side) but once I want to connect to that collection, it will time out with an error.

    Today there were a bunch of Windows Updates though, so I wonder whether that has broken things on XP.

  2. #2
    I'm entirely clueless on this. It turned out not necessarily an XP issue. At some point I got it working from my XP Home desktop machine. Still remains to be seen if it won't break again at some point.
    XP Pro still is not working at all. Complete uninstall, reboot, what-else, is just not working.
    I've never had issues with SqueezePlay... I wonder if it's a 7.6 server issue, because a couple of days ago I did a complete reinstall of the server.

  3. #3
    Senior Member
    Join Date
    May 2008
    Location
    United States
    Posts
    11,076
    Quote Originally Posted by Squid View Post
    I'm entirely clueless on this. It turned out not necessarily an XP issue. At some point I got it working from my XP Home desktop machine. Still remains to be seen if it won't break again at some point.
    XP Pro still is not working at all. Complete uninstall, reboot, what-else, is just not working.
    I've never had issues with SqueezePlay... I wonder if it's a 7.6 server issue, because a couple of days ago I did a complete reinstall of the server.
    Just to add another data point: Can't speak to XP, but I have squeezeplay running on two different win7 machines. One is running 7.6.1 SbS the other 7.5.4. Lots of updates to win7 too, but all is fine in both cases on my end.

  4. #4
    I finally figured out what the problem is. I was doing the tests through Remote Desktop (RDP) to avoid running around. Tonight when wanting to switch audio outputs on the music workstation (through RDP), I noticed I didn't have my regular audio outputs at all. The only output I had was Microsoft RDP Audio.

    I immediately realized what was happening. When connecting through RDP and redirecting the audio to the RDP (default behavior), you actually turn off all regular audio devices. SqueezePlay doesn't quite like this, it does initially connect to the server, but then immediately hangs when trying to access the music collection itself (even before being able to play).

    The solution is obviously very simple as well, as you can select whether or not to redirect the audio.

    Happy I finally solved this puzzle.

  5. #5
    Senior Member
    Join Date
    May 2008
    Location
    United States
    Posts
    11,076
    Quote Originally Posted by Squid View Post
    I finally figured out what the problem is. I was doing the tests through Remote Desktop (RDP) to avoid running around. Tonight when wanting to switch audio outputs on the music workstation (through RDP), I noticed I didn't have my regular audio outputs at all. The only output I had was Microsoft RDP Audio.

    I immediately realized what was happening. When connecting through RDP and redirecting the audio to the RDP (default behavior), you actually turn off all regular audio devices. SqueezePlay doesn't quite like this, it does initially connect to the server, but then immediately hangs when trying to access the music collection itself (even before being able to play).

    The solution is obviously very simple as well, as you can select whether or not to redirect the audio.

    Happy I finally solved this puzzle.
    I love a happy (and simple) ending!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •