Home of the Squeezebox™ & Transporter® network music players.
Page 3 of 7 FirstFirst 12345 ... LastLast
Results 21 to 30 of 70
  1. #21
    Junior Member
    Join Date
    Jul 2015
    Posts
    1
    Hi,

    I basically have the same situation here as catweazle70: installation seems to work, connection to mixcloud is established (the artwork and the length of the track is shown), but then no playback (for mixes where I can be sure that they are in the mp3 format). Like pippin, I tried to "turn it off and on again" => no improvement.
    Any hints on extra steps to get the thing working are highly appreciated.

    Thanks!

  2. #22
    Senior Member pippin's Avatar
    Join Date
    Oct 2007
    Location
    Berlin
    Posts
    13,988
    Yea, Mixcloud may have done some changes. Plugins like that need regular maintenance
    ---
    learn more about iPeng, the iPhone and iPad remote for the Squeezebox and
    Logitech UE Smart Radio as well as iPeng Party, the free Party-App,
    at penguinlovesmusic.com
    New: iPeng 9, the Universal App for iPhone, iPad and Apple Watch

  3. #23
    Junior Member
    Join Date
    May 2009
    Location
    FL
    Posts
    22
    I also have a problem running this on my QNAP NAS, looking at the server log it seems as though after it fetches the artwork it gets itself in a loop and trys over and over to re-fetch the artwork but never plays the track.

    Here's a sample of the two lines from the server log that continue to repeat after I press play

    193474: [15-07-29 16:14:29.1341] Plugins::MixCloud::ProtocolHandler::getMetadataFor (192) getMetadataFor: mixcloud://wassieone/wassie-one-connoisseur-thursdays-on-venture-fm-2372015/
    193473: [15-07-29 16:14:29.1336] Plugins::MixCloud::ProtocolHandler::getMetadataFor (195) ----------------------------------getMetadataFor TRACK TITLE: http://images-mix.netdna-ssl.com/w/3...upload/images/


    I have the exact same plugin running on LMS under windoze on a VM on the same QNAP NAS and its working fine.

    Unfortunately I don't know enough to figure out whether its a problem with the plugin or the LMS running on Linux
    LMS 7.9.0 -> QNAP TVS-871 Raid 5, Slimdevices Silver Transporter, 1 * SB Touch, 2 * SB Duets, 2 * SB Boom, 1 * SB Radio, 1 * Wandboard Quad, (1 dead SB Classic), Rasp Pi 2.0 + HiFiBerry-Amp+ Official Touchscreen + PiCorePlayer

  4. #24
    Senior Member pippin's Avatar
    Join Date
    Oct 2007
    Location
    Berlin
    Posts
    13,988
    It looks like the protocol handler (for the music stream) somehow tries to process the artwork.

    Btw: regarding the issue above, mixcloud does work for me again, so it doesn't seem to be generally broken
    ---
    learn more about iPeng, the iPhone and iPad remote for the Squeezebox and
    Logitech UE Smart Radio as well as iPeng Party, the free Party-App,
    at penguinlovesmusic.com
    New: iPeng 9, the Universal App for iPhone, iPad and Apple Watch

  5. #25
    Senior Member
    Join Date
    Jan 2008
    Posts
    339
    I've just installed and it works here too (LMS 7.9 which is running on a Windows Server 2012).

    Unbelievable how flexible the platform is, even after all these years.

    Thanks a lot for the effort findechris!

  6. #26
    Quote Originally Posted by findechris View Post
    If is there still somebody interested in a Mixcloud plugin, i created one frome the Soundcloud Plugin. It is still in Alpha stage and i just tested it with the SqueezeServer 7.9 and the squeezelite player and the squeezebox Radio.
    I really like the Squeezebox Server but i really dislike perl and the poor documentation of the logitech squeezebox Server!!!
    You can find the plugin here github.com/findechris/lms_mixcloud
    Have fun.
    I tried to install your plugin on my Synology, but I get an error:

    [15-11-04 20:30:20.9381] Slim::Utils::PluginManager::load (295) Error: Couldn't load Plugins::MixCloud::Plugin
    [15-11-04 20:30:30.5565] Slim::Plugin::CLI::Plugin::cli_socket_open (166) Can't setup the listening port 9090: Address already in use

    Sabnzbd is already running on that port.

    Is there a way to change the port of the MixCloud plugin (the plug does not start and is not listen in settings -> advanced)?

  7. #27
    Junior Member
    Join Date
    May 2009
    Location
    FL
    Posts
    22
    Quote Originally Posted by kefkekeyser View Post
    I tried to install your plugin on my Synology, but I get an error:

    [15-11-04 20:30:20.9381] Slim::Utils::PluginManager::load (295) Error: Couldn't load Plugins::MixCloud::Plugin
    [15-11-04 20:30:30.5565] Slim::Plugin::CLI::Plugin::cli_socket_open (166) Can't setup the listening port 9090: Address already in use

    Sabnzbd is already running on that port.

    Is there a way to change the port of the MixCloud plugin (the plug does not start and is not listen in settings -> advanced)?
    I'm not so sure that we will ever get a reply. The plugins author has only posted once, then he disappeared. Bit of a shame.

    I would really like some help diagnosing a problem with this plugin working on my Qnap NAS, but doesn't look like that will happen.
    LMS 7.9.0 -> QNAP TVS-871 Raid 5, Slimdevices Silver Transporter, 1 * SB Touch, 2 * SB Duets, 2 * SB Boom, 1 * SB Radio, 1 * Wandboard Quad, (1 dead SB Classic), Rasp Pi 2.0 + HiFiBerry-Amp+ Official Touchscreen + PiCorePlayer

  8. #28
    Senior Member pinkdot's Avatar
    Join Date
    Nov 2009
    Location
    The Netherlands
    Posts
    839
    Quote Originally Posted by kefkekeyser View Post
    I tried to install your plugin on my Synology, but I get an error:

    [15-11-04 20:30:20.9381] Slim::Utils::PluginManager::load (295) Error: Couldn't load Plugins::MixCloud::Plugin
    [15-11-04 20:30:30.5565] Slim::Plugin::CLI::Plugin::cli_socket_open (166) Can't setup the listening port 9090: Address already in use

    Sabnzbd is already running on that port.

    Is there a way to change the port of the MixCloud plugin (the plug does not start and is not listen in settings -> advanced)?
    Yes you can, its in the LMS webui. Go to -> settings->Advanced-> command line Interface -> change your port.
    -Synology nas DS115 - (LmsUpdate) + (LmsRepack)
    -RPI 3 (Moode 3.6 + LibreSpot), IQaudIO Pi-DAC PRO - Exposure 3010S2 - PMC GB1i
    -2x Radio
    -Laptop - openSUSE Leap - LMS/Squeezelite

  9. #29
    Junior Member
    Join Date
    Jun 2014
    Posts
    25
    so how do i install this mixcloud plugin? do i do it through the LMS or do i need to code it in? sorry if this has already been addressed. i looked back a few pages and just saw the d/l link. thanks for your efforts!

  10. #30
    Senior Member
    Join Date
    Jun 2009
    Posts
    120

    able to log into mixcloud and play your favorites like soundcloud

    does anyone know if there is a way to log into mixcloud and play favorites like soundcloud? just a lot easier as searching in sort of a pain...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •