Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 47
  1. #11
    Senior Member
    Join Date
    May 2008
    Location
    United States
    Posts
    11,044
    Quote Originally Posted by aubuti View Post
    Use a better tagging program for editing the compilation tag. Just because you use iTunes for some things doesn't mean you can't use other programs sometimes for the same files. If you're on Windows, mp3tag is an excellent tagger. If you're on Linux, I'd recommend puddletag. If you're on OSX, I don't know what to recommend.
    I haven't checked lately, but I recall that in itunes saying "no" to compilation is the same as having a COMPILATION filed that is blank (or not even there) in mp3tag. Saying YES is the same as COMPILATION=1 in mp3tag.

    In the old days there were some differences as itunes used something that showed up in mp3tag as ITUNESCOMPILATION. But since that time, simple COMPILATION in mp3tag maps to itunes directly....
    Home: VortexBox 4TB (2.4) > LMS 7.9.1 > Transporter, Touch, Boom, Radio (all ethernet)
    Cottage: VBA 3TB (2.4) > LMS 7.9.1 > Touch > Benchmark DAC I, Boom, Radio w/Battery (all ethernet except Radio)
    Office: Win8(64) > LMS 7.9.1 > Squeezelite
    Spares: Transporter, Touch(3), Radio(3), Boom, SB3, CONTROLLER
    Controllers: iPhone6 & iPadAir2 (iPeng & Squeezepad), CONTROLLER, or SqueezePlay 7.8 on Win10(64) laptop
    Files: ripping: dbpoweramp > FLAC; post-rip: mp3tag, PerfectTunes; Streaming: Spotify

  2. #12
    MrSinatra
    Guest
    Quote Originally Posted by phinfo View Post
    I have the same problem but using iTunes.

    If I undestand correctly you manage 3 values for the compilation tag "blank, 0, or 1 (if compilation)", Am I correct ?

    BUT with iTunes I can only set Yes or No, any ideas how can I solve this issue to be also happy happy with clean list of artists.......
    r u on mac or windows?

    either way, itunes is ok to set comp=1 (yes) but i don't know what it does otherwise. as said, ultimately u need a good tagger, and itunes is not that.

    comp=1, comp=0, comp=[null/blank], and no mention of a comp frame at all; are the four comp states you will in a file's tag. my advice to 99.9% of users is to use albumartist tags on everything, and then add comp=1 to those things you want LMS or itunes to know is a comp.

    so basically, a tag should either not mention a comp frame at all, OR comp=1 if so desired. those are the only two states of the 4 available i purposely use.

  3. #13
    Senior Member
    Join Date
    May 2008
    Location
    United States
    Posts
    11,044
    Quote Originally Posted by MrSinatra View Post
    so basically, a tag should either not mention a comp frame at all, OR comp=1 if so desired. those are the only two states of the 4 available i purposely use.
    yes, definitely!
    Home: VortexBox 4TB (2.4) > LMS 7.9.1 > Transporter, Touch, Boom, Radio (all ethernet)
    Cottage: VBA 3TB (2.4) > LMS 7.9.1 > Touch > Benchmark DAC I, Boom, Radio w/Battery (all ethernet except Radio)
    Office: Win8(64) > LMS 7.9.1 > Squeezelite
    Spares: Transporter, Touch(3), Radio(3), Boom, SB3, CONTROLLER
    Controllers: iPhone6 & iPadAir2 (iPeng & Squeezepad), CONTROLLER, or SqueezePlay 7.8 on Win10(64) laptop
    Files: ripping: dbpoweramp > FLAC; post-rip: mp3tag, PerfectTunes; Streaming: Spotify

  4. #14
    Junior Member
    Join Date
    Jan 2012
    Posts
    3
    [QUOTE=MrSinatra;688830]r u on mac or windows?

    Thanks for your help.

    For MrSinatra I use Windows.

    I have just tried with Mp3tag and deleted the COMPILATION TAG.

    But no change in LMS, on the artist list I still have an entry based on the ARTIST tag AND an other on the ALBUMARTIST tag

    I am on a Synology LMS 7.7.1 server.

    Any idea how to have an entry ONLY based on the ARTIST tag and not based on the ALBUMARTIST tag

  5. #15
    MrSinatra
    Guest
    LMS normally will always prefer the albumartist tag over the artist tag, UNLESS you use the Comp=0 tag with it. Comp=0 will explode the artists on a comp with an AA tag into the artists list.

    you also might experiment with the settings in LMS, that allow you to list all artists on comps, so in that scenario you would use AA and comp=1 and adjust the lms settings for that.

    these might help you figure out whats going on:

    http://wiki.slimdevices.com/index.ph..._Artists_logic

    http://wiki.slimdevices.com/index.php/Compilations
    Last edited by MrSinatra; 2012-02-05 at 16:23.

  6. #16
    Junior Member
    Join Date
    Jan 2012
    Posts
    3

    Smile

    Thanks for the support, I have now everythink to clean my music.

  7. #17
    I think I'm having a similar problem, but can't seem to fix it.

    On LMS v 7.7.1 (Crunchbang Linux), under the My Music/Artists tab, almost all of the artists are in perfect alphabetical order. However, about 20-25 artists are clumped in between "Vangelis" and "Various Artists". All of these artists happen to have their own full albums as well as tracks on compilations.

    I initially suspected a tagging problem, so I checked some of the suspect files out using EasyTag and ExFalso. I found nothing wrong in the tags, but cleared all tags anyway. This didn't help.

    Then I found this thread. Based on what indigo_daisies posted, I went into the Compilations option under the Settings/My Music tab, and changed the setting from "Group compilation albums together" to "List compilation albums under each artist". I then completely cleared and rescanned the music library. Unfortunately, this did not fix the problem.

    Not sure if this is relevant, but these are FLAC files stored on a NAS.

    Any ideas?

    Thanks.

  8. #18
    Senior Member
    Join Date
    Jun 2008
    Posts
    195
    Maybe you can check your tags also with Puddletag (Extended tags: ctrl+e). Or you can remove with tagtools APEv2 tags.
    Ape tags in combination with ID3 tags are causing much problems. Always use one tag format in your tags.
    "Puddletag is an audio tag editor (primarily created) for GNU/Linux similar to the Windows program, Mp3tag. Unlike most taggers for GNU/Linux, it uses a spreadsheet-like layout so that all the tags you want to edit by hand are visible and easily editable."
    http://puddletag.sourceforge.net/
    It is also possible to use mp3tag with wine under Linux.
    Squeezebox: 2x Touch + 1x 3 Classic + 2x Radio
    Squeezelite 0.9beta7: 4x
    Logitech Media Server: Version: 7.8.0 - 1395409907
    Plugins: Album Review 2.9.9; Biography 2.9.9; Smart Mix v1.4.3; Song Info 1.1.3883; Song Lyrics 1.1.3856; Spicefly SugarCube v4.60; Trackstat v3.2.3926; YouTube 0.16
    NAS: QNAP Turbostation TS-239 Pro II (1,6Ghz, 1GB); firmware 4.1.0 Build 20140605; QPKG LogitechMediaServer 7.7.2
    Tag: MusicBrainz Picard 1.2 (Ubuntu 14.04); Puddletag 1.0.2 (Ubuntu 14.04)
    Last.fm

  9. #19
    Member
    Join Date
    Oct 2012
    Location
    Southern UK
    Posts
    68
    My first encounters with tagging were with WMP - that was pretty basic and I didn't encounter too many issues. When I moved to Media Jukebox, the world of tagging opened up in front of me in all it's glory and accompanying confusion. Well before coming to the Squeezebox I sussed out what worked best for me and how to tidy up and standardise the tagging. I did create a few custom fields and of course they don't get recognised by LMS but that's another issue. In short, I fill in both the ARTIST and ALBUM ARTIST fields with the same artist name for every track I have ripped/downloaded. The exception being for various artist albums and for these I enter the ALBUM ARTIST field as "Various Artists" and for the ARTIST field I give the actual artist/band name. When I did my first few LMS scans there were a few anomalies - all caused by tagging and until I used MP3Tag I couldn't see what was causing the issues. With MP3tag, I found that none of my ALBUM ARTIST tag fields had been ported across to MP3Tag, so the first thing I did was to spend an hour or so copying from the ARTIST field to the ALBUM ARTIST field. Subsequent rips now mean that I have to manually add those fields within MP3Tag after ripping and before each new LMS scan. It's no big deal and has become part and parcel of the procedure to get music onto the Touch - the only real hassle is waiting for the MP3tag application to load the initial data!

    Within LMS I use "List compilation albums under each artist" / "List albums by band" / "Treat TPE2 MP3 tag as Album Artist"

    Now I'm sure those of you who have a far greater understanding of the mechanics of LMS will shout that I am duplicating unnecessarily, however, I NEVER get spurious cataloguing problems within LMS. In other words, every artist is filed as I expect, every album has an entry in all fields I require and I no longer get entries in the "No Artist" and "No Album" fields within LMS.

    The above doesn't work with Classical but then I don't use the Touch for classical, preferring to use the CD (but they are other issues)

    Others have mentioned a "Compilation" tag but I admit to not knowing where or what this setting is; is it an external tag field or is it a setting within LMS? Either way, I use nothing that highlights a compilation other than by default within the context of the ALBUM ARTIST tag field.
    Last edited by StridingEdge; 2013-02-09 at 14:22.

  10. #20
    Turns out I *did* have some tagging issues causing problems. I didn't realize that an incorrectly/carelessly tagged compilation album would basically bootstrap all of the other single-artist albums by artists on that same comp. I should have realized that. Sorry to junk up the thread!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •