Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: 802.11n support

  1. #1
    Junior Member
    Join Date
    Nov 2009
    Location
    Glasgow, Scotland
    Posts
    29

    802.11n support

    I recently altered my Apple Time Capsule wireless router settings at home so that it is only using a 2.4GHz 802.11n signal and not b/g. I thought I would need to run my Boom via a ethernet cable as I understood it cannot connect to a 802.11n network. Oddly though it is continuing to work perfectly via wifi and the network is definitely only running on 802.11n, any idea why this is working?

    My SB Radio does support 802.11n so all is good there as expected.

  2. #2
    Senior Member toby10's Avatar
    Join Date
    Jul 2007
    Location
    USA (home of the bottomless credit card)
    Posts
    8,397
    The Boom does not have 802.11n chipsets.
    So either your router is broadcasting both g & n or your n is running with a backwards compatibility g mode (which may be the default behaviour).

  3. #3
    Junior Member
    Join Date
    Nov 2009
    Location
    Glasgow, Scotland
    Posts
    29
    It does have a backwards compatibility mode but I have disabled this and double checked this with my wifi monitoring software. I'm curious to see if my Boom is actually connected to a external open network instead of my own. Must go investigate by unplugging my router.

  4. #4
    Senior Member toby10's Avatar
    Join Date
    Jul 2007
    Location
    USA (home of the bottomless credit card)
    Posts
    8,397
    Quote Originally Posted by sneeks View Post
    It does have a backwards compatibility mode but I have disabled this and double checked this with my wifi monitoring software. I'm curious to see if my Boom is actually connected to a external open network instead of my own. Must go investigate by unplugging my router.
    I'd suggest changing the name of your SSID to something unique, then such accidental connections cannot happen.

    I do not use any n gear, but I don't see how a g rated device can see or connect to a pure n signal (no g and no backwards compatibility).
    It would be like having a b rated device trying to connect to a g only router, the b chipset could not even see the g signal much less connect to it.
    Last edited by toby10; 2010-06-19 at 06:36.

  5. #5
    Junior Member
    Join Date
    Nov 2009
    Location
    Glasgow, Scotland
    Posts
    29
    Ok I have double checked everything again and the Boom is displaying the correct SSID for my router. All other G only network devices cannot connect to the network while it is in N only mode but the Boom continues to stream music without issue. I'm very confused now.

  6. #6
    Senior Member
    Join Date
    May 2008
    Location
    United States
    Posts
    9,419
    Quote Originally Posted by sneeks View Post
    Ok I have double checked everything again and the Boom is displaying the correct SSID for my router. All other G only network devices cannot connect to the network while it is in N only mode but the Boom continues to stream music without issue. I'm very confused now.
    Have you, for example, held down the BOOM power button so that it resets, and goes back through the finding the internet connection again. I can't recall the exact circumstances, but I had a transporter keep playing an internet radio station even after I'd turned off the computer with SbS running. Odd I know. But my limited understanding of how this works is that SbS and mysb.com merely make the connection to the internet radio stream for you and after that the SB player is really just talking to the internet stream source.

    Anyhow, my comment is that if you haven't rebooted the Boom, it might have somehow remained connected to the router, even though you changed the router settings. Not likely I know, but worth mentioning.

  7. #7
    Junior Member
    Join Date
    Nov 2009
    Location
    Glasgow, Scotland
    Posts
    29
    I think I have discovered what is happening. My internal network is 802.11n only on the Apple Time Capsule and this connects to a Airport Express at the opposite end of the house to extend my network. If the AE is disconnected the Boom will not connect to the network. If I reconnect the AE then the Boom functions correctly. I can only assume that the AE is able to communicate on the N band and G band simultaneously so that it can stream over the network with both devices.

  8. #8
    Senior Member toby10's Avatar
    Join Date
    Jul 2007
    Location
    USA (home of the bottomless credit card)
    Posts
    8,397
    Quote Originally Posted by sneeks View Post
    I think I have discovered what is happening. My internal network is 802.11n only on the Apple Time Capsule and this connects to a Airport Express at the opposite end of the house to extend my network. If the AE is disconnected the Boom will not connect to the network. If I reconnect the AE then the Boom functions correctly. I can only assume that the AE is able to communicate on the N band and G band simultaneously so that it can stream over the network with both devices.
    Now that makes sense.

  9. #9
    Senior Member
    Join Date
    Nov 2005
    Location
    Berlin, DE
    Posts
    1,869
    Quote Originally Posted by sneeks View Post
    I recently altered my Apple Time Capsule wireless router settings at home so that it is only using a 2.4GHz 802.11n signal and not b/g. I thought I would need to run my Boom via a ethernet cable as I understood it cannot connect to a 802.11n network. Oddly though it is continuing to work perfectly via wifi and the network is definitely only running on 802.11n, any idea why this is working?

    My SB Radio does support 802.11n so all is good there as expected.
    Just so you know, there is no reason to disable 11g on equipment that supports 11n. There is no performance issue with having both. 11b -> 11g changed the RF modulation, but 11g -> 11n basically didn't. 11n is a superset of features (mostly 5.8ghz and channel bonding) and can interoperate fine with 11g devices.

  10. #10
    Junior Member
    Join Date
    Nov 2009
    Location
    Glasgow, Scotland
    Posts
    29
    Quote Originally Posted by SuperQ View Post
    Just so you know, there is no reason to disable 11g on equipment that supports 11n. There is no performance issue with having both. 11b -> 11g changed the RF modulation, but 11g -> 11n basically didn't. 11n is a superset of features (mostly 5.8ghz and channel bonding) and can interoperate fine with 11g devices.
    That's handy to know, thank you. I'd have ideally liked to select the 5GHz 802.11n setting on my router but not all of my devices would support this so I'll make do with the standard 802.11g/n setting for now.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •