Home of the Squeezebox™ & Transporter® network music players.
Page 3 of 22 FirstFirst 1234513 ... LastLast
Results 21 to 30 of 219
  1. #21
    Senior Member erland's Avatar
    Join Date
    Dec 2005
    Location
    Sweden
    Posts
    11,009
    Quote Originally Posted by mherger View Post
    > I get the same problem if I click on the image or on the link.
    > I'm using Ubunbtu 8.04.3 on the server with a svn installation of
    > Squeezebox Server 7.5.


    What perl version are you running?
    v5.8.8 built for i486-linux-gnu-thread-multi

    Quote Originally Posted by mherger View Post

    > I've only seen the problem in Firefox, I tried it in IE8 on a Windows
    > client towards the same server and there it seems to work perfectly. On


    FF 3.6 is fine here. Are you using the Classic skin by default, or Default?
    Classic, but I'm using the patched plugin version from yesterday. In Classic it happens always in Default it just happens sometimes (every second time it seems).
    Erland Isaksson (My homepage)
    Lead platform developer of ickStream Music Platform - A world of music at your fingertips

    (Also developer of many plugins/applets (both free and commercial). If you like to encourage future presence on this forum and/or third party plugin/applet development, consider purchasing some plugins)

  2. #22
    Senior Member erland's Avatar
    Join Date
    Dec 2005
    Location
    Sweden
    Posts
    11,009
    Quote Originally Posted by mherger View Post
    Could you please add the following line?


    Index: Common.pm
    ================================================== =================
    --- Common.pm (revision 997)
    +++ Common.pm (working copy)
    @@ -718,6 +718,7 @@

    };

    + $response->header("Content-Type" => "image/jpeg");
    main:EBUGLOG && $@ && $log->debug($@);
    }
    Sorry, same problem.
    Erland Isaksson (My homepage)
    Lead platform developer of ickStream Music Platform - A world of music at your fingertips

    (Also developer of many plugins/applets (both free and commercial). If you like to encourage future presence on this forum and/or third party plugin/applet development, consider purchasing some plugins)

  3. #23
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,681

    [Announce] Photo Gallery Plugin v1.0

    I'm sorry, didn't have time yet to investigate this issue. I'll let you know.

  4. #24
    Senior Member erland's Avatar
    Join Date
    Dec 2005
    Location
    Sweden
    Posts
    11,009
    Quote Originally Posted by mherger View Post
    I'm sorry, didn't have time yet to investigate this issue. I'll let you know.
    Don't worry it isn't urgent on my part, I just reported it so you have the information if you like to correct it when you get the time.

    Point 5 in my initial list is a lot worse because it results in that images isn't even shown on the Squeezebox Touch/Radio/Controller. It's still not urgent for me though, so take your time.
    Erland Isaksson (My homepage)
    Lead platform developer of ickStream Music Platform - A world of music at your fingertips

    (Also developer of many plugins/applets (both free and commercial). If you like to encourage future presence on this forum and/or third party plugin/applet development, consider purchasing some plugins)

  5. #25
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,681

    [Announce] Photo Gallery Plugin v1.0

    > No, IV doesn't seem to autorotate at all. I'll file a bug.

    Did you ever file a bug? I just fixed it - but didn't find your report.

    --

    Michael

  6. #26
    Junior Member
    Join Date
    Apr 2010
    Location
    Stockholm
    Posts
    10

    Strict filename rules?

    Dear Michael,

    I installed the Photo Gallery plugin on my setup (SBC/WHS with Duet) because I also have a collection of pictures on the same machine.
    But I noticed that files with names like DSC_0275.JPG do not play.
    Renaming the file to abc.jpg (ie. no underscore and no capitals) makes the file play in the controller. Via my browser(Chrome) I get the text version when it opens in a new window. But doing this in IExplorer does give the right image.

    I hope that it is possible to do something about the filename restrictions.

    Thanks for the plugin and the work you've put in.

  7. #27
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,681

    [Announce] Photo Gallery Plugin v1.0

    > I installed the Photo Gallery plugin on my setup (SBC/WHS with Duet)
    > because I also have a collection of pictures on the same machine.
    > But I noticed that files with names like DSC_0275.JPG do not play.


    Sounds like Erlands problem #5. Are you using 7.5.0?

    Erland - did you ever try to use the same file with 7.6? I think there is a bug in SBS' resizing code which considers the above a resizing spec (like eg. photo_320x240.jpg - 320x240 being the desired image size).

    It look as if that actually was a bug in SBS 7.5.0. Or two: a.) filename parsing is broken, b.) it doesn't return the correct content type when returning the generic icon. I filed bug 16028. I hope to get it in to 7.5.1.

    Michael

  8. #28
    Junior Member
    Join Date
    Apr 2010
    Location
    Stockholm
    Posts
    10
    Quote Originally Posted by mherger View Post
    > I installed the Photo Gallery plugin on my setup (SBC/WHS with Duet)
    > because I also have a collection of pictures on the same machine.
    > But I noticed that files with names like DSC_0275.JPG do not play.


    Sounds like Erlands problem #5. Are you using 7.5.0?

    Erland - did you ever try to use the same file with 7.6? I think there is a bug in SBS' resizing code which considers the above a resizing spec (like eg. photo_320x240.jpg - 320x240 being the desired image size).

    It look as if that actually was a bug in SBS 7.5.0. Or two: a.) filename parsing is broken, b.) it doesn't return the correct content type when returning the generic icon. I filed bug 16028. I hope to get it in to 7.5.1.

    Michael
    Are indeed running 7.5. Guess I'll have to hold out till the next updat then.

  9. #29
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,681

    [Announce] Photo Gallery Plugin v1.0

    > Point 5 in my initial list is a lot worse because it results in that
    > images isn't even shown on the Squeezebox Touch/Radio/Controller. It's
    > still not urgent for me though, so take your time.


    Erland - could you please try again with the 7.5.1 trunk? I've checked in a fix to the file name regex which should make this work now.

  10. #30
    formerly known as Fletch
    Join Date
    May 2005
    Posts
    2,237
    Quote Originally Posted by mherger View Post
    Did you ever file a bug? I just fixed it - but didn't find your report.
    Sorry, no. Do yo still want one?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •