Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 4 of 4
  1. #1
    Member
    Join Date
    Jan 2006
    Location
    Outside of Toronto, Canada
    Posts
    96

    Issues With Playlists

    I've lost the link to my Playlists in Squeezebox Server despite the fact the Basic Settings are pointing to the folder where my Playlists reside. When I select “Playlist” from the menu, Squeezebox Server replies with “Empty”. Also, when I go to the sub-menus under “My Music” (e.g.: “Years), the library data is there, but the music won’t play when requested.

    I’ve scanned and rescanned the entire library as well as “Playlists” individually, and no luck.

    Also suspicious; while the library statistics generally appear to be correct, Squeezebox Server shows Artists as equaling 0. In fact when I call up Artists under “My Music”, Squeezebox Server responds with “Empty”.

    Running Squeezebox Server 7.4.2

    Any help appreciated.
    Tim

    Living Room: Touch, Bryston B60R w/built-in DAC, PMC FB1i Speakers
    Kitchen: Boom
    Bedroom: Radio
    iPeng / Controller for all

  2. #2
    Senior Member Mnyb's Avatar
    Join Date
    Feb 2006
    Location
    Västerås Sweden
    Posts
    13,294
    The scan must have gone wrong somehow do check the server.log and scanner.log files .

    What OS do run SBS on ?

    What do you use as Antivirus ? (if you are on windows)
    --------------------------------------------------------------------
    Main hifi: Touch + CIA PS +MeridianG68J MeridianHD621 MeridianG98DH 2 x MeridianDSP5200 MeridianDSP5200HC 2 xMeridianDSP3100 +Rel Stadium 3 sub.
    Bedroom/Office: Boom
    Kitchen: Touch + powered Fostex PM0.4
    Misc use: Radio (with battery)
    iPad1 with iPengHD & SqueezePad
    (in storage SB3, reciever ,controller )
    server HP proliant micro server N36L with ClearOS Linux

    http://people.xiph.org/~xiphmont/demo/neil-young.html

  3. #3
    Member
    Join Date
    Jan 2006
    Location
    Outside of Toronto, Canada
    Posts
    96
    Quote Originally Posted by Mnyb View Post
    The scan must have gone wrong somehow do check the server.log and scanner.log files .

    What OS do run SBS on ?

    What do you use as Antivirus ? (if you are on windows)
    What should I be looking for in the log files?

    Windows 7, AVG Free.

    Thanks.
    Tim

    Living Room: Touch, Bryston B60R w/built-in DAC, PMC FB1i Speakers
    Kitchen: Boom
    Bedroom: Radio
    iPeng / Controller for all

  4. #4
    Member
    Join Date
    Jan 2006
    Location
    Outside of Toronto, Canada
    Posts
    96

    Play list Errors in Log

    Does the snip of the log below help in identifying the issue? Error 1918 appears several times in the log.


    [10-03-19 20:35:02.1110] Slim::Control::Request::execute (1918) Error: While trying to run function coderef [Slim::Control::Commands:laylistXitemCommand]: [Carp::Clan::__ANON__(): DBI Exception: DBD::mysql::st execute failed: Lock wait timeout exceeded; try restarting transaction [for Statement "
    REPLACE INTO contributor_album
    (role, contributor, album)
    VALUES
    (?, ?, ?)
    "] at /<C:\PROGRA~1\SQUEEZ~1\server\SQUEEZ~3.EXE>Slim/Schema/Storage.pm line 86
    ]
    [10-03-19 21:59:32.9034] Slim::Control::Request::execute (1918) Error: While trying to run function coderef [Slim::Control::Commands:laylistcontrolCommand]: [Can't call method "name" on an undefined value at /<C:\PROGRA~1\SQUEEZ~1\server\SQUEEZ~3.EXE>Slim/Control/Commands.pm line 1888.
    ]
    Tim

    Living Room: Touch, Bryston B60R w/built-in DAC, PMC FB1i Speakers
    Kitchen: Boom
    Bedroom: Radio
    iPeng / Controller for all

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •