Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 3 123 LastLast
Results 1 to 10 of 21
  1. #1
    Junior Member
    Join Date
    Jul 2008
    Location
    Boise, id
    Posts
    17

    Question Plea for MySQL 5.1 compatibility

    Where is the best place to voice my support for MySQL 5.1 compatibility for SBS? I would like to be able to run KDE 4.X applications that require MySQL 5.1 (latest beta of Amarok 2.2.2, K3b, etc.). If I try to install these applications, I must remove SBS, and of course, that is not an option.

    Music lovers who own Logitech audio equipment like Squeezeboxes and run servers on Linux probably also choose to run Amarok. Amarok is the most promising audio management and playback application for Linux. (I know there are nostalgic v1.4 Amarok users out there, but it was time for the community to move on to a more stable architecture).

  2. #2
    Administrator andyg's Avatar
    Join Date
    Jan 2006
    Location
    Pittsburgh, PA
    Posts
    7,395
    SBS runs fine with MySQL 5.1.

  3. #3
    Member
    Join Date
    Nov 2005
    Location
    Germany
    Posts
    68
    squeezeboxserver 7.4.1 depends show (on Debian Lenny):
    Code:
    Depends: perl (>= 5.8.8), mysql-server-4.1 | mysql-server-5.0, libmysqlclient14-dev | libmysqlclient15-dev, mysql-client-4.1 | mysql-client-5.0, adduser

    I have a hard time remembering how to tweak dependencies, but IIRC there is some --ignore-depends switch to apt-get.
    SB3 wired, SB3 wireless, SB Radio
    Squeezebox Server 7.5.3 on Debian Lenny/2.6.26-2-amd64
    Plugins FindArt, WeatherTime Screensaver

  4. #4
    The same issue under Ubuntu Karmic when trying to install the released version:

    Code:
    :~$ sudo apt-get install squeezeboxserver
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies.
      squeezeboxserver: Depends: mysql-server-4.1 but it is not installable or
                                 mysql-server-5.0 but it is not going to be installed
    E: Broken packages

  5. #5
    Senior Member
    Join Date
    Dec 2009
    Location
    Germany
    Posts
    324
    the debian package might depend on mysql-server 5.0. You can either force it to install (ignoring dependencies). Or you can install a fake dummy package that provides mysql-server 5.0 or you can install from a source tarball.

    I run SBS 7.4.1 with mysql 5.1 (external database) on debian squeeze (arm). Both installed from package.

  6. #6
    Senior Member mudlark's Avatar
    Join Date
    Aug 2006
    Location
    Cumbria, England
    Posts
    714
    Quote Originally Posted by andyg View Post
    SBS runs fine with MySQL 5.1.
    andy..as far as I know my bug was never properly dealt with and also 7.4.1 has not had the fix applied as far as I know.

    The fix is still try 7.4.2 and then if that doesn't work add mysql-client-5.1 and try again.
    Transporter or Cyrus streamX>CyrusDACX>PreXvs>ESPAudio P09B Active filter>Cyrus X x 2>Rhapsody, Avondale and Naim cable, Kubuntu 12.04 server, various boxes for storage.
    SB3 Flycatcher 3A linear power supply. Touch also.
    Using SqueezeBoxServer (LMS) 7.8
    Also piCorePlayer>Rega DAC>B4>Avondale 260>KEF iQ7 Kubuntu 14.04

  7. #7
    Junior Member
    Join Date
    Jul 2008
    Location
    Boise, id
    Posts
    17

    how?

    Where can I get 7.4.2 packages?
    Is this the best place? http://downloads.slimdevices.com/nightly/?ver=7.4

    If I want to stay with 7.4.1, how do you take away the dependencies on MySQL 5.0?
    When I try to install MySQL 5.1 in Synaptic, I get the attached warning that SBS will be removed.

    Thanks,
    Dave
    Attached Images Attached Images  

  8. #8
    Junior Member
    Join Date
    Jul 2008
    Location
    Boise, id
    Posts
    17

    how?

    Where can I get 7.4.2 packages?
    Is this the best place? http://downloads.slimdevices.com/nightly/?ver=7.4

    If I want to stay with 7.4.1, how do you take away the dependencies on MySQL 5.0?
    When I try to install MySQL 5.1 in Synaptic, I get the attached warning that SBS will be removed.

    Thanks,
    Dave
    Attached Images Attached Images  

  9. #9
    Junior Member
    Join Date
    Jan 2010
    Posts
    10
    Quote Originally Posted by andyg View Post
    SBS runs fine with MySQL 5.1.
    Is there some trick to the install, or is it just a Kubuntu 9.10 issue?

    I tried to install SBS 7.4.1 on an Acer revo and both kpackagekit and gdebi-installer refused. Gdebi-installer revealed that it had a mysql 5.0 dependency and that could not be installed. I uninstalled the 5.1 server and client and SBS seemed to install, although the commandline

    'sudo squeezeboxserver'

    fails with a

    'BEGIN failed--compilation aborted at /usr/sbin/squeezeboxserver line 134.'

    There were some install problems requiring a 'sudo apt-get install -f' and that seemed to have some problems, as well. Anyway, some of the KDE4 features are now gone including kpackagekit.

    My next cunning plan is to 'burn' my usb with 9.04, install that and try again. If that works and I then upgrade to 9.10, will SBS stop working?

    I noticed someone else suggested installing a dummy package for mysql-server 5.0 to fool SBS into installing with mysql 5.1. Can anyone tell me how that might be done?

    Regards
    Roy Leith

    Regards
    Roy Leith

  10. #10
    Senior Member
    Join Date
    Dec 2009
    Location
    Germany
    Posts
    324
    a dummy package means building a dummy debian package with no actual content and a provides line. If you don't know about package building, ignore this advice.

    I just noticed that on my debian the mysql-server-5.0 package also provides mysql-server-5.1. Looks like ubuntu packs different.


    you can try to override the dependency check manual.

    your ubuntu system should have installed mysql-server, mysql-client and all other dependencies of squeezeboxserver.

    so in a terminal you write

    apt-get install mysql-server mysql-client libmysqlclient15-dev perl

    this should ensure (on ubuntu) that mysql-server and client are version 5.1.

    then you can try to force the installation of the squeezebox server package

    dpkg --force-depends squeezeboxserver_7.4.1_all.deb


    In my opinion there should be no problem with SBS and mysql 5.1. No old features have gone away, only a few timestamp bugs have been introduced, and most likely SBS is not using any overly complicated sql statements.

    Can some offical developer state if the sbs is compatible with mysql 5.1 (at least it is running here)? I could look into an unoffical repacking of the deb (if i find the sources) that also accepts mysql 5.1.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •