Home of the Squeezebox™ & Transporter® network music players.
Page 406 of 446 FirstFirst ... 306356396404405406407408416 ... LastLast
Results 4,051 to 4,060 of 4454
  1. #4051
    Senior Member
    Join Date
    Nov 2010
    Location
    Hertfordshire, UK
    Posts
    2,485
    It seems people living outside the UK and using a VPN to access UK domestic iplayer streams may be being blocked. See http://www.theregister.co.uk/2015/10...pn_to_iplayer/
    LMS 7.9.1 on VortexBox Midi box, Xubuntu 17.04, FLACs 16->24 bit, 44.1->192kbps. Touch & EDO. 2nd Touch standard.
    LMS plugin UPnP/DLNA Bridge to MF M1 CLiC (to A308CR amp & ESLs) & Marantz CR603 UPnP renderers.
    Alternatively Minimserver & Upplay to same & to upmpdcli/mpd PC renderers.
    Squeezelite to Meridian USB Explorer DAC to PC speakers/headphones.
    Wireless Xubuntu 17.04 laptop firefox/upplay or Android 'phone with Squeeze-Commander/BubbleUPnP controls LMS/Minimserver.

  2. #4052
    Senior Member
    Join Date
    Jun 2014
    Location
    North Somerset, UK
    Posts
    286

    BBC changes again?

    To continue the conversation started in the quick fix thread.

    Whilst live radio continues to work, Listen Again has stopped working although the programme info is displayed. The HLS streams are still there and working because, for example, if you open http://www.bbc.co.uk/radio/aod/avail...adio4extra.xml and paste an HLS link into the 'Tune in URL' in the LMS GUI, play will commence using the Play HLS plugin. Way beyond my scope but presumably something in Triode's plugin needs changing to accommodate the latest changes.

    Maybe all is not yet lost!

  3. #4053
    Senior Member
    Join Date
    May 2006
    Location
    New York
    Posts
    234
    While this is the UK only thread, the same thing is happening with the non-UK streams.

    Bill

  4. #4054
    Senior Member
    Join Date
    May 2008
    Location
    United States
    Posts
    10,949
    Quote Originally Posted by ftlight View Post
    While this is the UK only thread, the same thing is happening with the non-UK streams.

    Bill
    Same here. Live nonUK is working, iPlayerEXTRA playing old stuff is working, but the listen again under iPlayer is NOT working (see show info, but stays on "0" and doesn't play)
    Home: VortexBox 4TB (2.3) > LMS 7.9 > Transporter, Touch, Boom, Radio (all ethernet)
    Cottage: VBA 3TB (2.3) > LMS 7.9 > Touch > Benchmark DAC I, Boom, Radio w/Battery (all ethernet except Radio)
    Office: Win8(64) > LMS 7.9 > Squeezelite
    Spares: Transporter, Touch(3), Radio(3), Boom, SB3, CONTROLLER
    Controllers: iPhone6 & iPadAir2 (iPeng & Squeezepad), CONTROLLER, or SqueezePlay 7.8 on Win8(64) laptop
    Files: ripping: dbpoweramp > FLAC; post-rip: mp3tag, PerfectTunes; Streaming: Spotify

  5. #4055
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    14,809
    Quote Originally Posted by PaulinPosset View Post
    To continue the conversation started in the quick fix thread.

    Whilst live radio continues to work, Listen Again has stopped working although the programme info is displayed. The HLS streams are still there and working because, for example, if you open http://www.bbc.co.uk/radio/aod/avail...adio4extra.xml and paste an HLS link into the 'Tune in URL' in the LMS GUI, play will commence using the Play HLS plugin. Way beyond my scope but presumably something in Triode's plugin needs changing to accommodate the latest changes.

    Maybe all is not yet lost!
    BBC have added content choice of HLS or DASH format where previously there was only only format. Plugin needs to be modified to pick the HLS format.

  6. #4056
    Senior Member
    Join Date
    Jun 2014
    Location
    North Somerset, UK
    Posts
    286
    Quote Originally Posted by bpa View Post
    BBC have added content choice of HLS or DASH format where previously there was only only format. Plugin needs to be modified to pick the HLS format.
    I thought it looked different to the last time I looked at it as couldn't remember the 'dash' streams being there. I've spent the last hour or so looking at the BBCXMLParser file and the other files to see if there is an obvious link to the content choice but it's all way beyond me really.

  7. #4057
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    14,809
    I don't have time to to make up a patcth etc and this is just for adventurous to test to see if it works for UK and non UK users.

    Stop LMS and edit the BBCXMLParser.pm file in the BBCiPlayer plugin


    patch deleted because it is not correct and replace BBCXMLParser fiule as per utgg post below.

    edit:

    This patch is not quite right because XML seems to return DASH and HLS in some instances and only HLS contents in others - the above patch will work if only HLS is returned.
    Last edited by bpa; 2015-10-29 at 03:18. Reason: remove patch

  8. #4058
    Senior Member
    Join Date
    Oct 2010
    Location
    UK
    Posts
    306
    I've also had a play. Don't know how this compares to your patch, bpa, but I think the attached forces it to make sure the HLS rather than DASH url is picked up.
    Attached Files Attached Files

  9. #4059
    Senior Member Jeff07971's Avatar
    Join Date
    Aug 2011
    Location
    London, England
    Posts
    753
    Quote Originally Posted by bpa View Post
    I don't have time to to make up a patcth etc and this is just for adventurous to test to see if it works for UK and non UK users.

    Stop LMS and edit the BBCXMLParser.pm file in the BBCiPlayer plugin

    On around line 97 add the text "->{'mediaselector'}" in the place shown in red, save & close the file and then restart LMS

    Code:
    		my $title = $entry->{'title'}; 
    		$log->error(Dumper($entry->{'links'}));
    
    		# move info to top level of entry so we can filter on it
    		$entry->{'url'} = $entry->{'links'}->{'mediaselector'}->{'content'};
    		for my $info (keys %{$entry->{'parents'}}) {
    			$entry->{ lc($info) } = $entry->{'parents'}->{ $info }->{'content'};
    		}
    edit:

    This patch is not quite right because XML seems to return DASH and HLS in some instances and only HLS contents in others - the above patch will work if only HLS is returned.


    Tried this but no luck, though no error is shown in the logs
    Players: SliMP3,Squeezebox3 x3,Receiver,SqueezePlayer,PiCorePlayer x3,Wandboard
    Server: LMS Version: 7.9.0 - 1475786002 on Centos 7 VM on ESXi 6 on Dell T320
    Plugins: AutoRescan/BBCiPlayer/PowerSave/PowerSwitchIII/Squeezecloud
    Remotes: iPeng8/Orangesqueeze/PC/Jivelite
    Music: 383GB,1269 albums 17756 songs 4381 artists mostly FLACs

    Want a webapp ? See http://forums.slimdevices.com/showth...Webapp-for-LMS

  10. #4060
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    14,809
    Quote Originally Posted by utgg View Post
    I've also had a play. Don't know how this compares to your patch, bpa, but I think the attached forces it to make sure the HLS rather than DASH url is picked up.
    Shall I leave the fix to you ? I haven't anymore time until later on tonight.

    My fix worked for me becuase the XMLin merged hls and dash content into one link which is not correct but happened to remove the dash and leave the hls - I think you're on the right track as XMLin needed to be changedto avoid this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •