Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 8 of 8
  1. #1
    Junior Member
    Join Date
    Mar 2008
    Posts
    4

    Unhappy Monkey, Monkey do-do: Freenas problem

    I'm working here under " monkey see, monkey do", I'm trying to learn.I have an installed freenas : freenas.mshome
    Version 0.686.2 (revision 2891)
    OS Version FreeBSD 6.2-RELEASE-p11 (revision 199506)
    Platform i386-embedded on Intel Celeron (256 memory)697 MHz
    I'm able to reach it through winXp. I wanted to install slimserver on it. When I attempt to create a second share one of two things happen- 1) the new share asks for an unknown password when I attempt to reach it via winXP, or 2) the share contains the folder of the original share. If I create a slimnas folder (containing slimnas.tgz, slimnas-install.sh ,and slimserver_v6.5.1.nocpan-arch.tar.gz)and and attempt to execute command I get "$ bin/sh /mnt/data/slimnas/slimnas-install.sh" and nothing happens. In this instance "data" is the name of my original share since I can't open the other share. My shares are: /mnt/datadisk/ name:data
    /mnt name:slimer - the second share I can't open.Does freenas support 2 shares ok? HELP!
    Last edited by ccchuck; 2008-03-15 at 09:30.

  2. #2
    Junior Member
    Join Date
    Mar 2008
    Posts
    4

    Something to check

    Under "Services -> CIFS/SMB -> Settings tab" have you set "Authentication" to "Local User"?

    Under "Services -> CIFS/SMB -> Shares tab" how does "Hosts allow" and "Hosts deny" look? Double check that your "Path" is correct by clicking "..." and browsing to it. It must be located under your mountpoint.

    Under "Access -> Users and Groups" have you created a user and/or group there? (pref. create a user with the same username and password as you use on your XP-machine.

  3. #3
    Junior Member
    Join Date
    Mar 2008
    Posts
    4

    monkey continues..

    I answered your questions/comments below-
    Does Frenas support more than one share if using embedded?, that is, my disk is already partitioned, partition1 being the OS, partition2 data.
    When I attempt a new share I can't partiton 1 since it is the OS and is very small.
    Does that mean I create a share on partition 2?


    Under "Services -> CIFS/SMB -> Settings tab" have you set "Authentication" to "Local User"? YES


    Under "Services -> CIFS/SMB -> Shares tab" how does "Hosts allow" and "Hosts deny" look? BOTH BLANK
    Double check that your "Path" is correct by clicking "..." and browsing to it. PATH NOT FOUND
    It must be located under your mountpoint.
    PLEAS EXPLAIN MORE IF YOU WOULD

    Under "Access -> Users and Groups" have you created a user and/or group there? (pref. create a user with the same username and password as you use on your XP-machine YES I HAVE.

    I really appreciate your willingness to help, all too often "dumb" questions like mine are ignored. :-)

  4. #4
    Junior Member
    Join Date
    Mar 2008
    Posts
    4
    Quote Originally Posted by ccchuck View Post
    I answered your questions/comments below-
    Under "Services -> CIFS/SMB -> Shares tab" how does "Hosts allow" and "Hosts deny" look? BOTH BLANK

    Double check that your "Path" is correct by clicking "..." and browsing to it. PATH NOT FOUND
    It must be located under your mountpoint.
    PLEAS EXPLAIN MORE IF YOU WOULD
    Ok, first things first...dont use CAPS unless you are shouting at me, wish Im hoping you are not. :-D

    Do the following.

    1.) The path not found doesnt sound good. Your mount point can be checked under "Disks -> Mount Point". I guess yours is named "data".

    Tha means your path to your mount point is "/mnt/data"

    2.) You can try to set "Hosts allow" to ALL (maybe not recomended to allow everyone access).

    I have linked a couple of screenshoots so that you can see what I mean. Hope it helps.

  5. #5
    Junior Member
    Join Date
    Mar 2008
    Posts
    4

    the monkey is turning gray...

    Sorry about the shouting was trying to be sure my answers were noticed...

    Ok some progress thanks to your help, I have two shares, data, and one so originally named slim. Both are now accessible from the GUI.
    I created a folder in slim called slimnas, put slimnas.tgz,
    slimnas-install.sh, and slimserver 6.5.4 no-cspan-arch.tar.gz IN that folder.
    When I execute "/bin/sh /mnt/slim/slimnas/slimnas-install.sh"
    nothing happens, I get "$ /bin/sh /mnt/slim/slimnas/slimnas-install.sh" and no further feedback.

  6. #6
    Junior Member
    Join Date
    Mar 2008
    Posts
    4
    Quote Originally Posted by ccchuck View Post
    When I execute "/bin/sh /mnt/slim/slimnas/slimnas-install.sh"
    nothing happens, I get "$ /bin/sh /mnt/slim/slimnas/slimnas-install.sh" and no further feedback.
    Try to put your slimnas directory in your first share (data).
    And execute something like: "/bin/sh /mnt/data/slimnas/slimnas-install.sh"

    Notice that "slimnas" and "Slimnas" is not the same thing under FreeBSD as its casesensitive.

  7. #7
    Junior Member
    Join Date
    Mar 2008
    Posts
    4

    the monkey dances!

    rereading your posts and others here, I re-did most everything, and now it works!

    I really appreciate the help!

  8. #8
    Junior Member
    Join Date
    Mar 2008
    Posts
    4

    Smile

    Quote Originally Posted by ccchuck View Post
    rereading your posts and others here, I re-did most everything, and now it works!

    I really appreciate the help!
    Glad it works, have fun with it!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •