Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 3 of 3
  1. #1
    Junior Member
    Join Date
    Jan 2008
    Posts
    2

    "can't connect to retrieve playlist" AlienBBC on QNAP 209

    Hello all,

    well this is a weird one and I've tried just about everything, which makes me think it PEBKAC...'problem exists between the keyboard and chair'

    I recently got a SB3 and QNAP 209 NAS. I loaded slimserver package from progressive (6.5.3 with 6.5.4 upgrade) and all seemed well for a week or two. There have been some events over the last week including a power outage which crashed the disks(in which I needed to fsck to get the disks back online) and a reconfig of the network and now I getting connection timeouts for AlienBBC stations from the SB3 and SS gui. The SB3 and Softsqueeze come back with "can't connect to retrieve playlist". To isolate I connected my laptop with Slimserver to the same cable and same IP as the QNAP and was able to connect and play music ok. When swapped over with QNAP no-go although Shoutcast etc do work, so it is a problem specific with AlienBBC/SS on QNAP. Next I uninstalled SS package and reinstalled, this did not fix the problem. As a last effort, I pulled the disks and went through the fresh installation including initialising/formatting disks, still had the same problem after a fresh install of all software/firmware. When I look at the outgoing traffic on the firewall I only see HTTP traffic to the BBC sites but RTSP/554 traffic doesn't seem to leave the box.

    Can't find any decent log files to view/enable on the QNAP, which doesn't help.

    Any help or advice greatly appreciated,

    cheers
    caz

  2. #2
    I've experienced a number of occasions where AlienBBC has suddenly stopped working for no apparent reason. Like you I was convinced that it was something to do with the server (mine's a TS-109). I discovered, though, that it wasn't the server, but a problem with the base station/router. By accident I regained access to the AlienBBC streams by restarting each element on the network in turn - my router is separate to the wireless base station/hub that the TS-109 is connected to. Since then, when it has happened on other occasions I've just had to restart the base station (an Apple Airport Extreme 802.11n) device.

    The Airport box is connected to a Zoom X3 router, which is configured in half bridge mode, so the IP address it gets from my ISP is passed directly to the base station, and it is this device that runs the DHCP server that my Squeezeboxes get their addresses from. Unfortunately I've not yet determined what the circumstances are that cause AlienBBC to stop working. It is only AlienBBC that is affected - music streaming from the server works fine, as do other Internet radio stations. One possibility might be the unavailability of some ancillary service, like ntp, which AlienBBC depends on for some reason, but that is only a wild guess (there are a number of messages in the Qnap logs relating to the unavailability of ntp). If anyone else out there has other ideas I'd be happy to try them out.

    Steve

  3. #3
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    15,328
    A few months ago - a lot of people experienced problems with Apple Airport Extreme - it would block rtsp traffic so couldn't play BBC RealAudio streams over RTSP. You can see lots of postings on the reciva users forum.

    RealPlayer would work because it can use Realaudio over http. A theory was that it was related to Apple TV which may use a different version of rtsp.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •