Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1
    Senior Member
    Join Date
    Mar 2007
    Posts
    260

    .@_thumb in qnap

    I have a Qnap and when i browse the music folder I now see these .@_thumb things which I can not see in windows explorer. i seached this site for "_thumb" and got not results but I am hoping it's an easy and obvious one.... many thanks

  2. #2
    Senior Member
    Join Date
    Jun 2006
    Location
    Portland, OR
    Posts
    566
    Quote Originally Posted by willyhoops View Post
    I have a Qnap and when i browse the music folder I now see these .@_thumb things which I can not see in windows explorer. i seached this site for "_thumb" and got not results but I am hoping it's an easy and obvious one.... many thanks
    Hello,

    QNAP multimedia server generates thumbnails of images (e.g. Album art). These images will be stored in the .@ folders. Since they are hidden, you can't see them in the explorer.
    2 x Squeezebox 3 - 1 x Squeezebox Touch - SSOTS 4.14 - Squeezecenter 7.7.3 - QNAP TS439 Pro (3.6.3) - 4 x 500 GB Hitachi (RAID5)

  3. #3
    Senior Member
    Join Date
    Mar 2007
    Posts
    260
    can i get rid of them so they don't show up in slim server?

  4. #4
    Senior Member
    Join Date
    Jun 2006
    Location
    Portland, OR
    Posts
    566
    Quote Originally Posted by willyhoops View Post
    can i get rid of them so they don't show up in slim server?
    For me it is not a problem since i don't us the browsefolder function. Nevertheless it should be possible to patch the correspondig file. I am not a Perl expert, so i don't know how to do this. The Scanner.pm could be patched because flip has already done it for the synology diskstation with the 'eapatch' <- corresponding folders of the Diskstation. I tried this also with the Scanner.pm, but i think this is only relevant for the DB scan and not for Browsing through folders.
    2 x Squeezebox 3 - 1 x Squeezebox Touch - SSOTS 4.14 - Squeezecenter 7.7.3 - QNAP TS439 Pro (3.6.3) - 4 x 500 GB Hitachi (RAID5)

  5. #5
    Senior Member
    Join Date
    Mar 2007
    Posts
    260
    My goodness I have never used perl in my life and hardly a word of that made any sense to me. No idea what a "Scanner.pm" is or for that matter a "synology diskstation" or an "epatch"! I guess usless someone else has fixed this problem I will have to put up with it. What a shame, i wish i had just bough another pc- less hassle that this qnap with all it's funny bugs.
    Last edited by willyhoops; 2007-10-14 at 04:02.

  6. #6
    Senior Member
    Join Date
    Jun 2006
    Location
    Portland, OR
    Posts
    566
    Quote Originally Posted by willyhoops View Post
    What a shame, i wish i had just bough another pc- less hassle that this qnap with all it's funny bugs.
    It is not a problem of the QNAP and mine is working nearly excellent. You should try another device with the TwonkyMedia. Then you will see that Slimserver is nearly perfect (even with the directories that you don't want to see). As i told you, it is the same on other NAS devices as e.g. the Diskstation.
    2 x Squeezebox 3 - 1 x Squeezebox Touch - SSOTS 4.14 - Squeezecenter 7.7.3 - QNAP TS439 Pro (3.6.3) - 4 x 500 GB Hitachi (RAID5)

  7. #7
    Senior Member
    Join Date
    Mar 2007
    Posts
    260
    Well I spent ú1,000 on a handheld palm Sony UX vista machine so i could control the hifi from the web browser instead of using the tiny transporter screen. and now i have dumb ".@_thumb" entries everywhere and it really bugs me. how can i show my web interface to friends with pride when it is full of buggy entries.

    then there is the fact that qnap filenames are case sensitive so i have to find a way to turn all the "folder.JPG" images to "folder.jpg" across 700 albumns or i see no artwork in the browser.

    on top of that i have a strange qnap problem where web pages are getting corrupted even without me editing them (only happens while slimserver is running so qnap is very busy and multiple people access my web site).

    And then there is the fact that qnap is dead slow... just clicking on the browser or using the controls on the squeezebox takes an age.

    all in all i am gutted.
    Last edited by willyhoops; 2007-10-14 at 04:51.

  8. #8
    Senior Member
    Join Date
    Jun 2006
    Location
    Portland, OR
    Posts
    566
    Quote Originally Posted by willyhoops View Post
    Well I spent ú1,000 on a handheld palm Sony UX vista machine so i could control the hifi from the web browser instead of using the tiny transporter screen. and now i have dumb ".@_thumb" entries everywhere and it really bugs me. how can i show my web interface to friends with pride when it is full of buggy entries.

    then there is the fact that qnap filenames are case sensitive so i have to find a way to turn all the "folder.JPG" images to "folder.jpg" across 700 albumns or i see no artwork in the browser.

    on top of that i have a strange qnap problem where web pages are getting corrupted even without me editing them (only happens while slimserver is running so qnap is very busy and multiple people access my web site).

    And then there is the fact that qnap is dead slow... just clicking on the browser or using the controls on the squeezebox takes an age.

    all in all i am gutted.
    Ok,

    but then you should have bought a real server.

    Nevertheless there could be a solution for your .@__thumb problem. You just have to move the Music folders to another directory and then you have to link this folder to the slimserver environment.

    http://forums.slimdevices.com/showthread.php?t=37838

    But then you still have to remove the .@__thumb folders in this tree. The QNAP won't create new subfolders in this area since it is only done in Qmultimedia. When i've got time, i will try.
    2 x Squeezebox 3 - 1 x Squeezebox Touch - SSOTS 4.14 - Squeezecenter 7.7.3 - QNAP TS439 Pro (3.6.3) - 4 x 500 GB Hitachi (RAID5)

  9. #9
    Senior Member
    Join Date
    Mar 2007
    Posts
    260
    Ok many thanks I will try that. I tried to put the files in another directoy before but it did not work. I will follow that post and try again. Many thanks

  10. #10
    Senior Member
    Join Date
    Jun 2006
    Location
    Portland, OR
    Posts
    566
    Quote Originally Posted by willyhoops View Post
    Ok many thanks I will try that. I tried to put the files in another directoy before but it did not work. I will follow that post and try again. Many thanks
    Hello again, i've moved the music now to another share and mounted it to the chroot environment. Then i've written a script that removes you all the .@__thumb directories


    find /share/Music/ -type d | grep .@__thumb > foo
    while read LINE
    do
    set $LINE
    echo $LINE
    rm -r "$LINE"
    done < foo
    rm foo


    /share/Music/ is the new location of your music (probably you have to change it)

    SS scans the music and it seems to work (before the scan, you have to reboot the QNAP). A first look in the 'Browsefolder' shows me no .@__ directories.

    If you use Trackstat, then you also have to change the statistic xml file (just exchange the ...Qmultimedia.... to ...Music...)
    Last edited by mr_hyde; 2007-10-14 at 09:53.
    2 x Squeezebox 3 - 1 x Squeezebox Touch - SSOTS 4.14 - Squeezecenter 7.7.3 - QNAP TS439 Pro (3.6.3) - 4 x 500 GB Hitachi (RAID5)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •