Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 6 of 6
  1. #1
    Junior Member
    Join Date
    Mar 2007
    Posts
    7

    Internet speed and wireless network

    Does internet speed have anything to do with dropouts when running SB3 wireless from a computer? In other words, not using any internet based music. I have huge problems more than 50% of the time with slow motion, hesitating music. My wireless signals are all high but my internet connection has been horrible recently(they're "working" on it). I'm wondering if there's any connection.

    I run a US Robotics MaxG router and a US Robotics MaxG extender. WPA Personal security. My music is on a fairly new Apple iMac. I stream nothing but lossless audio like FLAC and AIF to my Squeezebox. Reliability is zero. One day it works and another it doesn't. The server and network health page on SlimServer shows 100% at 3000 kpbs with no music playing but with music playing, I'm lucky to get 100% above 1000 kbps. Most readings are 100%, 50% or 0%. Any ideas? I'm ready to give up on this thing and buy something different. BTW, I have the same problems with my Windows XP laptop so it doesn't seem to be Apple specific.

    Thanks.
    Last edited by amini1; 2007-04-04 at 19:13.

  2. #2
    Junior Member
    Join Date
    Mar 2007
    Posts
    7
    One more thing...here is the SlimServer I'm using:

    SlimServer Version: 6.5.0 - 9916 - Mac OS X 10.4.9 (8P2137) - EN - utf8
    Server IP address: 192.168.2.2
    Perl Version: 5.8.6 darwin-thread-multi-2level
    MySQL Version: 5.0.22-standard

  3. #3
    Senior Member
    Join Date
    Jun 2005
    Posts
    128

    Sounds familiar

    At one point in time I too suffered like you.
    Then I noticed it was only when playing music that I was suffering from dropouts. Make that when streaming music it was most noticeable.

    After numerous tech support calls, I found out that it had to with the network dropping packets.

    The tech support people had me go into my router software/firmware and adjust a couple of settings. They made me upgrade to the latest version of the firmware, change my Threshold setting and then had me change the MTU setting.

    Once that was done, I nevered suffered from dropouts again.
    My connect has been stable ever since.


    Maybe you learn from my pain..

    1) Upgrade your routers firmware
    2) Call the tech support people and see if they can tell you about the threshold and mtu settings and how to change them.

    It worked for me.

    I'm running windows xp sp2, linksys wrt54g router and 6.5.1

    I hope this helps

  4. #4
    Senior Member
    Join Date
    Apr 2005
    Location
    Minnesnowta, USA
    Posts
    117
    this is a long shot, but ya never know...

    It *could* possibly be DNS issues. A similar symptom happened to me a long time ago (FreeBSD), when my cable-modem provider was having all sorts of trouble.

    I've never touched a mac, but you might try looking into setting up your own local DNS, at least so that your server doesn't try and hit your ISP's DNS server to lookup host-names for your 192.168.2.* addresses on your LAN.

    Under 'bsd, it was just a matter of setting up /etc/hosts with a whole buncha entries for my network:

    --
    ::1 localhost
    127.0.0.1 localhost
    192.168.1.1 router
    192.168.1.2 server
    192.168.1.3 dot3
    192.168.1.4 dot4
    192.168.1.5 dot5
    ...
    192.168.1.255 dot255
    --

    And also making sure that my /etc/host.conf file looked like:
    --
    hosts
    bind
    --

    This tells the OS to first try resolving hostnames from the local hosts file first, and THEN to consult bind (which would try to get the info from a DNS server on the internet, typically whatever your cable-modem tells it to).


    Probably not much help, though OSX is derived from 'bsd. Might give you something to go on, anyways. Good luck!

  5. #5
    Senior Member
    Join Date
    Nov 2005
    Location
    Berlin, DE
    Posts
    1,870
    Quote Originally Posted by bflatmajor View Post
    Maybe you learn from my pain..

    1) Upgrade your routers firmware
    2) Call the tech support people and see if they can tell you about the threshold and mtu settings and how to change them.

    It worked for me.

    I'm running windows xp sp2, linksys wrt54g router and 6.5.1

    I hope this helps
    yep, it sounds like packet loss to me too.. Can you tell us what the before/after MTU settings were? I've never seen any device default to anything other than 1500 before.. and I've only done minor adjustments to MTU before to work around 802.1q vlan problems.. and of course moving some networks over to 9000 for jumbo frames.. but that was gige only, and not wireless.

    Updating router firmware seems to be a common problem.. not the fault of end users, but companies like Linksys releasing half-baked crap software.

    It's stuff like 802.11n draft equipment and constant beta quality firmware that makes wireless a pain in the ass.

  6. #6
    Junior Member
    Join Date
    Mar 2007
    Posts
    7
    I figured it was some sort of packet loss. My firmware is the latest(from 2005). I'll see what I can find out about MTU and theshold settings.

    Maditude, I like the idea of setting up a sort of priority list like you did. Since I rarely use anything from the internet on my SB3, I really don't need the connection just my own local network.

    Thanks everyone and any more suggestions will be greatly appreciated.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •