Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 10 of 10
  1. #1
    Jeff Pound
    Guest

    Player only plays for 5 seconds under Red Hat 8.0 Linux :(

    Greetings all,

    I've been using the windows server with my Slimp3 for six months or so
    and everything has been working fine. Now it's time to migrate to the
    Linux server and I have a problem. I have a fresh (server, no GUI )
    install of Red Hat 8.0 running on a Compaq Deskpro 6000 (350mhz 128megs
    ram). I installed the latest slimserver. The server runs with no errors,
    the web interface works great, the player is recognized and seems fine.
    But when I play a song it only plays for about 5 seconds, then stops and
    the player goes blank about 15 seconds after that and stays that way
    until I mess with it. Unfortunately I'm relatively new to Linux so I'm
    not sure how to troubleshoot this.

    I'm really hoping to get this straightened out, any info or suggestions
    would be very helpful!!!

    Thanks in advance.
    Jeff

  2. #2
    NOT a Slim Devices Employee kdf's Avatar
    Join Date
    Apr 2005
    Posts
    9,493

    Player only plays for 5 seconds under Red Hat 8.0 Linux :(

    Quoting Jeff Pound <jfpound (AT) zeno (DOT) math.fsu.edu>:

    > Greetings all,
    >
    > I've been using the windows server with my Slimp3 for six months or so
    > and everything has been working fine. Now it's time to migrate to the
    > Linux server and I have a problem. I have a fresh (server, no GUI )
    > install of Red Hat 8.0 running on a Compaq Deskpro 6000 (350mhz 128megs
    > ram). I installed the latest slimserver. The server runs with no errors,
    > the web interface works great, the player is recognized and seems fine.
    > But when I play a song it only plays for about 5 seconds, then stops and
    > the player goes blank about 15 seconds after that and stays that way
    > until I mess with it. Unfortunately I'm relatively new to Linux so I'm
    > not sure how to troubleshoot this.
    >
    > I'm really hoping to get this straightened out, any info or suggestions
    > would be very helpful!!!
    >

    from the terminal:

    su -c "/etc/init.d/slimserver stop"
    cd /usr/local/slimserver
    ../slimserver.pl --d_source

    see what happens as you try to play.

    You can also try running 'Top' while the service is running. start playing a
    song and watch for slimserver.pl in the list and see wha the CPU usage level is at.

    -kdf

  3. #3
    Jeff Pound
    Guest

    Player only plays for 5 seconds under Red Hat 8.0 Linux

    Thanks for the quick response. I followed your instruction, it's been doing something for a while now. It seems to be telling me the same thing over and over. The output looks like:
    Use of uninitialized value in concatenation (.) or string at Slim/Player/Source.pm line 175.
    Use of uninitialized value in concatenation (.) or string at Slim/Player/Source.pm line 175.
    2003-12-17 22:20:01 songTime: 0 = (0(realpos) / 0(size) * (duration) * 1(rate)) + (time offset of started stream)
    2003-12-17 22:25:02 realpos 0 calcuated from bytes received: 0 minus buffer fullness: 0
    Use of uninitialized value in concatenation (.) or string at Slim/Player/Source.pm line 175.
    Use of uninitialized value in concatenation (.) or string at Slim/Player/Source.pm line 175.
    2003-12-17 22:25:02 songTime: 0 = (0(realpos) / 0(size) * (duration) * 1(rate)) + (time offset of started stream)
    2003-12-17 22:30:03 realpos 0 calcuated from bytes received: 0 minus buffer fullness: 0
    Use of uninitialized value in concatenation (.) or string at Slim/Player/Source.pm line 175.
    Use of uninitialized value in concatenation (.) or string at Slim/Player/Source.pm line 175.
    2003-12-17 22:30:03 songTime: 0 = (0(realpos) / 0(size) * (duration) * 1(rate)) + (time offset of started stream)
    2003-12-17 22:35:04 realpos 0 calcuated from bytes received: 0 minus buffer fullness: 0
    Use of uninitialized value in concatenation (.) or string at Slim/Player/Source.pm line 175.
    Use of uninitialized value in concatenation (.) or string at Slim/Player/Source.pm line 175.
    2003-12-17 22:35:04 songTime: 0 = (0(realpos) / 0(size) * (duration) * 1(rate)) + (time offset of started stream)

    Is this what it's supposed to be doing or is it stuck in a loop?
    Thanks!!!

    kdf wrote:


    Quoting Jeff Pound &lt;jfpound (AT) zeno (DOT) math.fsu.edu&gt;:



    Greetings all, I've been using the windows server with my Slimp3 for six months or so and everything has been working fine. Now it's time to migrate to the Linux server and I have a problem. I have a fresh (server, no GUI ) install of Red Hat 8.0 running on a Compaq Deskpro 6000 (350mhz 128megs ram). I installed the latest slimserver. The server runs with no errors, the web interface works great, the player is recognized and seems fine. But when I play a song it only plays for about 5 seconds, then stops and the player goes blank about 15 seconds after that and stays that way until I mess with it. Unfortunately I'm relatively new to Linux so I'm not sure how to troubleshoot this. I'm really hoping to get this straightened out, any info or suggestions would be very helpful!!!



    from the terminal: su -c "/etc/init.d/slimserver stop" cd /usr/local/slimserver ../slimserver.pl --d_source see what happens as you try to play. You can also try running 'Top' while the service is running. start playing a song and watch for slimserver.pl in the list and see wha the CPU usage level is at. -kdf _______________________________________________ Discuss mailing list Discuss (AT) lists (DOT) slimdevices.com http://lists.slimdevices.com/lists/listinfo/discuss


  4. #4
    NOT a Slim Devices Employee kdf's Avatar
    Join Date
    Apr 2005
    Posts
    9,493

    Player only plays for 5 seconds under Red Hat 8.0 Linux :(

    This looks like an older streaming bug. What type of files are you trying to
    play? Can you try to upgrade to the latest nightly if you havne't already and
    see it that fixes the problem.

    http://www.slimdevices.com/downloads/nightly/latest

    -kdf

    Quoting Jeff Pound <jfpound (AT) zeno (DOT) math.fsu.edu>:


    > Thanks for the quick response. I followed your
    > instruction, it's been doing something for a while now. It seems to be
    > telling me the same thing over and over. The output looks like:
    >
    > Use of uninitialized value in concatenation (.) or string at
    > Slim/Player/Source.pm line 175.
    >
    > Use of uninitialized value in concatenation (.) or string at
    > Slim/Player/Source.pm line 175.
    >
    > 2003-12-17 22:20:01 songTime: 0 = (0(realpos) / 0(size) * (duration) *
    > 1(rate)) + (time offset of started stream)
    >
    > 2003-12-17 22:25:02 realpos 0 calcuated from bytes received: 0 minus
    > buffer fullness: 0
    >
    > Use of uninitialized value in concatenation (.) or string at
    > Slim/Player/Source.pm line 175.
    >
    > Use of uninitialized value in concatenation (.) or string at
    > Slim/Player/Source.pm line 175.
    >

  5. #5
    Jeff Pound
    Guest

    Player only plays for 5 seconds under Red Hat 8.0 Linux

    Yea, I decided it was stuck and rebooted.
    All my files are mp3s. The ones I'm trying to play have definitely played fine with the windows server. I'll try installing the nightly, can I install over the original or should I remove it first?
    Do you always work this late?

    kdf wrote:


    This looks like an older streaming bug. What type of files are you trying to play? Can you try to upgrade to the latest nightly if you havne't already and see it that fixes the problem. http://www.slimdevices.com/downloads/nightly/latest -kdf Quoting Jeff Pound &lt;jfpound (AT) zeno (DOT) math.fsu.edu&gt;:



    Thanks for the quick response. I followed your instruction, it's been doing something for a while now. It seems to be telling me the same thing over and over. The output looks like: Use of uninitialized value in concatenation (.) or string at Slim/Player/Source.pm line 175. Use of uninitialized value in concatenation (.) or string at Slim/Player/Source.pm line 175. 2003-12-17 22:20:01 songTime: 0 = (0(realpos) / 0(size) * (duration) * 1(rate)) + (time offset of started stream) 2003-12-17 22:25:02 realpos 0 calcuated from bytes received: 0 minus buffer fullness: 0 Use of uninitialized value in concatenation (.) or string at Slim/Player/Source.pm line 175. Use of uninitialized value in concatenation (.) or string at Slim/Player/Source.pm line 175.



    _______________________________________________ Discuss mailing list Discuss (AT) lists (DOT) slimdevices.com http://lists.slimdevices.com/lists/listinfo/discuss


  6. #6
    Jeff Pound
    Guest

    Player only plays for 5 seconds under Red Hat 8.0 Linux

    What's the difference between the noarch.rpm and src.rpm?

    kdf wrote:


    This looks like an older streaming bug. What type of files are you trying to play? Can you try to upgrade to the latest nightly if you havne't already and see it that fixes the problem. http://www.slimdevices.com/downloads/nightly/latest -kdf Quoting Jeff Pound &lt;jfpound (AT) zeno (DOT) math.fsu.edu&gt;:



    Thanks for the quick response. I followed your instruction, it's been doing something for a while now. It seems to be telling me the same thing over and over. The output looks like: Use of uninitialized value in concatenation (.) or string at Slim/Player/Source.pm line 175. Use of uninitialized value in concatenation (.) or string at Slim/Player/Source.pm line 175. 2003-12-17 22:20:01 songTime: 0 = (0(realpos) / 0(size) * (duration) * 1(rate)) + (time offset of started stream) 2003-12-17 22:25:02 realpos 0 calcuated from bytes received: 0 minus buffer fullness: 0 Use of uninitialized value in concatenation (.) or string at Slim/Player/Source.pm line 175. Use of uninitialized value in concatenation (.) or string at Slim/Player/Source.pm line 175.



    _______________________________________________ Discuss mailing list Discuss (AT) lists (DOT) slimdevices.com http://lists.slimdevices.com/lists/listinfo/discuss


  7. #7
    Jeff Pound
    Guest

    Player only plays for 5 seconds under Red Hat 8.0 Linux

    Oh yea, I ran top. the CPU never gets below 80% idle while it's playing.

    kdf wrote:


    This looks like an older streaming bug. What type of files are you trying to play? Can you try to upgrade to the latest nightly if you havne't already and see it that fixes the problem. http://www.slimdevices.com/downloads/nightly/latest -kdf Quoting Jeff Pound &lt;jfpound (AT) zeno (DOT) math.fsu.edu&gt;:



    Thanks for the quick response. I followed your instruction, it's been doing something for a while now. It seems to be telling me the same thing over and over. The output looks like: Use of uninitialized value in concatenation (.) or string at Slim/Player/Source.pm line 175. Use of uninitialized value in concatenation (.) or string at Slim/Player/Source.pm line 175. 2003-12-17 22:20:01 songTime: 0 = (0(realpos) / 0(size) * (duration) * 1(rate)) + (time offset of started stream) 2003-12-17 22:25:02 realpos 0 calcuated from bytes received: 0 minus buffer fullness: 0 Use of uninitialized value in concatenation (.) or string at Slim/Player/Source.pm line 175. Use of uninitialized value in concatenation (.) or string at Slim/Player/Source.pm line 175.



    _______________________________________________ Discuss mailing list Discuss (AT) lists (DOT) slimdevices.com http://lists.slimdevices.com/lists/listinfo/discuss


  8. #8
    NOT a Slim Devices Employee kdf's Avatar
    Join Date
    Apr 2005
    Posts
    9,493

    Player only plays for 5 seconds under Red Hat 8.0 Linux :(

    er....I'm at home, doing my emails

    you shoudl be able to install over top, but to be extra safe you can uninstall
    if you like

    -kdf
    > Yea, I decided it was stuck and rebooted.
    >
    > All my files are mp3s. The ones I'm trying to play have definitely
    > played fine with the windows server. I'll try installing the nightly,
    > can I install over the original or should I remove it first?
    >
    > Do you always work this late?
    >
    >
    >
    > kdf wrote:
    >
    >
    > This looks like an older streaming bug. What type of files are you trying
    > to
    > play? Can you try to upgrade to the latest nightly if you havne't already
    > and
    > see it that fixes the problem.
    >
    > http://www.slimdevices.com/downloads/nightly/latest
    >
    > -kdf
    >
    > Quoting Jeff Pound <jfpound (AT) zeno (DOT) math.fsu.edu>:
    >
    >
    >
    >
    > Thanks for the quick response. I followed your
    > instruction, it's been doing something for a while now. It seems to be
    > telling me the same thing over and over. The output looks like:
    >
    > Use of uninitialized value in concatenation (.) or string at
    > Slim/Player/Source.pm line 175.
    >
    > Use of uninitialized value in concatenation (.) or string at
    > Slim/Player/Source.pm line 175.
    >
    > 2003-12-17 22:20:01 songTime: 0 = (0(realpos) / 0(size) * (duration) *
    > 1(rate)) + (time offset of started stream)
    >
    > 2003-12-17 22:25:02 realpos 0 calcuated from bytes received: 0 minus
    > buffer fullness: 0
    >
    > Use of uninitialized value in concatenation (.) or string at
    > Slim/Player/Source.pm line 175.
    >
    > Use of uninitialized value in concatenation (.) or string at
    > Slim/Player/Source.pm line 175.
    >
    >
    >
    >
    >

  9. #9
    NOT a Slim Devices Employee kdf's Avatar
    Join Date
    Apr 2005
    Posts
    9,493

    Player only plays for 5 seconds under Red Hat 8.0 Linux :(

    Quoting Jeff Pound <jfpound (AT) zeno (DOT) math.fsu.edu>:

    >
    >
    >
    >
    >
    >
    >
    > What's the difference between the noarch.rpm and src.rpm?
    >

    noarch is the install. src is source code.

  10. #10
    Jeff Pound
    Guest

    Player only plays for 5 seconds under Red Hat 8.0 Linux

    OK, I removed the server and installed today's nightly. Unfortunately the problem is still there. Seems to be exactly the same. Is there something else I can try?

    Thanks in advance, Jeff

    kdf wrote:


    This looks like an older streaming bug. What type of files are you trying to play? Can you try to upgrade to the latest nightly if you havne't already and see it that fixes the problem. http://www.slimdevices.com/downloads/nightly/latest -kdf Quoting Jeff Pound &lt;jfpound (AT) zeno (DOT) math.fsu.edu&gt;:



    Thanks for the quick response. I followed your instruction, it's been doing something for a while now. It seems to be telling me the same thing over and over. The output looks like: Use of uninitialized value in concatenation (.) or string at Slim/Player/Source.pm line 175. Use of uninitialized value in concatenation (.) or string at Slim/Player/Source.pm line 175. 2003-12-17 22:20:01 songTime: 0 = (0(realpos) / 0(size) * (duration) * 1(rate)) + (time offset of started stream) 2003-12-17 22:25:02 realpos 0 calcuated from bytes received: 0 minus buffer fullness: 0 Use of uninitialized value in concatenation (.) or string at Slim/Player/Source.pm line 175. Use of uninitialized value in concatenation (.) or string at Slim/Player/Source.pm line 175.



    _______________________________________________ Discuss mailing list Discuss (AT) lists (DOT) slimdevices.com http://lists.slimdevices.com/lists/listinfo/discuss




    Quoting Jeff Pound &lt;jfpound (AT) zeno (DOT) math.fsu.edu&gt;:



    &gt; Greetings all, &gt; &gt; I've been using the windows server with my Slimp3 for six months or so &gt; and everything has been working fine. Now it's time to migrate to the &gt; Linux server and I have a problem. I have a fresh (server, no GUI ) &gt; install of Red Hat 8.0 running on a Compaq Deskpro 6000 (350mhz 128megs &gt; ram). I installed the latest slimserver. The server runs with no errors, &gt; the web interface works great, the player is recognized and seems fine. &gt; But when I play a song it only plays for about 5 seconds, then stops and &gt; the player goes blank about 15 seconds after that and stays that way &gt; until I mess with it. Unfortunately I'm relatively new to Linux so I'm &gt; not sure how to troubleshoot this. &gt; &gt; I'm really hoping to get this straightened out, any info or suggestions &gt; would be very helpful!!! &gt;



    from the terminal: su -c "/etc/init.d/slimserver stop" cd /usr/local/slimserver ../slimserver.pl --d_source see what happens as you try to play. You can also try running 'Top' while the service is running. start playing a song and watch for slimserver.pl in the list and see wha the CPU usage level is at. -kdf

    Attached Images Attached Images  

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •