Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 3 of 3

Hybrid View

  1. #1
    Senior Member hickinbottoms's Avatar
    Join Date
    Apr 2005
    Location
    Wokingham, UK
    Posts
    544

    ANNOUNCE: LazySearch v1.2 Released for SlimServer 6.2/6.3

    Iíve produced a bugfix release of the Lazy Search plugin for SlimServer 6.2 and 6.3. Note that this bug doesnít affect v2.x versions of the plugin for SlimServer 6.5 and so thereís no corresponding release for that SlimServer version.

    This fixes a bug reported by John Lara where some database entries would be continually re-lazified even though they were already lazified. This resulted in the search columns getting exponentially wider and wider until the rows got too large and caused SlimServer to run out of memory. All credit to the little sqlite library as it seemed to manage rows of over 85MB before the memory load got too great!

    Thanks to John for reporting it and helping to track it down.

    The plugin can be download from the plugin home page here:
    http://hickinbottom.demon.co.uk/lazysearch

    DETAILS

    This has probably been around for a long time, and Iím not too sure why it was occurring as the search looked sound to me (I think it might be a bug in the Perl database wrapper used in SlimServer 6.2.x/6.3.x, but Iíve not got to the bottom of it to be sure). Iíve changed the mechanism of searching for items to lazify to avoid it happening from now on.

    If Slim Devices are interested in the bug I think I found (Iíve not got enough confidence in this to raise a Bugzilla bug, and as Iíve not heard of anything similar for SlimServer without this plugin then Bugzilla isnít the right place to report it anyway), then the changes I had to make can be seen in this changeset:
    http://hickinbottom.demon.co.uk/lazy.../changeset/134

    The problem was the first search (the one that tries to find lazified items by searching with a LIKE '%||%' clause) wouldnít find all the rows that had that pattern in them, causing those rows to be re-lazified. This only affected a few rows out of the many that were in Johnís database, and there didnít appear to be anything particularly different about those rows that would make the search perform differently for them. At any rate I worked out how to do a proper NOT search with the database library and so avoided the need for the problematic search.

    Enjoy.

    Stuart
    "Never put off until tomorrow what you can put off until the day after - with Lazy Searching!"

  2. #2
    Greetings hickinbottoms,
    Thanks for the update , work great in V6.2.2.

  3. #3
    Senior Member Craig's Avatar
    Join Date
    Apr 2005
    Location
    Leeds, UK
    Posts
    845
    Hi Stuart,

    Sorry, I offered to test the new version for you but I've been a bit tied up with my Slim - J River Media Center project.

    I'll give it a go when I get a chance.

    Craig

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •