Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 3 123 LastLast
Results 1 to 10 of 27
  1. #1
    Senior Member gerph's Avatar
    Join Date
    Oct 2005
    Location
    Reading
    Posts
    179

    (AlienBBC) MPlayer under linux

    Hiya,

    This might not be the right please, but the AlienBBC website suggested posting updated instructions to this forum. The instructions for installing AlienBBC include a large point 4 'Ensure that mplayer is installed...'. Not knowing anything about MPlayer this was daunting. However, I made a note of what I did so that I could repeat it in the future, and I explained the process to a friend over the phone, so I know the process works - at least for Debian linux. If this is useful to someone then that's great - if not then I've not lost anything.

    Getting MPlayer working under linux:

    You require...

    * MPlayer from http://www.mplayerhq.hu/
    Source code is required
    All codecs package is required.

    * live555 support from http://www.live555.com/liveMedia/public/

    * Extract all codecs package to a directory.
    * Rename the directory to /usr/local/lib/codecs/
    * Make sure all the files are readable by the world.

    * Extract the live555 source using 'tar zxvf'.
    * Change to the 'live' directory.
    * Run './genMakefiles linux'
    * Run 'make'.
    * Move the 'live' directory to /usr/lib/live

    * Extract the MPlayer source.
    * Run './configure --enable-live --with-livelibdir=/usr/lib/live/
    --with-codecsdir=/usr/local/lib/codecs'
    * Check that the Enabled optional drivers 'Input' section has 'live.com'
    listed.
    * Check that the Enabled optional drivers 'Codecs' section has 'real'
    listed.
    * Run 'make'
    This will take a long time.
    * Run 'make install'

    * To test that the player works, run the following :
    mplayer rtsp://rmlivev8.bbc.net.uk/farm/*/ev7/live24/radio1/live/r1_dsat_g2.ra
    * You should see it connect and then start to decode; once it prints out
    'Starting playback', you know all's well.

  2. #2
    Thanks for this, I'll added a link to here from the instructions.

    Neil

  3. #3
    Junior Member
    Join Date
    May 2005
    Posts
    3

    Problems and solutions on Debian

    Thanx for the instructions, I run into a couple of problems during the installations. I thought it was a good idea to put them here together with my solutions.

    MPlayer webiste was down/unreachable. Finnaly found a mirror at
    http://www4.mplayerhq.hu/

    The codec package 'all' is available on the 'other codecs' link.

    Had to fix two read rights for world on two codecs.

    I had gcc version 4 on my newly installed Debian system, in order to compile without error I had to download version 3.4
    And the move the sym link to point to 3.4 instead of version 4

    Then I got this error:
    mplayer cannot exec `cc1plus':
    Which was solved by downloading libstdc++6-dev and maybe also g++-3.4

    BUT! It still doesn't work for me, mplayer work at the prompt but using slimserver on the same stream fails with the message:

    wma convert error - check file types

    How can I solve this, I have changed slimserver-conver.conf to use the pre7 version.


    Hope this helps someone more out there, and someone helps me with my problem.

    /fLa
    Last edited by fLa; 2005-10-15 at 06:23.

  4. #4
    formerly known as Fletch
    Join Date
    May 2005
    Posts
    2,239
    What exactly do the Live555 libraries do? I seem to be able to play rtsp streams without installing this...

  5. #5
    Senior Member
    Join Date
    Apr 2005
    Posts
    8,410
    fLA,

    Could you post the output of --d_source which inlcudes what happens when you try to play a stream.

  6. #6
    Senior Member
    Join Date
    Apr 2005
    Posts
    8,410
    You should not need the live555 libararies - make sure you turn off as much as possible (using commands to configure - see the windows web page on the Alien site)

  7. #7
    Junior Member
    Join Date
    Jul 2005
    Posts
    21
    Quote Originally Posted by fLa
    BUT! It still doesn't work for me, mplayer work at the prompt but using slimserver on the same stream fails with the message:

    wma convert error - check file types

    How can I solve this, I have changed slimserver-conver.conf to use the pre7 version.

    /fLa
    This probably means there are no wma conversions turned on in the slimsever config. In the Slimesrver web interface, go to Server settings|File types. Look down the list for the WMA ones. Check one of these and select "Change". If you don't see any errors (just a message about a setting being changed), then try and play the stream again.

    If you do see an error when you try and update the file types, post it up. mplayer is used to do the wma conversions, so make sure that the mplayer binary is in /usr/bin or /usr/local/bin and is executable by the user "slimserver".

    Cheers,
    Scoot

  8. #8
    Senior Member max.spicer's Avatar
    Join Date
    Apr 2005
    Location
    York, United Kingdom
    Posts
    1,661
    On debian, you can add the following to your /etc/apt/sources.list to easily add mplayer:

    deb ftp://ftp.nerim.net/debian-marillat/ sarge main

    Once you've done this, run 'apt-get update', then
    'apt-cache search mplayer' (both without the quotes). To find out about a particular package, do 'apt-cache show <pkgname>'. Once you know what package you want, 'apt-get install <pkgname>'. For example, 'apt-get install mplayer-586'.

    The above source also has packages for other debian releases. Have a look at ftp://ftp.nerim.net/debian-marillat/dists/ for info.

    Max

    Quote Originally Posted by gerph
    Hiya,

    This might not be the right please, but the AlienBBC website suggested posting updated instructions to this forum. The instructions for installing AlienBBC include a large point 4 'Ensure that mplayer is installed...'. Not knowing anything about MPlayer this was daunting. However, I made a note of what I did so that I could repeat it in the future, and I explained the process to a friend over the phone, so I know the process works - at least for Debian linux. If this is useful to someone then that's great - if not then I've not lost anything.

    Getting MPlayer working under linux:

    You require...

    * MPlayer from http://www.mplayerhq.hu/
    Source code is required
    All codecs package is required.

    * live555 support from http://www.live555.com/liveMedia/public/

    * Extract all codecs package to a directory.
    * Rename the directory to /usr/local/lib/codecs/
    * Make sure all the files are readable by the world.

    * Extract the live555 source using 'tar zxvf'.
    * Change to the 'live' directory.
    * Run './genMakefiles linux'
    * Run 'make'.
    * Move the 'live' directory to /usr/lib/live

    * Extract the MPlayer source.
    * Run './configure --enable-live --with-livelibdir=/usr/lib/live/
    --with-codecsdir=/usr/local/lib/codecs'
    * Check that the Enabled optional drivers 'Input' section has 'live.com'
    listed.
    * Check that the Enabled optional drivers 'Codecs' section has 'real'
    listed.
    * Run 'make'
    This will take a long time.
    * Run 'make install'

    * To test that the player works, run the following :
    mplayer rtsp://rmlivev8.bbc.net.uk/farm/*/ev7/live24/radio1/live/r1_dsat_g2.ra
    * You should see it connect and then start to decode; once it prints out
    'Starting playback', you know all's well.
    Some people think the title of this song is irrelevant,
    but it's not irrelevant - it's a hippopotamus.

  9. #9
    Senior Member
    Join Date
    Aug 2005
    Posts
    146
    Thanks for the apt-get tips.
    Does this do the 'full' install as detailed in the individual steps at the start of the thread (minus live555 I assume?), or are extra bits needed to get mplayer up and running ? Does everything get put in the right directory by the apt-get install ?

  10. #10
    Member
    Join Date
    Sep 2005
    Posts
    54
    Thanks for the install instructions.

    It worked great for me but the streams often go garbled and are not pleasant to listen to. Any hint/tips on how to fix this?

    I run CentOS Linux 4.1.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •