Home of the Squeezebox™ & Transporter® network music players.
Page 42 of 42 FirstFirst ... 32404142
Results 411 to 420 of 420
  1. #411
    Quote Originally Posted by mherger View Post
    >

    Is this still ongoing?
    Nope.
    Problem not reproducible this morning.
    Odd.

  2. #412
    Junior Member
    Join Date
    Oct 2017
    Posts
    6
    I was getting that 411 error on Tuesday while testing a Pi ZeroW with PiCorePlayer v3.22 with LMS. Also encountered that day with a Pi 3 running same stack with cable to network when I tried to check if the ZeroW was the problem. I ended up rebuilding, but may be I didn't need to, just wait for glitch to clear.

    Anyways, what I am getting on the Pi ZeroW now is:

    On the LMS server plugins>Advanced tab

    There has been a problem running the Spotty helper application. Most likely your operating system and/or platform is not supported. Please report the following details to me:

    Operating system: piCore / armv7l-linux

    Helper Applications Folder:
    /usr/local/slimserver/Bin/armhf-linux
    /usr/local/slimserver/Bin
    /usr/local/sbin
    /usr/local/bin
    /sbin
    /usr/sbin
    /bin
    /usr/bin
    /usr/local/slimserver/Cache/InstalledPlugins/Plugins/Spotty/Bin
    /usr/local/slimserver/Cache/InstalledPlugins/Plugins/Spotty/Bin/arm-linux
    On the LMS log

    [18-02-22 11:34:43.1478] main::init (387) Starting Logitech Media Server (v7.9.1, 1505480690, Fri Sep 15 22:32:08 UTC 2017) perl 5.024000 - arm-linux-gnueabihf-thread-multi-64int
    [18-02-22 11:34:46.9140] Slim::Utils::SQLiteHelper::postConnect (374) Optimizing DB because of missing or empty sqlite_stat1 table
    [18-02-22 11:34:46.9585] Slim::Schema::forceCommit (2149) Warning: Trying to commit transactions before DB is initialized!
    [18-02-22 11:34:48.1313] Slim::Utils::SQLiteHelper::postConnect (374) Optimizing DB because of missing or empty sqlite_stat1 table
    [18-02-22 11:34:48.1925] Slim::Schema::forceCommit (2149) Warning: Trying to commit transactions before DB is initialized!
    [18-02-22 11:34:53.5751] main::checkDataSource (1110) Warning: Schema updated or no media found in the database, initiating scan.
    [18-02-22 11:34:57.2046] Slim::Web::JSONRPC::requestMethod (443) b8:27:eb:44:59:8b: request not dispatchable!
    [18-02-22 11:35:22.1091] Slim::Utils::SQLiteHelper::postConnect (374) Optimizing DB because of missing or empty sqlite_stat1 table
    [18-02-22 11:35:22.1532] Slim::Schema::forceCommit (2149) Warning: Trying to commit transactions before DB is initialized!
    [18-02-22 19:25:19.0886] Plugins::Spotty::Connect::Daemon::_checkStartTimes (86) The spotty helper has crashed 3 times within less than 5 minutes - disable local announcement of the Connect daemon.
    [18-02-22 19:31:46.0259] main::init (387) Starting Logitech Media Server (v7.9.1, 1505480690, Fri Sep 15 22:32:08 UTC 2017) perl 5.024000 - arm-linux-gnueabihf-thread-multi-64int
    [18-02-22 19:31:52.1688] Slim::Utils::SQLiteHelper::postConnect (374) Optimizing DB because of missing or empty sqlite_stat1 table
    [18-02-22 19:31:52.2221] Slim::Schema::forceCommit (2149) Warning: Trying to commit transactions before DB is initialized!
    [18-02-22 19:31:53.4783] Slim::Utils::SQLiteHelper::postConnect (374) Optimizing DB because of missing or empty sqlite_stat1 table
    [18-02-22 19:31:53.5216] Slim::Schema::forceCommit (2149) Warning: Trying to commit transactions before DB is initialized!
    [18-02-22 19:31:58.2458] Plugins::Spotty::Connect::canSpotifyConnect (66) Cannot support Spotty Connect, need at least helper version 0.9.0
    [18-02-22 19:31:59.5158] main::checkDataSource (1110) Warning: Schema updated or no media found in the database, initiating scan.
    [18-02-22 19:32:10.0140] Plugins::Spotty::Plugin::getHelper (635) Didn't find Spotty helper application!
    [18-02-22 19:32:10.0511] Plugins::Spotty::API::getToken (125) Failed to get Spotify access token: malformed JSON string, neither array, object, number, string or atom, at character offset 0 (before "(end of string)") at /usr/local/slimserver/Cache/InstalledPlugins/Plugins/Spotty/API.pm line 122.

    [18-02-22 19:32:10.0545] Plugins::Spotty::API::getToken (142) Failed to get Spotify access token
    I am running PiCorePlayer v3.22 with LMS on the Pi ZeroW alongside the Squeezelite. The ONLY active LMS plugin is Spotty, all others removed. No media on Pi. I just want to run Spotify Connect from tablet or phone. The Connect service is announcing on the network.

    Things were running fine throughout the day as I made test plays at various times. Left it doing nothing for a few hours while I listened to another source on a Chromecast. Tried to go back to the Spotify Connect from android phone, and the player wasn't there. Found the logs as above.

    Any ideas ?

    Thanks for the great work mherger
    Attached Files Attached Files

  3. #413
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,874
    Quote Originally Posted by theonlyfoz View Post
    Anyways, what I am getting on the Pi ZeroW now is:
    Could you please ssh in to the pCP, cd /usr/local/slimserver/Cache/InstalledPlugins/Plugins/Spotty/Bin/arm-linux, then try to run all the binaries in there?

    I'm not sure, tbh, whether it's even supposed to run on the Zero: I think I gave up on the Pi1, considering it not a suitable platform anyway. Doesn't the Zero share the CPU with the Pi1 (plus a few MHz)?

    I must finally find some time to move the helper to the new librespot codebase. IIRC they have a change in there which should hopefully fix this issue.
    Michael

    http://www.herger.net/slim-plugins - Spotty, MusicArtistInfo

  4. #414
    Junior Member
    Join Date
    Oct 2017
    Posts
    6
    To be honest wasn't sure about the Zero although I did have it running an early Spotty (pre V2) on a Max2Play platform which only showed the usual problems (skipping tracks etc). I was hoping a lighter platform like pCP with Spotty V2.x.x would be OK, but it was always a trial. It ain't powerful and CPU goes quite busy when loading LMS and then when loading tracks as playing but after that is pretty easy. Bizarrely the last glitches I have had have been after idle periods when I don't use for a few hours and then come back. Doesn't seem to want to wake up or blows up. Anyways, what I now get when I try to restart the LMS server is:

    [ INFO ] Starting LMS...
    [ INFO ] [18-02-22 20:05:51.9753] main::init (387) Starting Logitech Media Server (v7.9.1, 1505480690, Fri Sep 15 22:32:08 UTC 2017) perl 5.024000 - arm-linux-gnueabihf-thread-multi-64int
    [18-02-22 20:05:52.0484] main::daemonize (947) Warning: Can't fork: Cannot allocate memory at /usr/local/slimserver/slimserver.pl line 947.

    Slimserver is not Running
    I'll put the pCP/LMS/Spotty mix back on to my Pi 3 and try that cable attached and wireless for a bit. The 2.4GHz wifi here is pretty congested and I don't know if congestion there might contribute, all my other stuff is on 5GHz.

  5. #415
    Junior Member
    Join Date
    Aug 2016
    Posts
    9

    Full rescan of library dropped Spotify connect

    Spotify connect via Spotty has worked like charm on my Max2play since 2.0. But when I cleared cache and rescanned my local music collection on LMS Spotify app refused to access my players. Only worked after reinstalling the Spotty plugin. Is there a connection or was it coincidentally?

  6. #416
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    1,330
    This maybe nothing to do with Spotty but webapi has appeared from nowhere in my "devices available" list. Any ideas?

    Sent from my SM-G900F using Tapatalk
    Edit. The webapi has now disappeared from the list.
    Last edited by slartibartfast; Today at 08:42.

  7. #417
    Junior Member
    Join Date
    Oct 2017
    Posts
    6
    Quote Originally Posted by theonlyfoz View Post
    I'll put the pCP/LMS/Spotty mix back on to my Pi 3 and try that cable attached and wireless for a bit. The 2.4GHz wifi here is pretty congested and I don't know if congestion there might contribute, all my other stuff is on 5GHz.
    Well the Pi 3 worked fine cable or wireless, then soon after I switched back to the rebuilt (again) Zerow it started stopping on it's own. So enough, life's too short, let us waste no more time, the ZeroW doesn't have the grunt for this.

    Thanks again for all your work.

  8. #418
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,874
    The log snippet you posted previously said:

    Can't fork: Cannot allocate memory
    The Zero probably just doesn't have the memory to run pCP, squeezelite, LMS and Spotty all at once.
    Michael

    http://www.herger.net/slim-plugins - Spotty, MusicArtistInfo

  9. #419
    Senior Member
    Join Date
    Sep 2007
    Location
    Aberdeen, UK
    Posts
    490
    Do I need a premium Spotify account to use this on LMS? I can see my LMS server listed (requiring "Spotify Authorization") on the "Connect to a device" screen on the Android app, but it's greyed-out and says "Premium users only". Won't let me select it. My Android and Windows apps are identified and work fine with the free account.

  10. #420
    Senior Member
    Join Date
    Oct 2009
    Location
    Olathe, Kansas, US
    Posts
    238
    Quote Originally Posted by majones View Post
    Do I need a premium Spotify account to use this on LMS? I can see my LMS server listed (requiring "Spotify Authorization") on the "Connect to a device" screen on the Android app, but it's greyed-out and says "Premium users only". Won't let me select it. My Android and Windows apps are identified and work fine with the free account.
    Yes. A premium Spotify account is required for LMS.

    Sent from my SAMSUNG-SM-G891A using Tapatalk

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •