Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 2 of 2

Hybrid View

  1. #1
    Junior Member
    Join Date
    Jan 2018
    Posts
    1

    first time LMS ARM install on Ubuntu 17.10 - HELP!!

    Hi everyone, and thanks for taking the time to help.

    I recently purchased a Rock64, and I'm now spending my free time trying to set up every server I have always wanted on it. Before this, i was new to Linux. Despite that, I set up my system to run Ubuntu 17.10 minimal, and have to use it in 32bit mode (ARM-HF) because there is really nothing available for ARM64 currently. ANYWAY - i'm having a heck of time trying to get LMS to even start up. I have installed the latest ARM nightly and I installed PERL from repositories. I have not received any error messages in the command line, but the web interface is not starting up. The log file just says over and over again "Logitech Media Server died. Restarting."

    Now, I have identified that the PERL version installed was "perl v5.26.0 built for arm-linux-gnueabihf-thread-multi-64int". From reading these message boards, I figured this version may not be compatible with LMS, so I installed perlbrew and an instance of 5.22.4 and ran "perlbrew switch" but that didnt seem to do anything. So I'm currently stumped and I'm hoping people here can help.

    1) Is the ARM version of LMS compatible with perl 5.26? If not, is that planned for anytime soon?
    2) I realize I'm probably missing essential perl modules, both in my system and perlbrew versions. Can anyone give me a list of the ones I need?
    3) any other pointers - things I'm not thinking of?

    Also, keep in mind that I'm still pretty much a newb. I have a MS in engineering, but i'm not a coder by any means. Please keep the lingo so i can understand it.

    Many thanks.

  2. #2
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,836
    Quote Originally Posted by rowmoney View Post
    1) Is the ARM version of LMS compatible with perl 5.26? If not, is that planned for anytime soon?
    No, we don't currently have support for Perl 5.26 on your platform. You'll have to build the modules yourself.

    * clone https://github.com/Logitech/slimserver-vendor
    * go down in to the CPAN folder
    * run the buildme.sh script
    Michael

    http://www.herger.net/slim-plugins - Spotty, MusicArtistInfo

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •