Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 6 of 6
  1. #1
    Junior Member
    Join Date
    Apr 2011
    Posts
    10

    Spotty + Spotify app

    I have LMS 7.9.0 - 1488878280 running on my Linux box. I also have Touch, Firmware: 7.8.0-r16754.

    Spotty works fine if I use the Squeeze Commander app (or the Touch interface). However, if I use the original Spotify app to play on "Devices available", my Touch is listed, but if I select it nothing happens.

    Nothing is displayed in the log so I'm wandering what to look for.

    Any ideas?

  2. #2
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,836

    Spotty + Spotify app

    > Nothing is displayed in the log so I'm wandering what to look for.

    You can set logging for plugin.spotty to INFO to get more information.

    --

    Michael

  3. #3
    Junior Member
    Join Date
    Apr 2011
    Posts
    10
    Quote Originally Posted by mherger View Post
    > Nothing is displayed in the log so I'm wandering what to look for.

    You can set logging for plugin.spotty to INFO to get more information.

    --

    Michael
    Thanks Michael.
    I did this and was instructed to install 7.9.1. So I downloaded and installed logitechmediaserver_7.9.1~1513951369_amd64.deb.

    Now things are a bit different: The Spotify app actually streams the song to my device, I see the seconds count (in 7.9.0 it was "stuck" and didn't move at all). However, nothing is displayed on the Touch and nothing plays.

    Best regards,
    -Snorri

  4. #4
    Junior Member
    Join Date
    Apr 2011
    Posts
    10
    Quote Originally Posted by Snyrkill View Post
    Thanks Michael.
    I did this and was instructed to install 7.9.1. So I downloaded and installed logitechmediaserver_7.9.1~1513951369_amd64.deb.

    Now things are a bit different: The Spotify app actually streams the song to my device, I see the seconds count (in 7.9.0 it was "stuck" and didn't move at all). However, nothing is displayed on the Touch and nothing plays.

    Best regards,
    -Snorri
    And to add: Nothing is displayed in the log when the songs stream.

  5. #5
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,836

    Spotty + Spotify app

    > And to add: Nothing is displayed in the log when the songs stream.
    But only in Connect mode? When selecting content through LMS, that would
    work? Sounds unlikely, but then...

    When you go to Settings/Advanced/Spotty, it would tell you what helper
    application and version it was using. What is it?

    --

    Michael

  6. #6
    Junior Member
    Join Date
    Apr 2011
    Posts
    10
    Quote Originally Posted by mherger View Post
    > And to add: Nothing is displayed in the log when the songs stream.
    But only in Connect mode? When selecting content through LMS, that would
    work? Sounds unlikely, but then...

    When you go to Settings/Advanced/Spotty, it would tell you what helper
    application and version it was using. What is it?

    --

    Michael
    Helper app is:
    /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/Spotty/Bin/i386-linux/spotty-x86_64 (v0.8.1)

    When I connect via LMS then stuff like this is displayed in the log:[18-01-09 18:22:33.4814] Plugins::Spotty::API::_call (1284) Trying to read from cache for browse/featured-playlists?country=IS&limit=50&locale=en_US&timesta mp=2018-01-09T18%3A20%3A00
    [18-01-09 18:22:33.4831] Plugins::Spotty::API::_call (1287) Returning cached data for browse/featured-playlists?country=IS&limit=50&locale=en_US&timesta mp=2018-01-09T18%3A20%3A00
    [18-01-09 18:22:33.4912] Plugins::Spotty::API::_call (1284) Trying to read from cache for me/albums?limit=50
    [18-01-09 18:22:33.5011] Plugins::Spotty::API::_call (1287) Returning cached data for me/albums?limit=50
    [18-01-09 18:22:33.5371] Plugins::Spotty::API::_call (1284) Trying to read from cache for albums/4f7U9Rycl2d3KMLoiEZtve?limit=50&market=from_token& offset=0
    [18-01-09 18:22:33.5377] Plugins::Spotty::API::_call (1287) Returning cached data for albums/4f7U9Rycl2d3KMLoiEZtve?limit=50&market=from_token& offset=0
    [18-01-09 18:22:33.5458] Plugins::Spotty::Plugin:urgeAudioCacheAfterXTracks (409) Played 1 song(s) since last audio cache purge.
    [18-01-09 18:22:33.5852] Plugins::Spotty::Plugin:urgeAudioCacheAfterXTracks (409) Played 2 song(s) since last audio cache purge.

    but nothing when I use the Spotify app.

    Thanks,
    -Snorri

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •