Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 2 of 2
  1. #1

    Now Playing Screen in Jivelite not showing up anymore

    Hi folks,

    I have a pCP 3.22 running on Pi 3 Model B with iQAudio DAC + and 7'' touchscreen with jivelite.

    Since updating to 3.22, I have a problem coming back regularly. After several days, the "Now Playing Screen" in Jivelite does not show up any more. Player works, different streams (TuneIn radio, own music from network drive, ...) can be played without a problem, and different remote Apps also work normal. Just Jivelite on the 7'' does not work any more. To fix, I have to reboot.

    In LMS logs, I found:

    [17-12-01 06:25:05.5263] Slim::Utils::Misc::msg (1250) Warning: [06:25:05.5187] Error reading: No space left on device (wanted 4096)

    But I have enough space on the drives. Partition of the SD card is big (1 GB), cache of LMS is on 4 GB ext4 formatted USB stick. Does not matter where the cache is (moved it back to the SD card or not).

    I also removed and reinstalled Jivelite plugin --> no success.

    Any ideas? Which log settings should I switch on to narrow this down? Thanks a lot.

  2. #2

    Squeezelite v.1.8.7-999 produces many errors: "File descriptor in bad state"


    I just wanted to report the solution to this issue.

    Squeezelite rev. 999 produced many of these error lines into the pcp_squeezelite.log:

    output_thread:701 start error: File descriptor in bad state

    This is as described here:


    Seems having to do with my hardware (iQaudio DAC+).

    After a few days up and running, the log was around 500MB large. I am not really sure what happens with such large log files because I thought piCorePlayer would not write to the SD card at all.

    But definetely, there was some limit at which parts of the system did not work any more, in all cases JiveLite could not show the Now Playing Screen any more, but sometimes also LMS crashed.

    Solution: One or both of the following two steps:

    1) Set Squeezelite logging level to "none" :-).
    2) Update Squeezelite to newest revision (v1.8.7-1007).

    Hope this helps for others having some (possibly strange) problems.

    BTW: I have another piCorePlayer installation without JiveLite and LMS. There, the log also was flushed with the same messages and stuck at some size limit, but player was still working.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts