Hi guys,

@mnvelocitypilot: If you are still experiencing issues, please head over to our support forums so I can make sure they do not reoccur. It seems indeed most likely, as already mentioned here, that you could have the wrong set of permissions for your mount point. On Max2Play's Filesystem Mount menu you should find an example value for the permissions parameter.

@Grumpy Bob: Yep, our current image is based on Raspbian Jessie, but we are currently working on a new Raspbian Stretch-based one. The settings you mentioned are displayed and editable in our Filesystem Mount plugin.

@everyone else: Thank you for stepping up and helping one of our users. In case I miss another topic here, you can also always send them to our forums