Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 16 FirstFirst 123412 ... LastLast
Results 11 to 20 of 159
  1. #11
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,833

    LogitechMediaServer for Qnapx86_64 with qts 4.2 or higher

    Hi digimaster

    thanks a lot for easing LMS installation on the QNAP! What I was
    wondering about is why the package would come with LMS pre-packaged?
    Couldn't you have a much smaller image which then would install whatever
    latest nightly? You mentioned it could be updated by providing a copy of
    the latest tarball. This way anyone would have the latest right from the
    start, without the need to download another image right away.

    --

    Michael

  2. #12
    Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    96
    Quote Originally Posted by mherger View Post
    Hi digimaster

    thanks a lot for easing LMS installation on the QNAP! What I was
    wondering about is why the package would come with LMS pre-packaged?
    Couldn't you have a much smaller image which then would install whatever
    latest nightly? You mentioned it could be updated by providing a copy of
    the latest tarball. This way anyone would have the latest right from the
    start, without the need to download another image right away.

    --

    Michael
    I looked at many ways, what would be the best solution.
    And look at the source of ssots, and where it went wrong there.
    And after testing, decided to included lms and perl.
    So it will work out of the box, and one can upgraded it.
    And it only depend on programs which are available in the software from Qnap.
    So it will keep work, even after a upgraded from Qnap.
    And through this way, is easy to do maintenance on a new release.

    But because I have include support for spotty, trying to included the lastet build from lms. To be sure that this plugin and other also work out of the box.

    I always try to look at the most simple way, one can make and install programs.
    this way, hope it will even work in five year's.
    Last edited by digimaster; 2017-12-02 at 01:37.

    maintainer of QLogitechMediaServer and Qnap-Optware-NG.

    Qnap TS-453a, with LogitechMediaSever 7.9.1 ( with spotty and youtube )
    Serval raspberry with hifiberry amp+ and picoreplayer.
    Love logitechmediaserver for it flexibel way, to play music from different sources.

  3. #13
    Junior Member
    Join Date
    Nov 2017
    Posts
    2
    Quote Originally Posted by digimaster View Post
    You can stop en start LogitechMediaServer form the app store, through the webgiu from QNap.
    Or logon through shh shell, and them do [ [cd /share/*/.qpkg/LogitechMediaServer/ ], [ ./LogitechMediaServer.sh restart ] and then exit to logout.
    Be aware it will take a few minutes, before you can use LogitechMediaServer through the webgui again, as the update has to be handled.


    QUOTE=Caladan;900245]Hi. I have just installed the LMS on my Qnap 451. Works perfectly . Thanks a lot for providing this QPKD.

    But I have a small question. How can I restart the server for making an update ?

    Thanks a lot for your reply.
    [/QUOTE]


    Thank you

  4. #14

    Qnap 259Pro+

    Quote Originally Posted by digimaster View Post
    Here you can downloaded the latest version of LogitechMediaServer for qnap QTS4.2 or higher.
    At the moment only support for x86_64. ( Needed more information on other arch from qnap )

    New release of LogitechMediaServer for Qnap x86_64 version 1.0

    Qnap LogitechMediaServer x86_64 version 1.0a

    ++++++++++++++++++++++++++++++++++++ Change log version 1.0a +++++++++++++++++++++++++
    Here it is the first officieel release of LogitechMediaServer for QNap x86_64 and QTS 4.2 or higher.
    * Check the serval script, and cleaned them up a bit
    * In version 1.0 there was a error on initscript, fixed and changed to version 1.0a
    * Spotty, Radio Paradiso and YouTube are supported. :-0
    * Runs on QNAP with QTS 4.2 or higher. ( tested on QTS 4.3.3 )
    * LMS will be installed in its orgineel way, like its suppled by the developers.
    * No need for a Optware/Entware to be installed.
    ( But a Optware/Entware, can add options like lame support, or add extra or better audio support. )
    * LMS is upgradeble, place logitechmediaserverXXXX.tgz in de Download share of the QNap. And restart the LMS. ( stop and start lms through the QNap app store )
    * Be aware, it some times can take some time, before the webgui is available. Especially when it needs to install serval plugins, or old prefs are copied in the slimserver directory.

    Included Software :

    Logitech Media Server Versie: 7.9.1 - 1503129892 @ Sat Aug 19 08:59:02 UTC 2017
    Perl 5.24.0
    Mozilla-CA-20160104
    Net-SSLeay-1.82 ( build with openssl-1.0.2m )
    IO-Socket-SSL-2.052
    JSON-2.90

    ++++++++++++++++++++++++++++++++++++++++++++++++++ ++++++++++++++++++++++++++++++

    Qnap LogitechMediaServer x86_64 version 1.0a


    LogitechMediaServer version 0.09z.beta

    LogitechMediaServer QNAP x86_64 0.09z.beta

    +++++++++++++++++++++++++++++++++ Changelog 0.09z.beta +++++++++++++++++++++++++++
    * Add support for the plugins spotty/youtube.
    * Add perl modules IO-Socket-SSL, Net-SSLeay, Mozilla-CA en JSON.
    * Already been tested by serval user, and it works great.

    - If its not working on you`re qnap, please let me know.
    -Please always test if you`re Qnap supports it, logon a ssh shel and do uname -m, then it should show x86_64 !
    ++++++++++++++++++++++++++++++++++++++++++++++++++ +++++++++++++++++++++++++++++
    Hi there, thrilled to have found this qpkg package but it failed to install on my Qnap 259Pro+? I have an Intel processor so why did it fail? Does it support Qnap 259Pro+? I would love to run this version on my QNAP as the latest version of Spotty does not work anymore on my SSOD installation. I am running 7.9.1 already.

    The error message was:
    Type Date Time Users Source IP Computer name Content
    Error 03-12-2017 10:29:35 System 127.0.0.1 localhost Wrong architecture: LogitechMediaServer 1.0a is built for x86_64

    Does it only work on 64bits processor? Qnap 259Pro+ has Intel Atom D525.

    Thanks in advance!
    Last edited by janus; 2017-12-03 at 02:39.

  5. #15

    uname -m

    Quote Originally Posted by janus View Post
    Hi there, thrilled to have found this qpkg package but it failed to install on my Qnap 259Pro+? I have an Intel processor so why did it fail? Does it support Qnap 259Pro+? I would love to run this version on my QNAP as the latest version of Spotty does not work anymore on my SSOD installation. I am running 7.9.1 already.

    The error message was:
    Type Date Time Users Source IP Computer name Content
    Error 03-12-2017 10:29:35 System 127.0.0.1 localhost Wrong architecture: LogitechMediaServer 1.0a is built for x86_64

    Does it only work on 64bits processor? Qnap 259Pro+ has Intel Atom D525.

    Thanks in advance!
    Sorry I didn't check with uname -m and it appers that my QNAP is not supported by your package... ;-( Maybe can you make it available in the future? Thank you very much!

  6. #16
    Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    96
    Quote Originally Posted by janus View Post
    Sorry I didn't check with uname -m and it appers that my QNAP is not supported by your package... ;-( Maybe can you make it available in the future? Thank you very much!
    At the moment it is only working on 86_64. Still looking for more information how to make it work on other arch used by Qnap. But that not easy, as I only own a Qnap ts-453a.

    maintainer of QLogitechMediaServer and Qnap-Optware-NG.

    Qnap TS-453a, with LogitechMediaSever 7.9.1 ( with spotty and youtube )
    Serval raspberry with hifiberry amp+ and picoreplayer.
    Love logitechmediaserver for it flexibel way, to play music from different sources.

  7. #17
    Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    96
    [B]New release of LogitechMediaServer for Qnap x86_64 version 1.01a

    ++++++++++++++++++++++++++++++++++++ Change log version 1.01a +++++++++++++++++++++++++
    * Add logfile function. It will write a logfile in the root directory of LogitechMediaServer.
    ( Can be very usefull and startup errors. )
    * Add more error options in the init-script, to get a better idea i`ve something goes wrong with the startup.
    * Upgraded LMS to nightly build Logitech Media Server Versie: 7.9.1 - 1511211491 @ Tue Nov 21 08:03:08 UTC 2017.
    ( To be sure that Spotty and YouTube support works. )
    * In version 1.01 there was a error, witch made LMS not startup from the appstore. In version 1.01a this is fixed.
    ================================================== ================================
    Last edited by digimaster; 2017-12-25 at 10:03. Reason: new release

    maintainer of QLogitechMediaServer and Qnap-Optware-NG.

    Qnap TS-453a, with LogitechMediaSever 7.9.1 ( with spotty and youtube )
    Serval raspberry with hifiberry amp+ and picoreplayer.
    Love logitechmediaserver for it flexibel way, to play music from different sources.

  8. #18
    Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    96
    I do apologize for version 1.01. After releasing it, noticed, that lms did not start from the Qnap webgui.
    So that's why I released the version 1.01a which has the problem fixed.
    Last edited by digimaster; 2017-12-25 at 10:03.

    maintainer of QLogitechMediaServer and Qnap-Optware-NG.

    Qnap TS-453a, with LogitechMediaSever 7.9.1 ( with spotty and youtube )
    Serval raspberry with hifiberry amp+ and picoreplayer.
    Love logitechmediaserver for it flexibel way, to play music from different sources.

  9. #19
    Senior Member
    Join Date
    Feb 2009
    Posts
    224
    Hi,

    I recently find that full text search plugin doesn't work with Unicode on my setup (469L with your qpkg). See thread here: http://forums.slimdevices.com/showth...upport-Unicode
    I have no idea whether it would in any way be related to the qpkg, but Michael doesn't have a problem with it on the original implementation, so I thought it might be a good idea to let you know as well. It's really not a big deal, and I'm truly grateful for your qpkg.

    Thanks.

  10. #20
    Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    96
    Quote Originally Posted by eduardoo View Post
    Hi,

    I recently find that full text search plugin doesn't work with Unicode on my setup (469L with your qpkg). See thread here: http://forums.slimdevices.com/showth...upport-Unicode
    I have no idea whether it would in any way be related to the qpkg, but Michael doesn't have a problem with it on the original implementation, so I thought it might be a good idea to let you know as well. It's really not a big deal, and I'm truly grateful for your qpkg.

    Thanks.
    I think that you must look at the settings of you're Qnap device. Think that something is causing this. Are you using some kind of Optware software?

    Logon a ssh shell and do set, and have a look at the local settings.

    maintainer of QLogitechMediaServer and Qnap-Optware-NG.

    Qnap TS-453a, with LogitechMediaSever 7.9.1 ( with spotty and youtube )
    Serval raspberry with hifiberry amp+ and picoreplayer.
    Love logitechmediaserver for it flexibel way, to play music from different sources.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •