Home of the Squeezebox™ & Transporter® network music players.
Page 4 of 5 FirstFirst ... 2345 LastLast
Results 31 to 40 of 48
  1. #31
    Senior Member
    Join Date
    Jun 2006
    Location
    Germany
    Posts
    576
    Hi,

    now I have analyzed all my songs and the Custom Search in LMSPlaylist seems to work.


    LMS Essentia does still not work. I have analyzed this a little bit more and it seems to be that there is something hardcoded when I analyze the network requests for this page:
    Code:
    15:12:32				script	http://raspi3-64:9000/plugins/LMSessentiaIntegration/js.html?_dc=1512223952925&args=%7B%22cmd%22%3A%22getAllTracks%22%7D&page=1&start=0&limit=25&callback=Ext.data.JsonP.callback1
    15:12:32				xhr	http://192.168.163.105:9001/plugins/LMSessentiaIntegration/html/classic.json?_dc=1512223952432
    15:12:32				xhr	http://raspi3-64:9000/plugins/LMSessentiaIntegration/js.html
    15:12:32				xhr	http://raspi3-64:9000/plugins/LMSessentiaIntegration/js.html
    15:12:31				css	http://192.168.163.105:9001/plugins/LMSessentiaIntegration/html/classic/resources/LMSessentiaIntegration-all_2.css
    15:12:31				css	http://192.168.163.105:9001/plugins/LMSessentiaIntegration/html/classic/resources/LMSessentiaIntegration-all_1.css
    15:12:31				script	http://192.168.163.105:9001/plugins/LMSessentiaIntegration/html/classic/app.js?_dc=20171129161442
    15:12:31				css	http://192.168.163.105:9001/plugins/LMSessentiaIntegration/html/app.css?_dc=20171129161442
    15:12:31				css	http://192.168.163.105:9001/plugins/LMSessentiaIntegration/html/classic/resources/LMSessentiaIntegration-all.css?_dc=20171129161442
    15:12:31		whitelisted	++	doc	http://192.168.163.105:9001/plugins/LMSessentiaIntegration/html/index.html?player=00:04:20:22:fe:94
    The 'raspi3-64:9000' won't result in any response in my network.

    I have changed the file app.js in ../cache/InstalledPlugins/Plugins/LMSessentiaIntegration/HTML/EN/plugins/LMSessentiaIntegration/html/classic/

    and replaced the raspi6-64:9000 with my server address and it is working now.

    This part should be replaced with the corresponding variables and it should work.

    I just have the problem, that Firefox is not working with the Webpage on my Laptop, while it is working on my wife's laptop.... Will check.

    Alex
    Last edited by mr_hyde; 2017-12-02 at 07:41.
    2 x Squeezebox 3 - 1 x Squeezebox Touch - Squeezecenter 7.9.1 / MusicIP in Container station - QNAP TS453A - 4 x 3 TB Hitachi (RAID5)

  2. #32
    Senior Member
    Join Date
    Aug 2012
    Location
    Austria
    Posts
    704
    Quote Originally Posted by mr_hyde View Post
    now I have analyzed all my songs and the Custom Search in LMSPlaylist seems to work.
    Well, that's good news...
    LMS Essentia does still not work. I have analyzed this a little bit more and it seems to be that there is something hardcoded when I analyze the network requests for this page:
    Thanks for investigating this issue, I've released a new version which hopefully fixes it.
    I just have the problem, that Firefox is not working with the Webpage on my Laptop, while it is working on my wife's laptop.... Will check.
    Same FF version? I have yet to test with FF 57...

  3. #33
    Senior Member
    Join Date
    Jun 2006
    Location
    Germany
    Posts
    576
    Quote Originally Posted by Roland0 View Post
    Well, that's good news...

    Thanks for investigating this issue, I've released a new version which hopefully fixes it.

    Same FF version? I have yet to test with FF 57...
    I have updated the version and it is working now.

    I am using FF57, but still no luck.

    The page was loading and the window with the information on an updated version opened. But it is not possible to click any of the buttons. The same is true for the LMS playlist plugin. ext4gui is working under FF57.

    It is not so important. I will look into this at a laer point of time.
    2 x Squeezebox 3 - 1 x Squeezebox Touch - Squeezecenter 7.9.1 / MusicIP in Container station - QNAP TS453A - 4 x 3 TB Hitachi (RAID5)

  4. #34
    Junior Member
    Join Date
    Sep 2017
    Location
    ┼kersberga, Sweden
    Posts
    13

    v0.0.4 saves the day :-)

    Thanks Roland0 for fixing this! The webgui LMS Essentia Integration now works on my LMS showing statistics and possibility to explore the new tracks attributes, the LMS Playlist Editor produce playlists based on Essentia attributes - with pleasant results. Great plugin :-)

    /Bosse
    Attached Images Attached Images  

  5. #35
    Senior Member
    Join Date
    Jun 2006
    Location
    Germany
    Posts
    576
    Hi,

    I have updated to 0.0.5 and this version brings back the issue that the plugin does not find/show any data.

    However, the requests go to the correct LMS server address. This points to a different problem.

    The playlist plugin does now also not find any essentia entries.

    The direct sql request on the database does still show the correct number of tracks.
    Last edited by mr_hyde; 2017-12-05 at 23:15.
    2 x Squeezebox 3 - 1 x Squeezebox Touch - Squeezecenter 7.9.1 / MusicIP in Container station - QNAP TS453A - 4 x 3 TB Hitachi (RAID5)

  6. #36
    Senior Member
    Join Date
    Aug 2012
    Location
    Austria
    Posts
    704
    Quote Originally Posted by mr_hyde View Post
    Hi,
    I have updated to 0.0.5 and this version brings back the issue that the plugin does not find/show any data.
    The playlist plugin does now also not find any essentia entries.
    The direct sql request on the database does still show the correct number of tracks.
    Very strange - the only change in the plugin was in a function not even used by the WebUI.
    Does the plugin even load at all? If you set the log to debug for the plugin, any messages?

  7. #37
    Senior Member
    Join Date
    Jun 2006
    Location
    Germany
    Posts
    576
    Quote Originally Posted by Roland0 View Post
    Very strange - the only change in the plugin was in a function not even used by the WebUI.
    Does the plugin even load at all? If you set the log to debug for the plugin, any messages?
    Hi, I have currently no access to the server. But I downgraded to 0.0.4 and it started working.

    Gesendet von meinem Moto G (5) Plus mit Tapatalk
    2 x Squeezebox 3 - 1 x Squeezebox Touch - Squeezecenter 7.9.1 / MusicIP in Container station - QNAP TS453A - 4 x 3 TB Hitachi (RAID5)

  8. #38
    Senior Member
    Join Date
    Aug 2012
    Location
    Austria
    Posts
    704
    Quote Originally Posted by mr_hyde View Post
    Hi, I have currently no access to the server. But I downgraded to 0.0.4 and it started working.
    I'd still appreciate it if you could check the logs for 0.0.5 when you have access again - others may have the same issue, and I'm unable to reproduce it on my setup.

  9. #39
    Senior Member
    Join Date
    Jun 2006
    Location
    Germany
    Posts
    576
    Quote Originally Posted by Roland0 View Post
    I'd still appreciate it if you could check the logs for 0.0.5 when you have access again - others may have the same issue, and I'm unable to reproduce it on my setup.
    Hi,

    the only thing I have found was this:
    Code:
    [17-12-06 07:05:35.6281] Plugins::LMSplaylistEditor::Plugin::initPlugin (107) ^plugins/LMSplaylistEditor/html/resources/fonts/OpenSans-Light.ttf => /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/LMSplaylistEditor/HTML/EN/plugins/LMSplaylistEditor/html/resources/fonts/OpenSans-Light.ttf
    [17-12-06 07:05:35.6285] Plugins::LMSplaylistEditor::Plugin::initPlugin (107) ^plugins/LMSplaylistEditor/html/resources/fonts/OpenSans-Bold.ttf => /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/LMSplaylistEditor/HTML/EN/plugins/LMSplaylistEditor/html/resources/fonts/OpenSans-Bold.ttf
    [17-12-06 07:05:35.6289] Plugins::LMSplaylistEditor::Plugin::initPlugin (107) ^plugins/LMSplaylistEditor/html/resources/font-awesome/fonts/fontawesome-webfont.ttf => /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/LMSplaylistEditor/HTML/EN/plugins/LMSplaylistEditor/html/resources/font-awesome/fonts/fontawesome-webfont.ttf
    [17-12-06 07:05:35.6293] Plugins::LMSplaylistEditor::Plugin::initPlugin (107) ^plugins/LMSplaylistEditor/html/resources/fonts/OpenSans-Regular.ttf => /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/LMSplaylistEditor/HTML/EN/plugins/LMSplaylistEditor/html/resources/fonts/OpenSans-Regular.ttf
    [17-12-06 07:05:35.6297] Plugins::LMSplaylistEditor::Plugin::initPlugin (107) ^plugins/LMSplaylistEditor/html/resources/fonts/DroidSans-webfont.woff => /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/LMSplaylistEditor/HTML/EN/plugins/LMSplaylistEditor/html/resources/fonts/DroidSans-webfont.woff
    [17-12-06 07:05:35.6302] Plugins::LMSplaylistEditor::Plugin::initPlugin (107) ^plugins/LMSplaylistEditor/html/classic.json.* => /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/LMSplaylistEditor/HTML/EN/plugins/LMSplaylistEditor/html/classic.json
    [17-12-06 07:05:35.6306] Plugins::LMSplaylistEditor::Plugin::initPlugin (113) LMSplaylistEditor initialized (v0.0.2)
    [17-12-06 07:05:35.6640] Plugins::SugarCube::Breakout::init (226) Initialising SugarCube Database
    [17-12-06 07:05:35.6663] Plugins::SugarCube::Breakout::init (240) Database tables are up to date
    [17-12-06 07:05:35.6668] Plugins::SugarCube::Breakout::init (245) Database tables are really up to date
    [17-12-06 07:05:35.7562] Plugins::TrackStat::Storage::refreshTracks (1242) TrackStat: Synchronizing TrackStat data, please wait...
    [17-12-06 07:05:47.3403] Plugins::TrackStat::Storage::refreshTracks (1891) TrackStat: Synchronizing TrackStat data finished
    [17-12-06 07:05:54.3729] Slim::Web::JSONRPC::requestMethod (443) 00:04:20:12:4d:7e: request not dispatchable!
    [17-12-06 07:06:50.1581] Plugins::LMSessentiaIntegration::Plugin::handleJSONP (208) handleJSONP args={'cmd' => 'getStats'}
    [17-12-06 07:06:50.1586] Plugins::LMSessentiaIntegration::Plugin::handleJSONP (298) processing time=1.7e-05
    [17-12-06 07:06:50.2037] Plugins::LMSessentiaIntegration::Plugin::handleJSONP (208) handleJSONP args={'cmd' => 'getAllTracks'}
    [17-12-06 07:06:50.2041] Plugins::LMSessentiaIntegration::Plugin::handleJSONP (298) processing time=1.5e-05
    [17-12-06 07:06:50.7621] Plugins::LMSessentiaIntegration::Plugin::handleJSONP (208) handleJSONP args={'cmd' => 'getStats'}
    with the error message in between:
    Code:
    [17-12-06 07:05:54.3729] Slim::Web::JSONRPC::requestMethod (443) 00:04:20:12:4d:7e: request not dispatchable!
    This message does not appear in version 0.0.4
    2 x Squeezebox 3 - 1 x Squeezebox Touch - Squeezecenter 7.9.1 / MusicIP in Container station - QNAP TS453A - 4 x 3 TB Hitachi (RAID5)

  10. #40
    Senior Member
    Join Date
    Jun 2006
    Location
    Germany
    Posts
    576
    Quote Originally Posted by mr_hyde View Post
    Code:
    [17-12-06 07:05:54.3729] Slim::Web::JSONRPC::requestMethod (443) 00:04:20:12:4d:7e: request not dispatchable!
    This message does not appear in version 0.0.4
    Issue is gone after re-installation of 0.0.5
    2 x Squeezebox 3 - 1 x Squeezebox Touch - Squeezecenter 7.9.1 / MusicIP in Container station - QNAP TS453A - 4 x 3 TB Hitachi (RAID5)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •