Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 18 12311 ... LastLast
Results 1 to 10 of 178
  1. #1
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,779

    [Announce] Radio Paradise Lossless Streaming (Plugin v2)

    Enjoy the lossless Radio Paradise stream right on your Squeezebox!

    Many Radio Paradise lovers were ecstatic when they heard about the lossless FLAC stream they have offered for a while. Unfortunately it's not available as a simple stream - thus not available on your beloved Squeezebox. No more! I've added support for the FLAC version of Radio Paradise to my plugin. The stream is available from My Apps/Radio Paradise.

    If you want to add it to a playlist or prefs, use the url "radioparadise://4.flac".

    Please note that for technical reasons outside my control this "stream" can be off by a few minutes, compared to the mp3 stream, or even the RP website. In most cases I've seen the FLAC version was ahead of the others.

    And one more important note: you'll need LMS 7.9.1 or the very latest 7.7.6 to enjoy the greatness of lossless Radio Paradise.

    Thanks Bill for providing me with the information required to make this happen!

    (oh, and if you like what you're hearing, don't forget to give Radio Paradise some "love" - they deserve it :-))

    Enjoy!

    Michael
    Last edited by mherger; 2017-11-06 at 07:57.
    Michael

    http://www.herger.net/slim-plugins - Spotty, MusicArtistInfo

  2. #2
    Senior Member SlimChances's Avatar
    Join Date
    Apr 2005
    Posts
    1,401
    Fantastic
    Thanks so much
    Logitech Media Server Version: 7.9.1 - 1504317335 @ Mon Sep 4 07:13:56 UTC 2017
    Operating system: Debian - EN - utf8 Platform Architecture: x86_64-linux
    Perl Version: 5.22.1 - x86_64-linux-gnu-thread-multi

    Database Version: DBD::SQLite 1.34_01 (sqlite 3.7.7.1)

    One SB Touch connected by Ethernet - Denon AVR -1912 Receiver, Paradigm 4.1 speakers
    Two SB Radios wireless

  3. #3
    Senior Member
    Join Date
    Oct 2009
    Posts
    147
    Wow!

    Big thanks

  4. #4
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    1,074
    Quote Originally Posted by Jackisidore View Post
    Wow!

    Big thanks
    Quote Originally Posted by SlimChances View Post
    Fantastic
    Thanks so much
    +1

    Sent from my SM-G900F using Tapatalk

  5. #5
    +1derful!

  6. #6
    Junior Member
    Join Date
    Oct 2017
    Posts
    5

    stopping and starting?

    HI - thanks so much for doing this, the sound quality is noticeably better than the 320k stream.

    However I've got a bit of a problem. Every couple of songs, the stream stops and starts again, it'll either go back to the beginning of the current song or possibly jump forward to the next one.

    I've updated LMS to the latest version, it's running on an HP microserver using WHS-2011, and the same thing happens with a normal squeezebox touch and also two raspberry Pi's. I was reading Bill's description of how they've got the Flac stream to work where he was talking about FLAC being a 'song based' method of encoding that they had to fool into playing as a stream, so I'm guessing it's something to do with that. Our broadband is pretty rock solid 150mb/s and I'm using Ethernet not wifi for all the players.

    Any ideas of how to fix, are there settings in LMS I should tweak?

    thanks
    Phil

  7. #7
    Senior Member
    Join Date
    Oct 2009
    Posts
    147
    Maybe a small bug:
    I noticed the now playing info (title, artist, cover etc) sometimes doesn't update. So I set the plugin logging to debug.

    A fresh start of RP playing shows a queue of 5 tracks (0-4) loaded. Track 0 shows correct now playing info. track 1 won't update now playing. Track 3 showed correct now playing. In the server log:

    [17-10-29 09:00:02.2607] Plugins::BookmarkHistory::Plugin::newsongCallback (1561) Trigger for newsong exists but is to old (to be expected when you press play after reconnect). client:Slim::Player::SqueezePlay=ARRAY(0x7ff5f5e98 9a8) time: 1509264002 trigger value:1509263229 requestlaylist newsong url:http://opml.radiotime.com/Tune.ashx?...70f96bfeb0df36

    track 4 didn't update now playing

    Track 4 ends and RP (Bill?) reads a short message with the RP cover. After that two blocks of tracks are loaded and the now playing is refreshed but different from what's playing (I think). the now playing doesn't change with the next track

    The sound quality is perfect and the stream plays flawless.

  8. #8
    Senior Member
    Join Date
    Dec 2005
    Location
    Sutton Coldfield, UK
    Posts
    529
    Excellent - thanks for the plugin.
    Music Store: Synology DS215J NAS
    Home Server/Player:
    LMS 7.9.1 on Pi 3B piCorePlayer v3.22 Server/IQAudio DAC+/Amp+
    Portable Server/Player: LMS 7.9.1 on HP-DV2700 Laptop/Ubuntu 17.10 with synced music drive.
    Homeplug LAN Players: Pi 3B piCorePlayer v3.22/HDMI/Jivelite, Squeezelite on Windows 10 PC
    UPNP Wifi Players: Chromecast Audio, Revo Super-Connect Radio, GGMM-E5 portable
    VPN Player: SqueezePlayer on Android Phone

  9. #9
    Quote Originally Posted by Jackisidore View Post
    Maybe a small bug:
    I noticed the now playing info (title, artist, cover etc) sometimes doesn't update. So I set the plugin logging to debug.

    A fresh start of RP playing shows a queue of 5 tracks (0-4) loaded. Track 0 shows correct now playing info. track 1 won't update now playing. Track 3 showed correct now playing. In the server log:

    [17-10-29 09:00:02.2607] Plugins::BookmarkHistory::Plugin::newsongCallback (1561) Trigger for newsong exists but is to old (to be expected when you press play after reconnect). client:Slim::Player::SqueezePlay=ARRAY(0x7ff5f5e98 9a8) time: 1509264002 trigger value:1509263229 requestlaylist newsong url:http://opml.radiotime.com/Tune.ashx?...70f96bfeb0df36

    track 4 didn't update now playing

    Track 4 ends and RP (Bill?) reads a short message with the RP cover. After that two blocks of tracks are loaded and the now playing is refreshed but different from what's playing (I think). the now playing doesn't change with the next track

    The sound quality is perfect and the stream plays flawless.

    Thanks very much Michael.

    Great sound and plays perfectly.............

    as with Jackisidore though now playing display not updating. (On Odroid XU4 Ubuntu 15.04 LMS 7.9.1, same on RPI 2 using Raspbian Jessie and LMS 7.9.1).

  10. #10
    Member
    Join Date
    Apr 2009
    Location
    Sheffield, UK
    Posts
    57

    Can't play the FLAC stream

    I'm on macOS HighSierra 10.13 with LMS 7.9.1 (LogitechMediaServer-7.9.1-1508904967).

    Playing Squeezelite on Safari web interface, I can play Something Different but not the Lossless stream.

    The current lossless song (with icon) appears in the playing screen but the song doesn't play. This happens with my hardware players too.

    Here's my server.log for info.

    server.log.zip

    Chris
    4 Booms, 2 Classics, 3 Radios, 1 Raspberry Pi.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •