Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 7 of 7
  1. #1
    Junior Member
    Join Date
    Oct 2017
    Posts
    2

    Buffering problem

    I have my Squeezebox Receiver / Controller combo for nearly 10 years. It worked flawless for years.

    Recently I started having buffering issues with internet streams (Radio/Deezer).

    For the last week my streams now buffer every 3-10 sec.

    I also noticed issues when playing from my library, but not to the same extend as with internet streams. It just seems a bit slower to respond ...

    I have tried everything I could think of ...

    - rebooted router (no network issues) - I can play streams via softsqueeze without running into buffering issues.
    - upgraded firmware (controller; not sure how to upgrade receiver - it is at 77).
    - re-installed LMS 7.7.5
    - upgraded LMS to 7.9.1
    - reset receiver
    - cleared preferences
    - tweaked network buffer settings (default 3, changed to 10 /30)
    - played streams via mysqueezebox

    Not sure what else I could do ...

    Any ideas?

    Philipp

  2. #2
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    3,302

    Buffering problem

    It very much sounds like a new neighbor is adding some wifi pollution. Did you try with the receiver wired?

    The fact that it happens locally as well but less often would confirm this. You might experience very long tcp blocking but locally you had the chance to have already sent a large piece of the audio (its http) where when streaming you have less available audio to send in bursts.

    I personally have experienced cases of 5-20 sec spent in a send() using tcp on wifi and that caused me a lot of grief on one of my plugins
    Last edited by philippe_44; 2017-10-23 at 10:09.
    LMS 7.7, 7.8 and 7.9 - 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB2. Sonos PLAY:3, PLAY:5, Marantz NR1603, JBL OnBeat, XBoxOne, XBMC, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, , Pi B3, B2, Pi B+, 2xPi A+, Odroid-C1, Odroid-C2, Cubie2, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5

  3. #3
    Senior Member
    Join Date
    Jan 2009
    Location
    Sor°, Denmark
    Posts
    601
    Quote Originally Posted by Philipp View Post
    I have my Squeezebox Receiver / Controller combo for nearly 10 years. It worked flawless for years.

    Recently I started having buffering issues with internet streams (Radio/Deezer).

    For the last week my streams now buffer every 3-10 sec.

    I also noticed issues when playing from my library, but not to the same extend as with internet streams. It just seems a bit slower to respond ...

    I have tried everything I could think of ...

    - rebooted router (no network issues) - I can play streams via softsqueeze without running into buffering issues.
    - upgraded firmware (controller; not sure how to upgrade receiver - it is at 77).
    - re-installed LMS 7.7.5
    - upgraded LMS to 7.9.1
    - reset receiver
    - cleared preferences
    - tweaked network buffer settings (default 3, changed to 10 /30)
    - played streams via mysqueezebox

    Not sure what else I could do ...

    Any ideas?

    Philipp
    Have you set soundsettings to "streaming through proxy??? This solves a lot of buffer problems... ?
    Attached Images Attached Images  
    Callesoroe
    Living room: Transporter, Tact RCS 2.2X digital preamp, Martin Logan Vista speakers, AMPS(Icepower): Acoustic Reality Ear Enigma PLUS(PANELS), Acoustic Reality Ear TWO MKII(Bas)
    Kitchen: Receiver - S.M.S.L DAC, Prodipe Pro 5 active bi-amp speakers. Bedroom: Receiver+UE boombox, Kids: Receiver+Active speakers, Office: Transporter, JBL LSR305 active speakers , TIDAL HIFI flac streaming.
    http://www.last.fm/user/callesoroe

  4. #4
    Junior Member
    Join Date
    Oct 2017
    Posts
    2
    Thank you guys for responding. Very much appreciated.

    I have traced the issue down to the Ethernet port (hybrid connection).

    My squeezebox works fine using wireless function. Happy days :-)

    Not sure whether it is the port on the receiver that failed or the switch the receiver is connected to.

    I think it may be the switch. Some of the ports seem to have failed, but not all. That's what got me ...

    While other devices connected to the switch seem to work fine the one other device I swapped cables with also has throughput issues. Oh well ...

    Thanks again for your help!

    Philipp

  5. #5
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    15,325
    Quote Originally Posted by callesoroe View Post
    Have you set soundsettings to "streaming through proxy??? This solves a lot of buffer problems... ?
    Proxied streaming will only affect internet streams - if the OP has problems with their local library it is more likely a wifi network issues.

  6. #6
    Senior Member
    Join Date
    Jan 2009
    Location
    Sor°, Denmark
    Posts
    601
    Quote Originally Posted by bpa View Post
    Proxied streaming will only affect internet streams - if the OP has problems with their local library it is more likely a wifi network issues.
    Yes I know. He also reported that the problem was with Deezer.......
    Callesoroe
    Living room: Transporter, Tact RCS 2.2X digital preamp, Martin Logan Vista speakers, AMPS(Icepower): Acoustic Reality Ear Enigma PLUS(PANELS), Acoustic Reality Ear TWO MKII(Bas)
    Kitchen: Receiver - S.M.S.L DAC, Prodipe Pro 5 active bi-amp speakers. Bedroom: Receiver+UE boombox, Kids: Receiver+Active speakers, Office: Transporter, JBL LSR305 active speakers , TIDAL HIFI flac streaming.
    http://www.last.fm/user/callesoroe

  7. #7
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    15,325
    Quote Originally Posted by callesoroe View Post
    Yes I know. He also reported that the problem was with Deezer.......
    He said he also had "issues" with library but wasn't specific - so I wanted to clarify to the OP the limitations of "proxied streaming"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •